summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-22 12:02:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-22 12:04:18 +0100
commit13dccb31fad613f7d2d3edb279d372974d47062a (patch)
tree9056515eb82c2e2631a04c7bfe97425fd04e3fde
parentdev-python/GitPython: Remove old (diff)
downloadgentoo-13dccb31fad613f7d2d3edb279d372974d47062a.tar.gz
gentoo-13dccb31fad613f7d2d3edb279d372974d47062a.tar.bz2
gentoo-13dccb31fad613f7d2d3edb279d372974d47062a.zip
dev-python/pytest-mock: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.11.1.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 4dbcca6fe769..4c553742bff7 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,2 +1 @@
-DIST pytest-mock-3.11.1.tar.gz 31251 BLAKE2B 26655487947d614483f082f17c9f3a9fc2688c016d07c6d4c4e34c369f87f3d914cf82d966a655e1eee501088d27d711f1b65f0c777678254dcfffa5c8c7585f SHA512 f52147498657d35f4616ea788b500a68ffcf1c2c066047fb973308b54e11bd7fe5a3961115bab99ae6858000ebb68b35cc489e81221a0bd26afae8426092ff6b
DIST pytest-mock-3.12.0.tar.gz 32139 BLAKE2B 4bc2289579686b8ca9e840440b21b7299817e803f108726692cda6f1a138564462b04b9ae6a3038a5e36ec4d665bb7c8f54c26d231d6b17188b8d830d553b20d SHA512 6da429e646a4e3a825f699969dbc87033136918bd9aa111ff334fac324e5ac89ef6516e82ffeeb20cb6a857fbbe904d8ee985acefba2d2b7bd0ffe4b9227ad82
diff --git a/dev-python/pytest-mock/pytest-mock-3.11.1.ebuild b/dev-python/pytest-mock/pytest-mock-3.11.1.ebuild
deleted file mode 100644
index 21e83bfc0670..000000000000
--- a/dev-python/pytest-mock/pytest-mock-3.11.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_TESTED=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-mock/
- https://pypi.org/project/pytest-mock/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
- local EPYTEST_DESELECT=()
-
- if has_version dev-python/mock; then
- EPYTEST_DESELECT+=(
- tests/test_pytest_mock.py::test_standalone_mock
- )
- fi
-
- epytest --assert=plain
-}