summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-19 08:05:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-19 08:57:15 +0200
commit13fdccec940de268d07a014d72034626177ab380 (patch)
treea557cb9d39f8e17a9ec447d5e8ee5d00424bb6d5
parentdev-python/mkdocs-redirects: Bump to 1.2.1 (diff)
downloadgentoo-13fdccec940de268d07a014d72034626177ab380.tar.gz
gentoo-13fdccec940de268d07a014d72034626177ab380.tar.bz2
gentoo-13fdccec940de268d07a014d72034626177ab380.zip
dev-python/click: Bump to 8.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/click/Manifest1
-rw-r--r--dev-python/click/click-8.1.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index 6028acac0569..3672b77b25c5 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1,3 +1,4 @@
DIST click-8.1.3.gh.tar.gz 333961 BLAKE2B ed80d9be1e5740f1e4af62e97cd78488dc99d59da4a6dc9c99fb62b08c32ca2b889e3678a2841052922d102d8ac83df19e3e2d0ff41c46387e695d3718c7702d SHA512 29194ee3877e013a2fe1037870522c5b5a78136ca60da9109f29312a3e52c767867f5eec2d90ca385cd0508f77555b9d6ad8f5141dc31900ddc9307a2207a818
DIST click-8.1.4.gh.tar.gz 340493 BLAKE2B 953e4033a1715ec631bec197f62d1015de28579e0cf3c3ee8fab1941a60797130d12e752aea5dc210cbedea1735cc6fa517eaf9f88836599a9135f42368bb603 SHA512 3095990cdbaa01a61fa5d84f6a80c03a9c645c81ac569f66a4b23ba06e37ba79a5c9fcc6f09a7b8bed1082cb17c0381743c5a160ae14634f102b7f29175e739b
DIST click-8.1.5.gh.tar.gz 341669 BLAKE2B fb3b1f8551ee79f4f6f8719133d370947c3ee1448ca95735cd9499f36a22cc93b25a87db40aa33aebbc196209236f458040f4012d7c1ae7adaa304999a3c1675 SHA512 55171a5f16643305c6d9b038ff6c72bdfbbdeb4c39e7dbc04618fceba2345b2a4d69925d3490ea5a974be4101c8b1f4c0dd3b247d9b050506bb92a6a7d6334cb
+DIST click-8.1.6.gh.tar.gz 341538 BLAKE2B 611619665a95be2ae590c2fdad403bc834fd43665df4418ab0fa5e55b4ea90600db8a1710e5c77bda3dc1a77e6b53393a52225730a4fe4bb874076569e4b1d96 SHA512 ae31e4b5666b7ab6638a12fd12088c5b5311a4f6913e3471aefdf2392cf47d4be6e745e09070d6f2e382fa92c4068c196e0109295d86953dd066f7619dfbd4cd
diff --git a/dev-python/click/click-8.1.6.ebuild b/dev-python/click/click-8.1.6.ebuild
new file mode 100644
index 000000000000..0cf462f36528
--- /dev/null
+++ b/dev-python/click/click-8.1.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+HOMEPAGE="
+ https://palletsprojects.com/p/click/
+ https://github.com/pallets/click/
+ https://pypi.org/project/click/
+"
+SRC_URI="
+ https://github.com/pallets/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinxcontrib-log-cabinet \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}