summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-02-09 20:29:21 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-02-09 20:29:21 +0700
commit15e5feccebbe15d18d58dbf883f12878dc4a8316 (patch)
tree3f3be32b678b9c8965474f189a3865a1229b2cb8
parentsci-geosciences/gpxsee: remove old versions (diff)
downloadgentoo-15e5feccebbe15d18d58dbf883f12878dc4a8316.tar.gz
gentoo-15e5feccebbe15d18d58dbf883f12878dc4a8316.tar.bz2
gentoo-15e5feccebbe15d18d58dbf883f12878dc4a8316.zip
sci-mathematics/wxmaxima: bump to 24.02.0
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-24.02.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index d128affc414d..f1eb8547b536 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,3 +1,4 @@
DIST wxmaxima-23.07.0.tar.gz 16427247 BLAKE2B c754e476adcf71b2074e5d20edc14ac0d81f453d2cfc1f69fb281c0e3290cf31487ee2772624f868bb1057c19e1dac3cee6bd402d2b7e8b35f1ef8e80c7611f5 SHA512 0b94443b2fa31c7f75f33d57285c5086e69f43abd53d2a66b78d946d5370982b5b3a2a53fc5c4b4631fec94453b6f94a209d7ba3d13b1518dbe597d62b7e4690
DIST wxmaxima-23.10.0.tar.gz 16466027 BLAKE2B 496765bfe55efb168396530eb3c44ef727f0398bf30a32e9a869c48572f0b53b6d851a7d8aa421199c071791efec37dece6cc23901826c62ca7ab6715a27b0cc SHA512 4055595f8e294726d2731da4a926844d3ad25561bb7d392c0ef08eb9322bc7e454edb6ae137eb7b8c2be53aba2f36abb0a0b32e03af4cc9a517130fd5466a1fb
DIST wxmaxima-23.12.0.tar.gz 16491009 BLAKE2B 1df61e6571302b9ae693af77b48c60d3799f036f2e5214ef5f003e4b9f20fa66a37ed10f52b35ac05e114e9a53afda761262bdf55dde86020687f69f5458ec78 SHA512 f0b8f17cd9e367fbd95dd9304926742b05ab6d04da07aed54b183d5fa97a5d0054481626182874daf54011bd3f2d3f4b467b1daf600d003976483331578eed89
+DIST wxmaxima-24.02.0.tar.gz 16485036 BLAKE2B 7994f126f975ae6ed801f6856cbf918302d67729d24a9057a709986c3c5e56c9d48793e32421da6c208a6ebcd571bac952175d81a931d3be264ddc2b336bfb52 SHA512 a64cf2c1024232df89d45c0a45eb59c62eeddd28a4bfb14765c1c7eca90fb3ce01fb681f7e65140243909afd34c95d399906afae1d11603f35f452e8831ec9d1
diff --git a/sci-mathematics/wxmaxima/wxmaxima-24.02.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-24.02.0.ebuild
new file mode 100644
index 000000000000..3fbeb1a253b0
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-24.02.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test webkit"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit?]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ -DWXM_DISABLE_WEBVIEW=$(usex webkit OFF ON)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}