summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-04-08 23:08:40 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-04-08 23:08:40 +0100
commit1669592bf97679ca6a94f4bc466b3e8acd540a5d (patch)
treea0e8f4998fe00e91683d084a4cf8f4fd64425e62
parentsys-cluster/kube-scheduler: add 1.26.3 (diff)
downloadgentoo-1669592bf97679ca6a94f4bc466b3e8acd540a5d.tar.gz
gentoo-1669592bf97679ca6a94f4bc466b3e8acd540a5d.tar.bz2
gentoo-1669592bf97679ca6a94f4bc466b3e8acd540a5d.zip
games-util/slade: Bump to 3.2.2, fix Wayland
Keeping the old version because the map editor doesn't render properly for me under the new version. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-util/slade/Manifest1
-rw-r--r--games-util/slade/files/slade-3.2.2-wayland.patch25
-rw-r--r--games-util/slade/slade-3.2.1-r1.ebuild1
-rw-r--r--games-util/slade/slade-3.2.2.ebuild80
4 files changed, 107 insertions, 0 deletions
diff --git a/games-util/slade/Manifest b/games-util/slade/Manifest
index bb06ceb8def6..71d47f925a43 100644
--- a/games-util/slade/Manifest
+++ b/games-util/slade/Manifest
@@ -1 +1,2 @@
DIST slade-3.2.1.tar.gz 6471666 BLAKE2B 17a4f2ec23699a56d4fd970605d7141d3f4593f7ced6fff205c87d9ecddc7b90e6da2991aeea32bd008e24cdfee95b7c16946f78b2701c94e51266afd78863d6 SHA512 b7d5a91c759c5a68af63aa9a8412452a5b2986e70f7189ca92ee99ce4953ef47381be907c8ce1166e479f24679904bf5f0e0b1a5da846fe7873c5b97f4315449
+DIST slade-3.2.2.tar.gz 6479812 BLAKE2B 2394f8f1e858a2f96e625cbf68a983d235e96a055c2fba7b99e79475e84bc43a9fce49bac1fadd6d5a5cfcf68f59f92ee61272def54962ec251a9441ca03c357 SHA512 4fd73f36df4800873154329222a382f9051f0d61aba1d7061e48b0350b5ab68066e5c484dd3200a118f254be5cb7b86dad7fa3a757556243bd5c8af5ea89d638
diff --git a/games-util/slade/files/slade-3.2.2-wayland.patch b/games-util/slade/files/slade-3.2.2-wayland.patch
new file mode 100644
index 000000000000..4207ceb2076d
--- /dev/null
+++ b/games-util/slade/files/slade-3.2.2-wayland.patch
@@ -0,0 +1,25 @@
+SFML's render window only supports X11 under Linux, so SLADE crashes if GDK
+chooses the Wayland backend. This patch tells GDK to prefer the X11 backend.
+SLADE 3.3.0 will apparently not use the render window.
+
+diff --git a/src/Application/SLADEWxApp.cpp b/src/Application/SLADEWxApp.cpp
+index 3dadf241..de01e340 100644
+--- a/src/Application/SLADEWxApp.cpp
++++ b/src/Application/SLADEWxApp.cpp
+@@ -52,6 +52,16 @@
+ using namespace slade;
+
+
++#ifdef __WXGTK__
++#include <gdk/gdk.h>
++
++struct PreferX11 {
++ PreferX11() { gdk_set_allowed_backends("x11,*"); }
++};
++static PreferX11 preferx11;
++#endif
++
++
+ // -----------------------------------------------------------------------------
+ //
+ // Variables
diff --git a/games-util/slade/slade-3.2.1-r1.ebuild b/games-util/slade/slade-3.2.1-r1.ebuild
index 285ef98db6f9..75ed0c04389d 100644
--- a/games-util/slade/slade-3.2.1-r1.ebuild
+++ b/games-util/slade/slade-3.2.1-r1.ebuild
@@ -48,6 +48,7 @@ S="${WORKDIR}/${PN^^}-${MY_PV}"
PATCHES=(
"${FILESDIR}"/${PN}-3.2.0-bundled-libs.patch
"${FILESDIR}"/${PN}-3.2.0_beta2-fluidsynth-driver.patch
+ "${FILESDIR}"/${PN}-3.2.2-wayland.patch
)
src_prepare() {
diff --git a/games-util/slade/slade-3.2.2.ebuild b/games-util/slade/slade-3.2.2.ebuild
new file mode 100644
index 000000000000..48395e6d88fa
--- /dev/null
+++ b/games-util/slade/slade-3.2.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..3} )
+WX_GTK_VER="3.2-gtk3"
+
+inherit cmake lua-single wxwidgets
+
+MY_PV="${PV/beta/b}"
+DESCRIPTION="Modern editor for Doom-engine based games and source ports"
+HOMEPAGE="https://slade.mancubus.net/"
+SRC_URI="https://github.com/sirjuddington/${PN^^}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="fluidsynth timidity webkit"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+DEPEND="
+ ${LUA_DEPS}
+ app-arch/bzip2:=
+ dev-libs/libfmt:=
+ >=media-libs/dumb-2:=
+ media-libs/freeimage[jpeg,png,tiff]
+ media-libs/glew:0=
+ media-libs/libsfml:=
+ media-sound/mpg123
+ net-misc/curl
+ sys-libs/zlib
+ x11-libs/wxGTK:${WX_GTK_VER}[opengl,webkit?,X]
+ fluidsynth? ( media-sound/fluidsynth:= )
+"
+
+RDEPEND="
+ ${DEPEND}
+ timidity? ( media-sound/timidity++ )
+"
+
+BDEPEND="
+ app-arch/p7zip
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN^^}-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.0_beta2-fluidsynth-driver.patch
+ "${FILESDIR}"/${PN}-3.2.2-wayland.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Delete bundled libraries just in case.
+ rm -r thirdparty/dumb/ thirdparty/fmt/ || die
+
+}
+
+src_configure() {
+ local luav=$(lua_get_version)
+
+ local mycmakeargs=(
+ -DLua_FIND_VERSION_MAJOR=$(ver_cut 1 "${luav}")
+ -DLua_FIND_VERSION_MINOR=$(ver_cut 2 "${luav}")
+ -DLua_FIND_VERSION_COUNT=2
+ -DLua_FIND_VERSION_EXACT=ON
+ -DNO_COTIRE=ON
+ -DNO_FLUIDSYNTH=$(usex fluidsynth OFF ON)
+ -DNO_WEBVIEW=$(usex webkit OFF ON)
+ -DUSE_SFML_RENDERWINDOW=ON
+ -DUSE_SYSTEM_DUMB=ON
+ -DUSE_SYSTEM_FMT=ON
+ -DWX_GTK3=ON
+ )
+
+ setup-wxwidgets
+ cmake_src_configure
+}