summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-16 14:56:20 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-16 15:37:30 +0100
commit16720393feaf7c8d76817072cfdb0a03463a8631 (patch)
treea5bb35fe837aaa43769dba7c8c60eb3f87add7b0
parentdev-python/strict-rfc3339: Set DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-16720393feaf7c8d76817072cfdb0a03463a8631.tar.gz
gentoo-16720393feaf7c8d76817072cfdb0a03463a8631.tar.bz2
gentoo-16720393feaf7c8d76817072cfdb0a03463a8631.zip
dev-python/bz2file: Set DISTUTILS_USE_SETUPTOOLS, EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/bz2file/bz2file-0.98.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/bz2file/bz2file-0.98.ebuild b/dev-python/bz2file/bz2file-0.98.ebuild
index 3b741c619575..b4c5026de847 100644
--- a/dev-python/bz2file/bz2file-0.98.ebuild
+++ b/dev-python/bz2file/bz2file-0.98.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python2_7 pypy )
+
inherit distutils-r1
DESCRIPTION="Replacement for bz2.BZ2File with features from newest CPython"
@@ -16,5 +18,5 @@ KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x64-cy
IUSE=""
python_test() {
- "${PYTHON}" test_bz2file.py -v || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" test_bz2file.py -v || die "Tests fail with ${EPYTHON}"
}