summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-15 22:06:19 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-15 22:07:56 +0200
commit17b38bb4fca9724972ad0e3a67fe1313debaf573 (patch)
treee21948722ad0054ac6fa9aa658de489a88c65d8c
parentmedia-video/hasciicam: Remove last-rited pkg (diff)
downloadgentoo-17b38bb4fca9724972ad0e3a67fe1313debaf573.tar.gz
gentoo-17b38bb4fca9724972ad0e3a67fe1313debaf573.tar.bz2
gentoo-17b38bb4fca9724972ad0e3a67fe1313debaf573.zip
net-libs/ftplib: Remove last-rited pkg
Closes: https://bugs.gentoo.org/520026 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-libs/ftplib/Manifest3
-rw-r--r--net-libs/ftplib/files/ftplib-4.0-crash.patch116
-rw-r--r--net-libs/ftplib/ftplib-3.1.1.ebuild43
-rw-r--r--net-libs/ftplib/ftplib-4.0-r1.ebuild45
-rw-r--r--net-libs/ftplib/ftplib-4.0.ebuild36
-rw-r--r--net-libs/ftplib/metadata.xml7
-rw-r--r--profiles/package.mask8
7 files changed, 0 insertions, 258 deletions
diff --git a/net-libs/ftplib/Manifest b/net-libs/ftplib/Manifest
deleted file mode 100644
index e7d7949ed742..000000000000
--- a/net-libs/ftplib/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST ftplib-4.0.tar.gz 66680 BLAKE2B a4a2ca6df725daaeec226c7dfe4b165e7a8e1c5317d681a0137056b89bbfc448c83e15278696062d9bda83b62c58dfa5f0a52b83817f2a642805b03a403bd08f SHA512 ff39c243a6acbb67a8d2779f34b59f69f45d578ea3976c14aee1abcc56bf16cbbc6518ba96a4ccf34f6dd469eef388043caf066858b8df24bebfab7ab30a1c62
-DIST ftplib_3.1-1-9.debian.tar.gz 8560 BLAKE2B c9a1a487bbf260cbdac5c3c5fef04a3e059414805e3528339d8bb37d37ed3a84c8858552ad6b8b48d1034c412d912933c04631ec5379d32148ba3508b10999f3 SHA512 c87fb17bca4616d85f064f718161071b35a0e3f1c84ce8f13b4cd9f9b75f5115a4c518680d77af240196f0b2ee5eff520e0d4a0b87c797554c1ee8caa4962e07
-DIST ftplib_3.1-1.orig.tar.gz 90724 BLAKE2B 4aabc71dae317801c3754979b48fa04871c6f6b5b332037d5606dbe669d64c82b057560656a5e2f8a792d4a3ae4597fc873f471d4e10f52e8a25ef6c41687249 SHA512 5a0116ce1526f77532ced94c00bc1199378da1e1707c86637c83c6e9a27fef3a290bfefb7fc537946219587625b39560399cf136b83878a7829a2f3bee5f926f
diff --git a/net-libs/ftplib/files/ftplib-4.0-crash.patch b/net-libs/ftplib/files/ftplib-4.0-crash.patch
deleted file mode 100644
index c984e2d81b19..000000000000
--- a/net-libs/ftplib/files/ftplib-4.0-crash.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-include sys/select.h for the select() prototype on unix systems.
-
-fix warning about using chars as subscripts in arrays. on many systems, isdigit
-turns into an index of an array, so the pnum char needs to be casted to an int.
-the spec says these funcs take an int, not a char.
-
-fix warnings about the rv return value being uninitialized in FtpAcceptConnection.
-
-fix a crasher in FtpClose where it derefs the ctrl pointer before checking
-if it's NULL.
-
-fix the FtpQuit API to return 0/1 as it's documented so the caller can detect.
-
-patch by Mike Frysinger <vapier@gentoo.org>
-
---- a/src/ftplib.c
-+++ b/src/ftplib.c
-@@ -31,6 +32,7 @@
- #if defined(__unix__)
- #include <sys/time.h>
- #include <sys/types.h>
-+#include <sys/select.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <netdb.h>
-@@ -453,7 +456,7 @@ GLOBALDEF int FtpConnect(const char *hos
- pnum = "ftp";
- else
- *pnum++ = '\0';
-- if (isdigit(*pnum))
-+ if (isdigit((int)*pnum))
- sin.sin_port = htons(atoi(pnum));
- else
- {
-@@ -841,7 +862,7 @@ static int FtpAcceptConnection(netbuf *n
- int i;
- struct timeval tv;
- fd_set mask;
-- int rv;
-+ int rv = 0;
-
- FD_ZERO(&mask);
- FD_SET(nControl->handle, &mask);
-@@ -858,14 +879,12 @@ static int FtpAcceptConnection(netbuf *n
- sizeof(nControl->response));
- net_close(nData->handle);
- nData->handle = 0;
-- rv = 0;
- }
- else if (i == 0)
- {
- strcpy(nControl->response, "timed out waiting for connection");
- net_close(nData->handle);
- nData->handle = 0;
-- rv = 0;
- }
- else
- {
-@@ -885,7 +904,6 @@ static int FtpAcceptConnection(netbuf *n
- strncpy(nControl->response, strerror(i),
- sizeof(nControl->response));
- nData->handle = 0;
-- rv = 0;
- }
- }
- else if (FD_ISSET(nControl->handle, &mask))
-@@ -893,7 +911,6 @@ static int FtpAcceptConnection(netbuf *n
- net_close(nData->handle);
- nData->handle = 0;
- readresp('2', nControl);
-- rv = 0;
- }
- }
- return rv;
-@@ -1054,10 +1054,11 @@ GLOBALDEF int FtpClose(netbuf *nData)
- net_close(nData->handle);
- ctrl = nData->ctrl;
- free(nData);
-- ctrl->data = NULL;
-- if (ctrl && ctrl->response[0] != '4' && ctrl->response[0] != 5)
-+ if (ctrl)
- {
-- return(readresp('2', ctrl));
-+ ctrl->data = NULL;
-+ if (ctrl->response[0] != '4' && ctrl->response[0] != 5)
-+ return readresp('2', ctrl);
- }
- return 1;
- case FTPLIB_CONTROL:
-@@ -1442,12 +1443,13 @@ GLOBALDEF int FtpDelete(const char *fnm, netbuf *nControl)
- *
- * return 1 if successful, 0 otherwise
- */
--GLOBALDEF void FtpQuit(netbuf *nControl)
-+GLOBALDEF int FtpQuit(netbuf *nControl)
- {
- if (nControl->dir != FTPLIB_CONTROL)
-- return;
-+ return 0;
- FtpSendCmd("QUIT",'2',nControl);
- net_close(nControl->handle);
- free(nControl->buf);
- free(nControl);
-+ return 1;
- }
---- a/src/ftplib.h
-+++ b/src/ftplib.h
-@@ -111,7 +111,7 @@ GLOBALREF int FtpPut(const char *input, const char *path, char mode,
- netbuf *nControl);
- GLOBALREF int FtpRename(const char *src, const char *dst, netbuf *nControl);
- GLOBALREF int FtpDelete(const char *fnm, netbuf *nControl);
--GLOBALREF void FtpQuit(netbuf *nControl);
-+GLOBALREF int FtpQuit(netbuf *nControl);
-
- #ifdef __cplusplus
- };
diff --git a/net-libs/ftplib/ftplib-3.1.1.ebuild b/net-libs/ftplib/ftplib-3.1.1.ebuild
deleted file mode 100644
index 51a887e92428..000000000000
--- a/net-libs/ftplib/ftplib-3.1.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils multilib toolchain-funcs versionator
-
-DEB_REV=9
-MY_PV=$(replace_version_separator 2 -)
-
-DESCRIPTION="A set of routines that implement the FTP protocol"
-HOMEPAGE="http://nbpfaus.net/~pfau/ftplib/"
-DEB_URI="mirror://debian/pool/main/f/${PN}"
-SRC_URI="${DEB_URI}/${PN}_${MY_PV}.orig.tar.gz
- ${DEB_URI}/${PN}_${MY_PV}-${DEB_REV}.debian.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-src_prepare() {
- epatch "${WORKDIR}"/debian/patches/{check-getservbyname-failure,fix-ascii-read-without-eol}
-
- sed -i \
- -e '/shared/s:$(CC):$(CC) $(LDFLAGS):' \
- -e 's:/usr/local:$(DESTDIR)/usr:' \
- -e '/^LDFLAGS/s:=:+=:' \
- -e "s:/lib:/$(get_libdir):" \
- linux/Makefile || die
-}
-
-src_compile() {
- tc-export CC
- emake -C linux DEBUG="${CFLAGS}"
-}
-
-src_install() {
- dodir /usr/bin /usr/include /usr/$(get_libdir)
- emake -C linux DESTDIR="${D}" install
- dodoc additional_rfcs CHANGES ftplib.lsm NOTES README* RFC959.txt TODO
-}
diff --git a/net-libs/ftplib/ftplib-4.0-r1.ebuild b/net-libs/ftplib/ftplib-4.0-r1.ebuild
deleted file mode 100644
index 9d3e7f9c5192..000000000000
--- a/net-libs/ftplib/ftplib-4.0-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit multilib multilib-minimal toolchain-funcs eutils
-
-DESCRIPTION="A set of routines that implement the FTP protocol"
-HOMEPAGE="http://nbpfaus.net/~pfau/ftplib/"
-SRC_URI="http://nbpfaus.net/~pfau/ftplib/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-src_prepare() {
- sed -i \
- -e '/shared/s:$(CC):$(CC) $(LDFLAGS):' \
- -e 's:/usr/local:$(DESTDIR)/usr:' \
- -e '/^LDFLAGS/s:=:+=:' \
- -e "s:/lib:/$(get_libdir):" \
- -e '/ar -rcs/s:ar:$(AR):' \
- src/Makefile || die
- epatch "${FILESDIR}"/${PN}-4.0-crash.patch
-
- multilib_copy_sources
-}
-
-multilib_src_compile() {
- emake -C src \
- DEBUG="${CFLAGS} ${CPPFLAGS}" \
- AR="$(tc-getAR)" \
- CC="$(tc-getCC)"
-}
-
-multilib_src_install() {
- dodir /usr/bin /usr/include /usr/$(get_libdir)
- emake -C src DESTDIR="${ED}" install
-}
-
-multilib_src_install_all() {
- dodoc additional_rfcs CHANGES README* RFC959.txt
- dohtml html/*
-}
diff --git a/net-libs/ftplib/ftplib-4.0.ebuild b/net-libs/ftplib/ftplib-4.0.ebuild
deleted file mode 100644
index 11dcd2fe2bd0..000000000000
--- a/net-libs/ftplib/ftplib-4.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils multilib toolchain-funcs versionator
-
-DESCRIPTION="A set of routines that implement the FTP protocol"
-HOMEPAGE="http://nbpfaus.net/~pfau/ftplib/"
-SRC_URI="http://nbpfaus.net/~pfau/ftplib/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-src_prepare() {
- sed -i \
- -e '/shared/s:$(CC):$(CC) $(LDFLAGS):' \
- -e 's:/usr/local:$(DESTDIR)/usr:' \
- -e '/^LDFLAGS/s:=:+=:' \
- -e "s:/lib:/$(get_libdir):" \
- -e '/ar -rcs/s:ar:$(AR):' \
- src/Makefile || die
-}
-
-src_compile() {
- tc-export AR CC
- emake -C src DEBUG="${CFLAGS} ${CPPFLAGS}"
-}
-
-src_install() {
- dodir /usr/bin /usr/include /usr/$(get_libdir)
- emake -C src DESTDIR="${ED}" install
- dodoc additional_rfcs CHANGES README* RFC959.txt
- dohtml html/*
-}
diff --git a/net-libs/ftplib/metadata.xml b/net-libs/ftplib/metadata.xml
deleted file mode 100644
index 106575f01e53..000000000000
--- a/net-libs/ftplib/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>media-video@gentoo.org</email>
- </maintainer>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 30b38ae9aa26..9398751510e4 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -526,14 +526,6 @@ app-emacs/prom-wl
# Removal in 30 days. Bug #601742.
net-analyzer/gnu-netcat
-# Michał Górny <mgorny@gentoo.org> (13 Apr 2019)
-# net-libs/ftplib: Unmaintained. The ebuild suffers build failures due
-# to broken multilib conversion. Last bumped in 2014, and needs local
-# patches to even work. Obscure library with only two revdeps.
-#
-# Removal in 30 days. Bug #520026.
-net-libs/ftplib
-
# Hans de Graaff <graaff@gentoo.org> (13 Apr 2019)
# Old ruby24-only slots of Rails-related packages
# These no longer have reverse dependencies or newer