summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-20 08:00:30 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-04-24 05:19:50 -0400
commit17d493d3641774d998b8d0b15086881203e3e977 (patch)
tree499c1654b9a3c1aa2e4d30881ada4748b7698661
parentsys-devel/autogen: epatch->PATCHES=() (diff)
downloadgentoo-17d493d3641774d998b8d0b15086881203e3e977.tar.gz
gentoo-17d493d3641774d998b8d0b15086881203e3e977.tar.bz2
gentoo-17d493d3641774d998b8d0b15086881203e3e977.zip
sys-devel/gdb: add explicit epatch
Also some formatting changes to keep the ebuild's aligned in layout, sort eclasses. Package-Manager: Portage-2.3.31, Repoman-2.3.9 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--sys-devel/gdb/gdb-8.0.1-r1.ebuild6
-rw-r--r--sys-devel/gdb/gdb-8.0.1.ebuild10
-rw-r--r--sys-devel/gdb/gdb-8.0.ebuild6
-rw-r--r--sys-devel/gdb/gdb-8.1-r1.ebuild6
-rw-r--r--sys-devel/gdb/gdb-8.1.ebuild6
5 files changed, 19 insertions, 15 deletions
diff --git a/sys-devel/gdb/gdb-8.0.1-r1.ebuild b/sys-devel/gdb/gdb-8.0.1-r1.ebuild
index f2a93879b156..f2de213b735c 100644
--- a/sys-devel/gdb/gdb-8.0.1-r1.ebuild
+++ b/sys-devel/gdb/gdb-8.0.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit flag-o-matic eutils python-single-r1
+inherit epatch eutils flag-o-matic python-single-r1
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -53,8 +53,8 @@ PATCH_DEV="slyfox"
DESCRIPTION="GNU debugger"
HOMEPAGE="https://sourceware.org/gdb/"
SRC_URI="${SRC_URI}
- ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${P}-patches-${PATCH_VER}.tar.xz}
- ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}
+ ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${PN}-8.0.1-patches-${PATCH_VER}.tar.xz}
+ ${PATCH_VER:+mirror://gentoo/${PN}-8.0.1-patches-${PATCH_VER}.tar.xz}
"
LICENSE="GPL-2 LGPL-2"
diff --git a/sys-devel/gdb/gdb-8.0.1.ebuild b/sys-devel/gdb/gdb-8.0.1.ebuild
index 6e1aa11c9e28..c961c9df536d 100644
--- a/sys-devel/gdb/gdb-8.0.1.ebuild
+++ b/sys-devel/gdb/gdb-8.0.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit flag-o-matic eutils python-single-r1
+inherit epatch eutils flag-o-matic python-single-r1
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -49,9 +49,13 @@ case ${PV} in
esac
PATCH_VER=""
+PATCH_DEV=""
DESCRIPTION="GNU debugger"
HOMEPAGE="https://sourceware.org/gdb/"
-SRC_URI="${SRC_URI} ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}"
+SRC_URI="${SRC_URI}
+ ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${PN}-8.0.1-patches-${PATCH_VER}.tar.xz}
+ ${PATCH_VER:+mirror://gentoo/${PN}-8.0.1-patches-${PATCH_VER}.tar.xz}
+"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
diff --git a/sys-devel/gdb/gdb-8.0.ebuild b/sys-devel/gdb/gdb-8.0.ebuild
index 825036422890..5ceaef605501 100644
--- a/sys-devel/gdb/gdb-8.0.ebuild
+++ b/sys-devel/gdb/gdb-8.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit flag-o-matic eutils python-single-r1
+inherit epatch eutils flag-o-matic python-single-r1
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
diff --git a/sys-devel/gdb/gdb-8.1-r1.ebuild b/sys-devel/gdb/gdb-8.1-r1.ebuild
index cd7fc728f51e..cd11a56608a9 100644
--- a/sys-devel/gdb/gdb-8.1-r1.ebuild
+++ b/sys-devel/gdb/gdb-8.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit flag-o-matic eutils python-single-r1
+inherit epatch eutils flag-o-matic python-single-r1
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -53,8 +53,8 @@ PATCH_DEV="slyfox"
DESCRIPTION="GNU debugger"
HOMEPAGE="https://sourceware.org/gdb/"
SRC_URI="${SRC_URI}
- ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${P}-patches-${PATCH_VER}.tar.xz}
- ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}
+ ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${PN}-8.1-patches-${PATCH_VER}.tar.xz}
+ ${PATCH_VER:+mirror://gentoo/${PN}-8.1-patches-${PATCH_VER}.tar.xz}
"
LICENSE="GPL-2 LGPL-2"
diff --git a/sys-devel/gdb/gdb-8.1.ebuild b/sys-devel/gdb/gdb-8.1.ebuild
index 6ad71b2755ad..cd11a56608a9 100644
--- a/sys-devel/gdb/gdb-8.1.ebuild
+++ b/sys-devel/gdb/gdb-8.1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit flag-o-matic eutils python-single-r1
+inherit epatch eutils flag-o-matic python-single-r1
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -53,8 +53,8 @@ PATCH_DEV="slyfox"
DESCRIPTION="GNU debugger"
HOMEPAGE="https://sourceware.org/gdb/"
SRC_URI="${SRC_URI}
- ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${PN}-8.0.1-patches-${PATCH_VER}.tar.xz}
- ${PATCH_VER:+mirror://gentoo/${PN}-8.0.1-patches-${PATCH_VER}.tar.xz}
+ ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${PN}-8.1-patches-${PATCH_VER}.tar.xz}
+ ${PATCH_VER:+mirror://gentoo/${PN}-8.1-patches-${PATCH_VER}.tar.xz}
"
LICENSE="GPL-2 LGPL-2"