summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-21 19:10:46 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-28 20:29:22 +0200
commit18b6ffd44d141a080e4d036f914d590e1fb495f4 (patch)
tree7f835d46f34ca394ce612496a0c66fb13d2daaf2
parentdev-java/plexus-classworlds: add 2.6.0 (diff)
downloadgentoo-18b6ffd44d141a080e4d036f914d590e1fb495f4.tar.gz
gentoo-18b6ffd44d141a080e4d036f914d590e1fb495f4.tar.bz2
gentoo-18b6ffd44d141a080e4d036f914d590e1fb495f4.zip
dev-java/hawtjni-runtime: add 1.18
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/26510 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/hawtjni-runtime/Manifest1
-rw-r--r--dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-java/hawtjni-runtime/Manifest b/dev-java/hawtjni-runtime/Manifest
index fb7445899281..473ef1cdabf5 100644
--- a/dev-java/hawtjni-runtime/Manifest
+++ b/dev-java/hawtjni-runtime/Manifest
@@ -1 +1,2 @@
DIST hawtjni-project-1.15.tar.gz 1606236 BLAKE2B 52357dbefde43ec82cf218ada90642d118ebaa6a6be173cc1f4f48377fda95b902f0a90dfb60822c02c144b9bf13d0800c94d67cc2f9c76e607bbbb80a80898e SHA512 1a93658bf8621c770cf97b546c6a5c0cf1821b06cb16dbc872ad0c830c599d3947ffe56b4cca16217a510d4e929ebcfc5eabdf4ad4364f5225b53d22c7d48abb
+DIST hawtjni-project-1.18.tar.gz 1615093 BLAKE2B a195bcfb7c213ec4451605f62a1ab3546b7fa160a03d8c6c1a77a58e103481a196845d924d9f1a08cc2a17dfd71f9428f69a64983df00333cc00435c7dde2e5d SHA512 beeacd92c9b4fef413cb2d339041042ffd79fe7cb62c4fa3bcc8c2d758402183a5806ebd0ee91754f9f0025f4115022c71705e8f6330f2fa8b8cead774a30bf0
diff --git a/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild b/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
new file mode 100644
index 000000000000..13748884cb64
--- /dev/null
+++ b/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID=""
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A JNI code generator based on the generator used by the Eclipse SWT project"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/hawtjni-project-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {changelog,notice,readme}.md )
+
+S="${WORKDIR}/hawtjni-hawtjni-project-${PV}"
+
+JAVA_AUTOMATIC_MODULE_NAME="org.fusesource.hawtjni.runtime"
+JAVA_SRC_DIR="${PN}/src/main/java"