summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-01-18 17:03:50 -0500
committerSam James <sam@gentoo.org>2024-01-24 06:54:39 +0000
commit198d1cae195f4d8807f3092933bc9a45a939207b (patch)
treefbb66397bdd0324fda31e9c0f1003a3185718d34
parentnet-misc/ntpsec: migrate checking for enabled lto, to tc-is-lto (diff)
downloadgentoo-198d1cae195f4d8807f3092933bc9a45a939207b.tar.gz
gentoo-198d1cae195f4d8807f3092933bc9a45a939207b.tar.bz2
gentoo-198d1cae195f4d8807f3092933bc9a45a939207b.zip
app-office/libreoffice: migrate checking for enabled lto, to tc-is-lto
This toolchain func was recently added, and is a lot more reliable than get-flagq, for example if the active flags contain `-flto -fno-lto` then tc-is-lto gets it correct. We would rather use this wherever possible. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-office/libreoffice/libreoffice-7.5.9.2.ebuild2
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/app-office/libreoffice/libreoffice-7.5.9.2.ebuild b/app-office/libreoffice/libreoffice-7.5.9.2.ebuild
index e8a4b6d5ca4e..c5269a7e3134 100644
--- a/app-office/libreoffice/libreoffice-7.5.9.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.5.9.2.ebuild
@@ -580,7 +580,7 @@ src_configure() {
myeconfargs+=( --with-rhino-jar=$(java-pkg_getjar rhino-1.6 rhino.jar) )
fi
- is-flagq "-flto*" && myeconfargs+=( --enable-lto )
+ tc-is-lto && myeconfargs+=( --enable-lto )
MARIADBCONFIG="$(type -p $(usex mariadb mariadb mysql)_config)" \
econf "${myeconfargs[@]}"
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 3d488003abe7..46798bb521b1 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -572,7 +572,7 @@ src_configure() {
myeconfargs+=( --with-rhino-jar=$(java-pkg_getjar rhino-1.6 rhino.jar) )
fi
- is-flagq "-flto*" && myeconfargs+=( --enable-lto )
+ tc-is-lto && myeconfargs+=( --enable-lto )
MARIADBCONFIG="$(type -p $(usex mariadb mariadb mysql)_config)" \
econf "${myeconfargs[@]}"