summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-02 08:06:23 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-02 09:05:05 -0400
commit1aade741f33c06bc029b153b4b5a56a46068e1dc (patch)
tree0928b8a0e71c304875b1046f472155e6df61fa8d
parentdev-qt/qtshadertools: add 6.7.0 (diff)
downloadgentoo-1aade741f33c06bc029b153b4b5a56a46068e1dc.tar.gz
gentoo-1aade741f33c06bc029b153b4b5a56a46068e1dc.tar.bz2
gentoo-1aade741f33c06bc029b153b4b5a56a46068e1dc.zip
dev-qt/qtspeech: add 6.7.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtspeech/Manifest1
-rw-r--r--dev-qt/qtspeech/qtspeech-6.7.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/Manifest b/dev-qt/qtspeech/Manifest
index d1b73e67d123..83ad85398e83 100644
--- a/dev-qt/qtspeech/Manifest
+++ b/dev-qt/qtspeech/Manifest
@@ -4,3 +4,4 @@ DIST qtspeech-everywhere-opensource-src-5.15.12.tar.xz 104816 BLAKE2B 8a64688c8e
DIST qtspeech-everywhere-opensource-src-5.15.13.tar.xz 104612 BLAKE2B 3c35098f0d4f4b4f804808f3d11abc0c0d189e3883cb1d15ea9b350948e061125299df1207ad44ed7af207c417980b0360ab6b44733efbbe7e5bdac6fe2402b5 SHA512 43b97ddc333d1c4a9715b1c306ced0506eb8faf69f1d22500b74e509d33b5a5cb9d0c166b9211a32a78eaba57925195d8ba0c39c8ae6a15551f841426294c75f
DIST qtspeech-everywhere-src-6.6.2.tar.xz 262008 BLAKE2B 6d9ae5b42f96fa02a15ac82e9e1c6a378c3b0ceccd278af9ef99346ad79a256e41d1d2ae10cfef75f311bdfad457271357b09fd067ddc902bff3e4ee31eda12e SHA512 e43793931b81bb86cc074a2153ec0160991c86bc255ea1b11e5b4a272b8d067fcfc6788261d4b2f6f7630eadbcab7be23249b980d2792cb9a109137af614601e
DIST qtspeech-everywhere-src-6.6.3.tar.xz 261976 BLAKE2B 839adf366d268f2872b321d16546fc953d2e3fa6724f76061fb44674d06a0dba949f171d67f528707d071a7b94f0097f4d6e0fa25ca902572477476d3f4872fc SHA512 4a43e1895ae477f6b6890a36ba2da365420e7778dece26535642ead39aab39c0c10d3be1c78a5b823eaddc646bdb60c5bd16bf3ac02f279832bc9724cfedc5d2
+DIST qtspeech-everywhere-src-6.7.0.tar.xz 261732 BLAKE2B a7e99c3c9efdaa7aa5d44537b9aaaed87af0607daa6b6ab21d602594081f5bcc5ead4da9eebbee15a7cc735a36e80cfa312452f2cdfa5ce4136bd0c06797eba2 SHA512 10d086633da8cc478619023baa4d2495bb394aa30e7ba7141b0e698ade5a4a723f5643a5df64e9920b90251e89722598b7d5b720d7b8d3a04449e94fd5984f82
diff --git a/dev-qt/qtspeech/qtspeech-6.7.0.ebuild b/dev-qt/qtspeech/qtspeech-6.7.0.ebuild
new file mode 100644
index 000000000000..52d658ae0a12
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-6.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Text-to-speech library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+IUSE="flite qml +speechd"
+# can build with neither, but then it is just mock tts and may be confusing
+REQUIRED_USE="|| ( flite speechd )"
+
+# TODO: tests are known failing with clang and needs looking into, albeit
+# it is still usable at runtime save for applications segfaulting on exit
+# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
+# of this). Restricting because also seen this result in hanging. Note that
+# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
+# status on new major versions.
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6
+ ~dev-qt/qtmultimedia-${PV}:6
+ flite? ( app-accessibility/flite )
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ speechd? ( app-accessibility/speech-dispatcher )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ $(qt_feature flite)
+ $(qt_feature speechd)
+
+ # flite_alsa was likely to work around old issues in flite, it does
+ # nothing but add -lasound (no code change, and is unneeded)
+ -DQT_FEATURE_flite_alsa=OFF
+ )
+
+ qt6-build_src_configure
+}