summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-13 21:19:20 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-13 21:49:42 +0200
commit1c479c9eb50d03e9d11aecb3ef9f8847eb0f25b5 (patch)
treec3b761b2df0059bb5eaec8056ebb25a163096872
parentgames-emulation/zsnes: add more stack realignment annotations (diff)
downloadgentoo-1c479c9eb50d03e9d11aecb3ef9f8847eb0f25b5.tar.gz
gentoo-1c479c9eb50d03e9d11aecb3ef9f8847eb0f25b5.tar.bz2
gentoo-1c479c9eb50d03e9d11aecb3ef9f8847eb0f25b5.zip
app-emulation/fuse: drop 1.5.7
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-emulation/fuse/Manifest1
-rw-r--r--app-emulation/fuse/files/multiple-definition.patch13
-rw-r--r--app-emulation/fuse/fuse-1.5.7.ebuild81
3 files changed, 0 insertions, 95 deletions
diff --git a/app-emulation/fuse/Manifest b/app-emulation/fuse/Manifest
index 62b174565f78..127daceb5a37 100644
--- a/app-emulation/fuse/Manifest
+++ b/app-emulation/fuse/Manifest
@@ -1,2 +1 @@
-DIST fuse-1.5.7.tar.gz 1634568 BLAKE2B 9d2f3c310132dc57336995c31adeb37d727506719d1089b2009a2f44cbfa59fc9c4e9252aeff64cdd22b7326328518b5da33af51be687f321b891b9d1dd2b646 SHA512 ac11e03fc203f98433253fb72d7700cf6285ad8662147f318bb4ceda3888bc865b80d85473a3b2bda9e0971989b1579fc928f41ddabbf01d58358362066be13d
DIST fuse-1.6.0.tar.gz 1686171 BLAKE2B d1e6b166f2f649f408349b16a5eb40dd414750ed7a805eb6505b6c81be6ed7bcaa4e6f0b14057645172add1b1a77881f90b64767390fe1a64a486168f452d29d SHA512 5096b24b5b3d812942a7ad401b886b6a99f5493686912cb4aff18ede65404ae97a9bcafa6337aaed4378382f2a170918797d7d4570bb809476be5aa9fc625b8b
diff --git a/app-emulation/fuse/files/multiple-definition.patch b/app-emulation/fuse/files/multiple-definition.patch
deleted file mode 100644
index 8a8e9d7d1758..000000000000
--- a/app-emulation/fuse/files/multiple-definition.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -Naur fuse-1.5.7/ui/widget/widget.c fuse-1.5.7-patched/ui/widget/widget.c
---- fuse-1.5.7/ui/widget/widget.c 2018-08-06 15:36:04.000000000 +0200
-+++ fuse-1.5.7-patched/ui/widget/widget.c 2020-09-20 15:27:42.045382588 +0200
-@@ -90,9 +90,6 @@
-
- static widget_recurse_t widget_return[10]; /* The stack to recurse on */
-
--/* The settings used whilst playing with an options dialog box */
--settings_info widget_options_settings;
--
- static int widget_read_font( const char *filename )
- {
- utils_file file;
diff --git a/app-emulation/fuse/fuse-1.5.7.ebuild b/app-emulation/fuse/fuse-1.5.7.ebuild
deleted file mode 100644
index 063ecf27471a..000000000000
--- a/app-emulation/fuse/fuse-1.5.7.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
-HOMEPAGE="http://fuse-emulator.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa ao backend-fbcon backend-sdl backend-svga backend-X gpm joystick memlimit png xml"
-
-# Only one UI back-end can be enabled at a time
-REQUIRED_USE="?? ( backend-fbcon backend-sdl backend-svga backend-X )"
-
-RDEPEND="
- >=app-emulation/libspectrum-1.4.4
- dev-libs/glib:2
- alsa? ( media-libs/alsa-lib )
- ao? ( media-libs/libao )
- backend-sdl? ( media-libs/libsdl )
- backend-svga? ( media-libs/svgalib )
- backend-X? ( x11-libs/libX11 x11-libs/libXext )
- !backend-fbcon? ( !backend-sdl? ( !backend-svga? ( !backend-X? ( x11-libs/gtk+:3 ) ) ) )
- gpm? ( sys-libs/gpm )
- joystick? ( !backend-sdl? ( media-libs/libjsw ) )
- png? ( media-libs/libpng:0= sys-libs/zlib )
- xml? ( dev-libs/libxml2:2 )"
-DEPEND="${RDEPEND}
- backend-fbcon? ( virtual/linux-sources )
- dev-lang/perl
- virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog README THANKS )
-
-PATCHES=(
- "${FILESDIR}"/multiple-definition.patch
- "${FILESDIR}"/remove-local-prefix.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- --without-win32
- $(use_with alsa)
- $(use_with ao libao)
- $(use_with gpm)
- $(use_with joystick)
- $(use_enable memlimit smallmem)
- $(use_with png)
- $(use_with xml libxml2)
- )
-
- if use backend-sdl; then
- myconf+=("--with-sdl")
- elif use backend-X; then
- myconf+=("--without-gtk")
- elif use backend-svga; then
- myconf+=("--with-svgalib")
- elif use backend-fbcon; then
- myconf+=("--with-fb")
- else
- myconf+=("--with-gtk")
- fi
-
- use joystick && myconf+=( $(use_enable backend-sdl ui-joystick) )
-
- econf "${myconf[@]}"
-}
-
-src_test() {
- emake test
-}