summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2024-02-29 23:04:10 +0100
committerNicolas Bock <nicolasbock@gentoo.org>2024-03-03 10:38:13 -0700
commit1d6ad5b5bd862872ca7165c8f8bbf4aab1a0addf (patch)
tree851ead37c06fb4aa5459f4a625c2b863fee136ca
parentsys-cluster/charliecloud: add 0.37 (diff)
downloadgentoo-1d6ad5b5bd862872ca7165c8f8bbf4aab1a0addf.tar.gz
gentoo-1d6ad5b5bd862872ca7165c8f8bbf4aab1a0addf.tar.bz2
gentoo-1d6ad5b5bd862872ca7165c8f8bbf4aab1a0addf.zip
sys-cluster/charliecloud: drop 0.35
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.35.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index c427ba6ae95e..8bdd1ce5d5df 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,3 +1,2 @@
-DIST charliecloud-0.35.tar.gz 585756 BLAKE2B ade539aa3f94055f84e1b6de73d0bea7739ab764c31399f25adbff82faa62c3ee7e8745aa74bb6e997d6723d002780339f48be8d7218462d3eb95ad119a2b8a8 SHA512 40f5e5891f0df8379b637c26c3d86b66a61b48ee1e7985260b47aa4abeffc77c3690af59ae38072b53f6dd348da4574249187ba922fc7c03fb74a513524dc08a
DIST charliecloud-0.36.tar.gz 604778 BLAKE2B 671c7a95be7a0d3e772e3a02185f15c5e00df6d84f0c6a068b6ac2268eaf471c3dc8a9a445036110b564e44b906e4c1ba090474e0f75653d6e24a6270f2c332b SHA512 411fc4eded6d557460ef4688ee123c54939fdeea6799c7176f136d494986a643c4ef3cadc8079e995374a7988c73d32d160d6a3094e8184b491cb1985a18facd
DIST charliecloud-0.37.tar.gz 612391 BLAKE2B 595052118fce06d542c5fe315663ff2bb6de1743646ac396f006760fb761b1d794b57065851cdf3c54acce54817c6242d40386d1aeae0999f4f927da3a97069b SHA512 5e7402435520b1558c855bce31d9debd1ce338718070a016b744e2a87ee7f7811b3de46cb7f8ea82187b7c7df0288bf87376fe8f543340a9474737d62f68826c
diff --git a/sys-cluster/charliecloud/charliecloud-0.35.ebuild b/sys-cluster/charliecloud/charliecloud-0.35.ebuild
deleted file mode 100644
index 197f766fead6..000000000000
--- a/sys-cluster/charliecloud/charliecloud-0.35.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit autotools optfeature python-single-r1
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
- S="${WORKDIR}/${P}"
-else
- SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~x86-linux"
-fi
-
-DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
-HOMEPAGE="https://hpc.github.io/charliecloud/"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-IUSE="ch-image doc"
-
-# Extensive test suite exists, but downloads container images
-# directly and via Docker and installs packages inside using apt/yum.
-# Additionally, clashes with portage namespacing and sandbox.
-RESTRICT="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- elibc_musl? ( sys-libs/argp-standalone )
-"
-DEPEND="
- ch-image? (
- $(python_gen_cond_dep '
- dev-python/lark[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- dev-vcs/git
- net-misc/rsync
- )
- doc? (
- $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
- ')
- net-misc/rsync
- )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local econf_args=(
- $(use_enable doc html)
- $(use_enable ch-image)
- # Libdir is used as a libexec-style destination.
- --libdir="${EPREFIX}"/usr/lib
- # Attempts to call python-exec directly otherwise.
- --with-sphinx-python="${EPYTHON}"
- # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
- --enable-buggy-build
- # Do not use bundled version of dev-python/lark.
- --disable-bundled-lark
- # Use correct shebang.
- --with-python="${PYTHON}"
- )
- econf "${econf_args[@]}"
-}
-
-src_install() {
- docompress -x "${EPREFIX}"/usr/share/doc/"${PF}"/examples
- default
-}
-
-pkg_postinst() {
- elog "Various builders are supported, as alternative to the internal ch-image."
- optfeature "Building with Buildah" app-containers/buildah
- optfeature "Building with Docker" app-containers/docker
- optfeature "Building with Podman" app-containers/podman
- optfeature "Progress bars during long operations" sys-apps/pv
- optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
- optfeature "Mount and umount squashfs images" sys-fs/squashfuse
- optfeature "Build versioning with ch-image" dev-vcs/git
-}