summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-07 16:46:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-07 17:32:46 +0200
commit1f0b0cd2275f59107d084aff6b2d926c2fb5f453 (patch)
tree9cc6cae93f947bd94d5ea64312ff4f4b07b19201
parentdev-ros/roscreate: Remove old (diff)
downloadgentoo-1f0b0cd2275f59107d084aff6b2d926c2fb5f453.tar.gz
gentoo-1f0b0cd2275f59107d084aff6b2d926c2fb5f453.tar.bz2
gentoo-1f0b0cd2275f59107d084aff6b2d926c2fb5f453.zip
dev-ros/roscreate: fix tests
Closes: https://bugs.gentoo.org/624928 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/roscreate/roscreate-1.15.6.ebuild5
-rw-r--r--dev-ros/roscreate/roscreate-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-ros/roscreate/roscreate-1.15.6.ebuild b/dev-ros/roscreate/roscreate-1.15.6.ebuild
index 34cd94cd1e66..5a077c7eb99f 100644
--- a/dev-ros/roscreate/roscreate-1.15.6.ebuild
+++ b/dev-ros/roscreate/roscreate-1.15.6.ebuild
@@ -20,3 +20,8 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/roscreate/roscreate-9999.ebuild b/dev-ros/roscreate/roscreate-9999.ebuild
index 34cd94cd1e66..5a077c7eb99f 100644
--- a/dev-ros/roscreate/roscreate-9999.ebuild
+++ b/dev-ros/roscreate/roscreate-9999.ebuild
@@ -20,3 +20,8 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}