summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-10-30 07:08:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-10-30 07:08:03 +0000
commit1f0bdebd54e972f19748a07dc16e7f3b1dbfb2fc (patch)
treeebda0bfb5dbc327b68d555c030c4ee54713832cd
parentdev-db/timescaledb: drop 2.10.3, 2.11.1, 2.11.2 (diff)
downloadgentoo-1f0bdebd54e972f19748a07dc16e7f3b1dbfb2fc.tar.gz
gentoo-1f0bdebd54e972f19748a07dc16e7f3b1dbfb2fc.tar.bz2
gentoo-1f0bdebd54e972f19748a07dc16e7f3b1dbfb2fc.zip
dev-db/timescaledb: add 2.12.2
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--dev-db/timescaledb/Manifest1
-rw-r--r--dev-db/timescaledb/timescaledb-2.12.2.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/timescaledb/Manifest b/dev-db/timescaledb/Manifest
index 6b79116a1966..0680ff7023f4 100644
--- a/dev-db/timescaledb/Manifest
+++ b/dev-db/timescaledb/Manifest
@@ -1 +1,2 @@
DIST timescaledb-2.12.0.tar.gz 7510785 BLAKE2B 9b94831988832e04943d69a6d1727a84f8e3d0f59e5db11cdba5cfdd9975e1e932e1df7f9b753ae73b70c3fb503fe92e057f8747a0ec21b7cd36abb4e524c022 SHA512 74d2c73c2c1c5c62d0681adee807c229c6c0454570f625eac4d999a8bcf9292ebc6424d9de084a7826a55e9721d6262fa2e12972185765285c0877cab1f15fd2
+DIST timescaledb-2.12.2.tar.gz 7521115 BLAKE2B 2bc2d43e3185b95cd0b4bcfc852c0850959ac117e4a30cd3b30157a82e7ad7f8192e80cc9787474e169c5ae5476a146cd2510ab93d25f479dcc7d39fa45ae15c SHA512 cb39f632a8c2e02968045f459edaacc291abbda6e64962bfd05519b9c2c00ccaac5f520f2abf8a0b08f4bb740488df56295585c13bb83b82c0d1842a71ff7224
diff --git a/dev-db/timescaledb/timescaledb-2.12.2.ebuild b/dev-db/timescaledb/timescaledb-2.12.2.ebuild
new file mode 100644
index 000000000000..5941e85afbb1
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.12.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 13 14 15 )
+POSTGRES_USEDEP="ssl"
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+CMAKE_BUILD_TYPE="RelWithDebInfo"
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}