summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-06 16:46:44 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-06 16:46:44 +0200
commit1f384dee83ed3c425f40eae102da72e7a07b4086 (patch)
tree7e8122f491b556b3e489535e14833ccbd55f0489
parentdev-util/android-sdk-update-manager: [QA] Add RESTRICT=bindist (diff)
downloadgentoo-1f384dee83ed3c425f40eae102da72e7a07b4086.tar.gz
gentoo-1f384dee83ed3c425f40eae102da72e7a07b4086.tar.bz2
gentoo-1f384dee83ed3c425f40eae102da72e7a07b4086.zip
dev-python/pulsectl: Bump to 24.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pulsectl/Manifest1
-rw-r--r--dev-python/pulsectl/pulsectl-24.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pulsectl/Manifest b/dev-python/pulsectl/Manifest
index ff4d46188099..92b5ba72b5e8 100644
--- a/dev-python/pulsectl/Manifest
+++ b/dev-python/pulsectl/Manifest
@@ -1 +1,2 @@
DIST pulsectl-23.5.2.tar.gz 41119 BLAKE2B 45239e9b6b3e19356f7c89acb673d9287e9e38099608e246c8334a5de82bf93d813688e376cf5aedb92e6b3368ce93bae1df630726a5ae568c83d774c942f848 SHA512 4f05edd994aac1964c358c50a95f564afb40fcc6ac410d5189525312c042057954d040dc41939b665347a39453244eccc138c4c7d628ef2da62034606716ecb9
+DIST pulsectl-24.4.0.tar.gz 41166 BLAKE2B 3b2d41b3077f050104e7b416cb8dbba47f4282bb90ee58c855f4f5a1e1b1183b131879e6965edf8d8b5a2466ce3381e45c7a6b92f2b64fc336d311d3d7625440 SHA512 b17fd577f9c336f762925bd423fdca665afa92a88b0dae076ca016d7c5b2b3d9ef11efd27f7339031accadef00d513f972c216a23f26cfd049516f3dbcc63d01
diff --git a/dev-python/pulsectl/pulsectl-24.4.0.ebuild b/dev-python/pulsectl/pulsectl-24.4.0.ebuild
new file mode 100644
index 000000000000..ac8b6d5ff25c
--- /dev/null
+++ b/dev-python/pulsectl/pulsectl-24.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+HOMEPAGE="
+ https://github.com/mk-fg/python-pulse-control/
+ https://pypi.org/project/pulsectl/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ media-libs/libpulse
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests unittest