summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-01 15:43:29 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-01 15:43:29 +0200
commit1fa08a55f34a787faf00f370b32bd2db0feab318 (patch)
treef982a0d2e53b04cdfacb9e8d96e929a47c2de0c2
parentdev-python/pybtex: Enable py3.12 (diff)
downloadgentoo-1fa08a55f34a787faf00f370b32bd2db0feab318.tar.gz
gentoo-1fa08a55f34a787faf00f370b32bd2db0feab318.tar.bz2
gentoo-1fa08a55f34a787faf00f370b32bd2db0feab318.zip
dev-python/pychm: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pychm/pychm-0.8.6-r1.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/dev-python/pychm/pychm-0.8.6-r1.ebuild b/dev-python/pychm/pychm-0.8.6-r1.ebuild
index e78d4371ba76..5cd27a7443bd 100644
--- a/dev-python/pychm/pychm-0.8.6-r1.ebuild
+++ b/dev-python/pychm/pychm-0.8.6-r1.ebuild
@@ -3,20 +3,32 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Python bindings for the chmlib library"
-HOMEPAGE="https://github.com/dottedmag/pychm"
-SRC_URI="https://github.com/dottedmag/pychm/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/dottedmag/pychm/
+ https://pypi.org/project/pychm/
+"
+SRC_URI="
+ https://github.com/dottedmag/pychm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~arm ~ppc x86"
-RDEPEND="dev-libs/chmlib"
-DEPEND="${RDEPEND}"
+DEPEND="
+ dev-libs/chmlib
+"
+RDEPEND="
+ ${DEPEND}
+"
distutils_enable_tests pytest