summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-11 04:21:32 +0100
committerSam James <sam@gentoo.org>2021-08-11 04:36:39 +0100
commit201afe2bae97330580f3cc56c600ab7d0956fa29 (patch)
treefb55317c295043ac1323d331b9100f04db0fda45
parentkde-apps/kde-apps-meta: Stabilize 21.04.3 arm64, #805065 (diff)
downloadgentoo-201afe2bae97330580f3cc56c600ab7d0956fa29.tar.gz
gentoo-201afe2bae97330580f3cc56c600ab7d0956fa29.tar.bz2
gentoo-201afe2bae97330580f3cc56c600ab7d0956fa29.zip
app-text/blogc: add 0.20.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/blogc/Manifest1
-rw-r--r--app-text/blogc/blogc-0.20.1.ebuild57
-rw-r--r--app-text/blogc/blogc-9999.ebuild23
3 files changed, 70 insertions, 11 deletions
diff --git a/app-text/blogc/Manifest b/app-text/blogc/Manifest
index 0089acec57cf..88ffbcc6cddb 100644
--- a/app-text/blogc/Manifest
+++ b/app-text/blogc/Manifest
@@ -1 +1,2 @@
DIST blogc-0.20.0.tar.xz 347924 BLAKE2B faabb51237ff4ba3b431b84394cb8ca6f977770f9ed8c1ffbcc841773dc707b9a51694d7a5f3dbe5c573bdd7a16971004551b8ae2c0347273d8c246ae329bd82 SHA512 3738eb23341deb755dbfb0d2e98a73fe53f0e38b929606ebb0a3210d0564a626375d5c20ebff220e63be1f61299492da9061db5366d9d53a28f7ff18cff678a5
+DIST blogc-0.20.1.tar.xz 346280 BLAKE2B b2cf2c0ac0eaa857d91c75f7bcdf9e6b6ce0132e5a999719f9da3d32c7c336b8557f0e76b13ca02e6a20d67aef5cccedf01b3abe7b77dce6be612501d208eb8e SHA512 0e64e3da70ce52cec148210c140000b34cdafb848ae1fbd6160979de47738257a08af236e53e908f256d610ae6680bb554376c049246c32867b64985a637746c
diff --git a/app-text/blogc/blogc-0.20.1.ebuild b/app-text/blogc/blogc-0.20.1.ebuild
new file mode 100644
index 000000000000..75b899156927
--- /dev/null
+++ b/app-text/blogc/blogc-0.20.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A blog compiler"
+HOMEPAGE="https://blogc.rgm.io/"
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/blogc/blogc.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+fi
+
+if [[ ${PV} = *9999* ]]; then
+ BDEPEND="app-text/ronn"
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="git httpd make test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="git? ( dev-vcs/git )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig
+ test? (
+ git? ( dev-vcs/git )
+ )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ eapply_user
+ default
+}
+
+src_configure() {
+ local myconf=""
+
+ if [[ ${PV} = *9999* ]]; then
+ myconf+="--enable-ronn"
+ else
+ myconf+="--disable-ronn"
+ fi
+
+ econf \
+ $(use_enable test tests) \
+ $(use_enable git git-receiver) \
+ $(use_enable make make) \
+ $(use_enable httpd runserver) \
+ --disable-make-embedded \
+ --disable-valgrind \
+ ${myconf}
+}
diff --git a/app-text/blogc/blogc-9999.ebuild b/app-text/blogc/blogc-9999.ebuild
index 3b3a78e46d44..75b899156927 100644
--- a/app-text/blogc/blogc-9999.ebuild
+++ b/app-text/blogc/blogc-9999.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+DESCRIPTION="A blog compiler"
+HOMEPAGE="https://blogc.rgm.io/"
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/blogc/blogc.git"
inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
fi
-DESCRIPTION="A blog compiler"
-HOMEPAGE="https://blogc.rgm.io/"
-
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
- DEPEND="app-text/ronn"
+ BDEPEND="app-text/ronn"
else
KEYWORDS="~amd64 ~x86"
fi
@@ -25,12 +24,12 @@ IUSE="git httpd make test"
RESTRICT="!test? ( test )"
RDEPEND="git? ( dev-vcs/git )"
-
-DEPEND="${DEPEND}
- virtual/pkgconfig
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig
test? (
git? ( dev-vcs/git )
- dev-util/cmocka )"
+ )"
src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
@@ -40,11 +39,13 @@ src_prepare() {
src_configure() {
local myconf=""
+
if [[ ${PV} = *9999* ]]; then
myconf+="--enable-ronn"
else
myconf+="--disable-ronn"
fi
+
econf \
$(use_enable test tests) \
$(use_enable git git-receiver) \