summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 12:40:05 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:38 +0100
commit21820be07fd5d863877665bf53c53285a96323cb (patch)
treeac5fdeec0b0a123895bfe6cfdb572862bcc62aa8
parentdev-util/txt2regex: port to EAPI 7 (diff)
downloadgentoo-21820be07fd5d863877665bf53c53285a96323cb.tar.gz
gentoo-21820be07fd5d863877665bf53c53285a96323cb.tar.bz2
gentoo-21820be07fd5d863877665bf53c53285a96323cb.zip
dev-util/splint: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/splint/splint-3.1.2-r2.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-util/splint/splint-3.1.2-r2.ebuild b/dev-util/splint/splint-3.1.2-r2.ebuild
index 464cab789b81..1975543f7f9d 100644
--- a/dev-util/splint/splint-3.1.2-r2.ebuild
+++ b/dev-util/splint/splint-3.1.2-r2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools epatch
+EAPI=7
+
+inherit autotools
DESCRIPTION="Check C programs for vulnerabilities and programming mistakes"
HOMEPAGE="http://lclint.cs.virginia.edu/"
@@ -12,12 +13,14 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~ppc-macos ~x64-macos"
-DEPEND="
- sys-devel/flex
-"
+DEPEND="sys-devel/flex"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.2-musl.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.1.2-musl.patch
+ default
# verbose compiler calls
sed -i -e '/Compiling/d' src/Makefile.am || die