summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2022-10-06 23:11:58 +0200
committerSam James <sam@gentoo.org>2022-10-13 00:04:31 +0100
commit21ac4b3c4f5a44df53bc912b5d1abf13dff71e1c (patch)
tree3c990ecbeef51bf5c0025326128427c3c49d3431
parentgames-strategy/0ad: add 0.0.26_alpha (diff)
downloadgentoo-21ac4b3c4f5a44df53bc912b5d1abf13dff71e1c.tar.gz
gentoo-21ac4b3c4f5a44df53bc912b5d1abf13dff71e1c.tar.bz2
gentoo-21ac4b3c4f5a44df53bc912b5d1abf13dff71e1c.zip
games-strategy/0ad: Drop the old version alpha25b
Signed-off-by: Nils Freydank <holgersson@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/27668 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-strategy/0ad/0ad-0.0.25b_alpha-r1.ebuild264
-rw-r--r--games-strategy/0ad/Manifest4
-rw-r--r--games-strategy/0ad/files/0ad-0.0.25b_alpha-fix-name-collision-glibc.patch131
-rw-r--r--games-strategy/0ad/files/0ad-0.0.25b_alpha-python3.10.patch156
4 files changed, 0 insertions, 555 deletions
diff --git a/games-strategy/0ad/0ad-0.0.25b_alpha-r1.ebuild b/games-strategy/0ad/0ad-0.0.25b_alpha-r1.ebuild
deleted file mode 100644
index 0939933bda9d..000000000000
--- a/games-strategy/0ad/0ad-0.0.25b_alpha-r1.ebuild
+++ /dev/null
@@ -1,264 +0,0 @@
-# Copyright 2014-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-WX_GTK_VER="3.0-gtk3"
-PYTHON_COMPAT=( python3_{8..10} )
-inherit desktop toolchain-funcs multiprocessing python-any-r1 wxwidgets xdg
-
-DESCRIPTION="A free, real-time strategy game"
-HOMEPAGE="https://play0ad.com/"
-LICENSE="BitstreamVera CC-BY-SA-3.0 GPL-2 LGPL-2.1 LPPL-1.3c MIT ZLIB"
-# Upstream signs releases (and only them) with app-crypt/minisign.
-# The (public) key can be found on https://play0ad.com/download/source.
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/0ad/0ad"
- S="${WORKDIR}/${P}"
-elif [[ ${PV} == *_pre* ]]; then
- ZEROAD_GIT_REVISION="c7d07d3979f969b969211a5e5748fa775f6768a7"
- SRC_URI="https://github.com/0ad/0ad/archive/${ZEROAD_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${ZEROAD_GIT_REVISION}"
-else
- # Trailing whitespace for IUSE append below
- IUSE="verify-sig "
- MINISIGN_KEY="RWT0hFWv57I2RFoJwLVjxEr44JOq/RkEx1oT0IA3PPPICnSF7HFKW1CT"
- MY_P="0ad-${PV/_/-}"
- SRC_URI="
- http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz
- https://releases.wildfiregames.com/${MY_P}-unix-data.tar.xz
- verify-sig? (
- http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz.minisig
- http://releases.wildfiregames.com/${MY_P}-unix-data.tar.xz.minisig
- )
- "
- S="${WORKDIR}/${MY_P}"
-fi
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE+="editor +lobby nvtt pch test"
-
-RESTRICT="test"
-CHECKREQS_DISK_BUILD="9000M" # 8769732 KiB (8.3 GiB) for alpha 25
-CHECKREQS_DISK_USR="3500M" # 3545972 KiB (3.3 GiB)
-
-# Premake adds '-s' to some LDFLAGS. Simply sed'ing it out leads to
-# build and/or startup issues.
-QA_PRESTRIPPED="/usr/lib64/0ad/libCollada.so /usr/bin/0ad"
-
-# virtual/rust is for bundled SpiderMonkey.
-# Build-time Python dependency is for SM, too.
-BDEPEND="
- ${PYTHON_DEPS}
- >=dev-util/premake-5.0.0_alpha12:5
- virtual/pkgconfig
- virtual/rust
- test? ( dev-lang/perl )
-"
-# Upstream uses minisign which is not supported by verify-sign, bug #783066.
-# Signatures are only provided for releases.
-if [[ ( ${PV} != *9999 ) && ( ${PV} != *_p* ) ]]; then
- BDEPEND+=" app-crypt/minisign"
-fi
-
-# Removed dependency on nvtt as we use the bundled one.
-# bug #768930
-DEPEND="
- dev-libs/boost:=
- dev-libs/icu:=
- dev-libs/libfmt:0=
- dev-libs/libsodium
- dev-libs/libxml2
- media-libs/libpng:0
- media-libs/libsdl2[X,opengl,video]
- media-libs/libvorbis
- media-libs/openal
- net-libs/enet:1.3
- net-libs/miniupnpc:=
- net-misc/curl
- sys-libs/zlib
- virtual/opengl
- x11-libs/libX11
- editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
- lobby? ( net-libs/gloox )
-"
-RDEPEND="
- ${DEPEND}
- !games-strategy/0ad-data
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.0.24b_alpha-respect-tc.patch
- "${FILESDIR}"/${PN}-0.0.25b_alpha-fix-setuptools.patch
- "${FILESDIR}"/${PN}-0.0.25b_alpha-python3.10.patch
- "${FILESDIR}"/${PN}-0.0.25b_alpha-fix-name-collision-glibc.patch
-)
-
-pkg_setup() {
- use editor && setup-wxwidgets
-
- python-any-r1_pkg_setup
-}
-
-src_unpack() {
- if [[ ( ${PV} != *9999 ) && ( ${PV} != *_p* ) ]]; then
- if use verify-sig; then
- elog "Verifying both signatures using app-crypt/minisign."
- minisign -V \
- -P "${MINISIGN_KEY}" \
- -x "${DISTDIR}/${MY_P}-unix-build.tar.xz.minisig" \
- -m "${DISTDIR}/${MY_P}-unix-build.tar.xz" \
- || die "Failed to verify engine distfile using minisign!"
- minisign -V \
- -P "${MINISIGN_KEY}" \
- -x "${DISTDIR}/${MY_P}-unix-data.tar.xz.minisig" \
- -m "${DISTDIR}/${MY_P}-unix-data.tar.xz" \
- || die "Failed to verify data distfile using minisign!"
- fi
- # Unpack manually until an eclass supports minisign and unpacks
- # if signatures match.
- default
- else
- # Unpack distfiles without checking as this is no official release.
- default
- fi
-}
-
-src_prepare() {
- default
-
- # SpiderMonkey's configure no longer recognises --build for
- # the build tuple
- sed -i -e "/--build/d" libraries/source/spidermonkey/build.sh || die
-
- # Originally from 0ad-data
- rm binaries/data/tools/fontbuilder/fonts/*.txt || die
-}
-
-src_configure() {
- # 0AD uses premake:5 to generate the Makefiles, so let's
- # 1. configure the configure args,
- # 2. export some toolchain args,
- # 3. configure premake args,
- # 4. run premake5.
- local myconf=(
- --minimal-flags
- $(usex nvtt "" "--without-nvtt")
- $(usex pch "" "--without-pch")
- $(usex test "" "--without-tests")
- $(usex editor "--atlas" "")
- $(usex lobby "" "--without-lobby")
- --bindir="/usr/bin"
- --libdir="/usr/$(get_libdir)"/${PN}
- --datadir="/usr/share/${PN}"
- )
-
- tc-export AR CC CXX RANLIB
-
- local mypremakeargs=(
- --outpath="../workspace/gcc"
- --os=linux
- --verbose
- )
-
- cd "${S}/build/premake" || die "Could not enter premake directory"
-
- /usr/bin/premake5 "${mypremakeargs[@]}" "${myconf[@]}" gmake2 \
- || die "Premake failed"
-}
-
-src_compile() {
- # Build 3rd party fcollada
- einfo "Building bundled fcollada"
- emake -C libraries/source/fcollada/src
-
- # Build bundled NVTT
- # nvtt is abandoned upstream and 0ad has forked it and added fixes.
- # Use their copy. bug #768930
- if use nvtt ; then
- cd libraries/source/nvtt || die
- elog "Building bundled NVTT (bug #768930)"
- JOBS="-j$(makeopts_jobs)" ./build.sh || die "Failed to build bundled NVTT"
- cd "${S}" || die
- fi
-
- # Build bundled SpiderMonkey
- # We really can't use the system SpiderMonkey right now.
- # Breakages occur even on minor bumps in upstream SM,
- # e.g. bug #768840.
- cd libraries/source/spidermonkey || die
- elog "Building bundled SpiderMonkey (bug #768840)"
- XARGS="${EPREFIX}/usr/bin/xargs" \
- JOBS="-j$(makeopts_jobs)" \
- ./build.sh \
- || die "Failed to build bundled SpiderMonkey"
-
- cd "${S}" || die
-
- # Build 0ad itself!
- elog "Building 0ad"
- JOBS="-j$(makeopts_jobs)" emake -C build/workspace/gcc verbose=1
-
- # Build assets
- # (We only do this if we're using a snapshot/non-release)
- # See bug #771147 (comment 3) and the old 0ad-data ebuild
- # Warning: fragile!
- if [[ ${PV} == 9999 || ${PV} == *_pre* ]]; then
- # source/lib/sysdep/os/linux/ldbg.cpp:debug_SetThreadName() tries to open /proc/self/task/${TID}/comm for writing.
- addpredict /proc/self/task
-
- # Based on source/tools/dist/build-archives.sh used by source/tools/dist/build.sh.
- local archivebuild_input archivebuild_output mod_name
- for archivebuild_input in binaries/data/mods/[A-Za-z0-9]*; do
- mod_name="${archivebuild_input##*/}"
- archivebuild_output="archives/${mod_name}"
-
- mkdir -p "${archivebuild_output}" || die
-
- einfo pyrogenesis -archivebuild="${archivebuild_input}" -archivebuild-output="${archivebuild_output}/${mod_name}.zip"
- LD_LIBRARY_PATH="binaries/system" binaries/system/pyrogenesis \
- -archivebuild="${archivebuild_input}" \
- -archivebuild-output="${archivebuild_output}/${mod_name}.zip" \
- || die "Failed to build assets"
-
- if [[ -f "${archivebuild_input}/mod.json" ]]; then
- cp "${archivebuild_input}/mod.json" "${archivebuild_output}" || die
- fi
-
- rm -r "${archivebuild_input}" || die
- mv "${archivebuild_output}" "${archivebuild_input}" || die
- done
-
- # Based on source/tools/dist/build-unix-win32.sh used by source/tools/dist/build.sh.
- rm binaries/data/config/dev.cfg || die
- rm -r binaries/data/mods/_test.* || die
- fi
-}
-
-src_test() {
- cd binaries/system || die
- ./test -libdir "${S}/binaries/system" || die "Failed tests"
-}
-
-src_install() {
- newbin binaries/system/pyrogenesis 0ad
- use editor && newbin binaries/system/ActorEditor 0ad-ActorEditor
-
- # Merged from 0ad-data
- # bug #771147 (comment 3)
- insinto /usr/share/${PN}
- doins -r binaries/data/{l10n,config,mods,tools}
-
- # Install bundled SpiderMonkey and nvtt
- # bug #771147 (comment 1)
- exeinto /usr/$(get_libdir)/${PN}
- doexe binaries/system/{libCollada,libmozjs78-ps-release}.so
-
- use nvtt && doexe binaries/system/{libnvtt,libnvcore,libnvimage,libnvmath}.so
- use editor && doexe binaries/system/libAtlasUI.so
-
- dodoc binaries/system/readme.txt
- doicon -s 128 build/resources/${PN}.png
- make_desktop_entry ${PN}
-}
diff --git a/games-strategy/0ad/Manifest b/games-strategy/0ad/Manifest
index ff4150c1231f..9f53ffa1fb54 100644
--- a/games-strategy/0ad/Manifest
+++ b/games-strategy/0ad/Manifest
@@ -1,7 +1,3 @@
-DIST 0ad-0.0.25b-alpha-unix-build.tar.xz 75579956 BLAKE2B 674d69d625137709a186f9273607dc353fc99aea68ef3f2ea5031dbe2f684176910d757c3f03c7fbdac475d30708be448b71f5020d27a65c346bf147223bcb9d SHA512 e8069897b97b381099ab5ec5868d27e96c699105b3307054d1bc7bf9236a537f02625ba9034892d91f3e951b4f95c9ce5fb75ed0a7c14b8a294882482fd9c1b4
-DIST 0ad-0.0.25b-alpha-unix-build.tar.xz.minisig 327 BLAKE2B 547a7a1c8a83167fa40976efb2efaf691fc5434eb1be227b481a70d308381b20dcdc90bb4652e190f8e329fb33cc19ebbaab43977329f8971e49436f7f1ce636 SHA512 9d6a235ea50183e1db16f4bf2dc59af9042a52e4e18ccd0c34c481a7e9021f19e2bc370e594aa97911bb7ca33bcc5ebe23a4b206cd74357060371ca06b6010d2
-DIST 0ad-0.0.25b-alpha-unix-data.tar.xz 1249684600 BLAKE2B d77546ba9d21b512f106645c07fa92ecc343e0a01d9a70a83f2a2b3ade912e72d095982f7d4c4cd64e18fb71a67a01c419763744dd4cad1e8c081e5f77ec17c9 SHA512 d6bbe484acb7fbd507d303f5c75f8a2ccbaf8fe9dd30ff408b082f170bfd96eb9235db1b710c15656ef465b44fa5597679a694515e0c153a35fe24c0915f29f1
-DIST 0ad-0.0.25b-alpha-unix-data.tar.xz.minisig 326 BLAKE2B 41975d4c4369780bd36edef448ab928c91ece0d60ddad04fbccd1da0ed5068b56c86fd57708c6158277c5db9faadc768f5e455d97fe5ae3c30a7522005c374e6 SHA512 ad3ef78b785db9eb37d547a86d2bf274e0b6635118a9c512d013adc45e4a0f071b86f0fb5bf696631596e0713b2de153b0ad245cbba86beb3ea153036178b07e
DIST 0ad-0.0.26-alpha-unix-build.tar.xz 75599800 BLAKE2B ddd589840b0dacee2377ff4e5624f69646b92da4217015d788c6abec097578e44aee6641b6a6945d15f50d8e50673a1d44587c2faf02278d981a0ed30c950214 SHA512 aaf647d5d8454c244015d2a198beeaaebc571a5bc96446f3acff8dbd05f9843029c500bf4162651a5e1fcdb42bd5fb5b4f5c512c78372479fbd8565dd093f272
DIST 0ad-0.0.26-alpha-unix-build.tar.xz.minisig 333 BLAKE2B 9f3146abda592fe6ab9433f6ee30060bcd4c5b594e00cb3fccc0aebb74652f3bc2ddd7b19a296da7ca13126ea9cc0337750f859e24f46adfcb84272bd2cce452 SHA512 eda542c1c363c7c0e6b235e6d8dfbd96d1c1e7cfca408b7215cf247b96c9f42b8bc206bbb4dd48dc41ee373db17d4a76cba940e454840dc41638dd572c580850
DIST 0ad-0.0.26-alpha-unix-data.tar.xz 1351511480 BLAKE2B 2f483593b79a6ae87d7582625e89c890cfcf4ad7116348b184dae6c47a814d95a7b9f3018cb79e8f024a61c647abd39d6faf5ad3d3fcbb0c7a0583d0479d9b18 SHA512 8fe29fce68737d5b7001c8c2a7198766583b22556129cd2d927823da9b2c58f224fb1207f35bd03abea9380cf24d00ab6257b0dba86ce3ad1f357d7006f051d6
diff --git a/games-strategy/0ad/files/0ad-0.0.25b_alpha-fix-name-collision-glibc.patch b/games-strategy/0ad/files/0ad-0.0.25b_alpha-fix-name-collision-glibc.patch
deleted file mode 100644
index e8d88e794c90..000000000000
--- a/games-strategy/0ad/files/0ad-0.0.25b_alpha-fix-name-collision-glibc.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-https://bugs.gentoo.org/834578
-https://trac.wildfiregames.com/changeset/26536/
-​https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103735
-​https://sourceware.org/bugzilla/show_bug.cgi?id=28713
---- a/source/tools/atlas/AtlasUI/ScenarioEditor/Sections/Environment/Environment.cpp
-+++ b/source/tools/atlas/AtlasUI/ScenarioEditor/Sections/Environment/Environment.cpp
-@@ -1,3 +1,3 @@
--/* Copyright (C) 2021 Wildfire Games.
-+/* Copyright (C) 2022 Wildfire Games.
- * This file is part of 0 A.D.
- *
-@@ -30,6 +30,4 @@
- static Observable<AtlasMessage::sEnvironmentSettings> g_EnvironmentSettings;
-
--const float M_PIf = 3.14159265f;
--
- //////////////////////////////////////////////////////////////////////////
-
-@@ -86,10 +84,13 @@
- m_Var(var)
- {
-- m_Conn = g_EnvironmentSettings.RegisterObserver(0, &VariableListBox::OnSettingsChange, this);
-+ m_Conn = g_EnvironmentSettings.RegisterObserver(
-+ 0, &VariableListBox::OnSettingsChange, this);
-
- m_Sizer = new wxStaticBoxSizer(wxVERTICAL, this, label);
- SetSizer(m_Sizer);
-
-- m_Combo = new wxComboBox(this, -1, wxEmptyString, wxDefaultPosition, wxDefaultSize, wxArrayString(), wxCB_READONLY),
-+ m_Combo = new wxComboBox(
-+ this, -1, wxEmptyString, wxDefaultPosition, wxDefaultSize,
-+ wxArrayString(), wxCB_READONLY),
- m_Sizer->Add(m_Combo, wxSizerFlags().Expand());
- }
-@@ -207,6 +208,7 @@
- }
-
--EnvironmentSidebar::EnvironmentSidebar(ScenarioEditor& scenarioEditor, wxWindow* sidebarContainer, wxWindow* bottomBarContainer)
--: Sidebar(scenarioEditor, sidebarContainer, bottomBarContainer)
-+EnvironmentSidebar::EnvironmentSidebar(
-+ ScenarioEditor& scenarioEditor, wxWindow* sidebarContainer, wxWindow* bottomBarContainer)
-+ : Sidebar(scenarioEditor, sidebarContainer, bottomBarContainer)
- {
- wxSizer* scrollSizer = new wxBoxSizer(wxVERTICAL);
-@@ -218,13 +220,22 @@
- wxSizer* waterSizer = new wxStaticBoxSizer(wxVERTICAL, scrolledWindow, _T("Water settings"));
- scrollSizer->Add(waterSizer, wxSizerFlags().Expand());
-- waterSizer->Add(new wxButton(scrolledWindow, ID_RecomputeWaterData, _("Reset Water Data")), wxSizerFlags().Expand());
-- waterSizer->Add(m_WaterTypeList = new VariableListBox(scrolledWindow, _("Water Type"), g_EnvironmentSettings.watertype), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableSliderBox(scrolledWindow, _("Water height"), g_EnvironmentSettings.waterheight, 0.f, 1.2f), wxSizerFlags().Expand());
-- waterSizer->Add(new wxButton(scrolledWindow, ID_PickWaterHeight, _("Pick Water Height")), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableSliderBox(scrolledWindow, _("Water waviness"), g_EnvironmentSettings.waterwaviness, 0.f, 10.f), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableSliderBox(scrolledWindow, _("Water murkiness"), g_EnvironmentSettings.watermurkiness, 0.f, 1.f), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableSliderBox(scrolledWindow, _("Wind angle"), g_EnvironmentSettings.windangle, -M_PIf, M_PIf), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableColorBox(scrolledWindow, _("Water color"), g_EnvironmentSettings.watercolor), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableColorBox(scrolledWindow, _("Water tint"), g_EnvironmentSettings.watertint), wxSizerFlags().Expand());
-+ waterSizer->Add(new wxButton(
-+ scrolledWindow, ID_RecomputeWaterData, _("Reset Water Data")), wxSizerFlags().Expand());
-+ waterSizer->Add(m_WaterTypeList = new VariableListBox(
-+ scrolledWindow, _("Water Type"), g_EnvironmentSettings.watertype), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Water height"), g_EnvironmentSettings.waterheight, 0.f, 1.2f), wxSizerFlags().Expand());
-+ waterSizer->Add(new wxButton(
-+ scrolledWindow, ID_PickWaterHeight, _("Pick Water Height")), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Water waviness"), g_EnvironmentSettings.waterwaviness, 0.f, 10.f), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Water murkiness"), g_EnvironmentSettings.watermurkiness, 0.f, 1.f), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Wind angle"), g_EnvironmentSettings.windangle, -static_cast<float>(M_PI), static_cast<float>(M_PI)), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableColorBox(
-+ scrolledWindow, _("Water color"), g_EnvironmentSettings.watercolor), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableColorBox(
-+ scrolledWindow, _("Water tint"), g_EnvironmentSettings.watertint), wxSizerFlags().Expand());
-
- std::vector<std::wstring> list;
-@@ -236,23 +247,38 @@
- scrollSizer->Add(sunSizer, wxSizerFlags().Expand().Border(wxTOP, 8));
-
-- sunSizer->Add(new VariableSliderBox(scrolledWindow, _("Sun rotation"), g_EnvironmentSettings.sunrotation, -M_PIf, M_PIf), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableSliderBox(scrolledWindow, _("Sun elevation"), g_EnvironmentSettings.sunelevation, -M_PIf/2, M_PIf/2), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableSliderBox(scrolledWindow, _("Sun overbrightness"), g_EnvironmentSettings.sunoverbrightness, 1.0f, 3.0f), wxSizerFlags().Expand());
-- sunSizer->Add(new LightControl(scrolledWindow, wxSize(150, 150), g_EnvironmentSettings));
-- sunSizer->Add(new VariableColorBox(scrolledWindow, _("Sun color"), g_EnvironmentSettings.suncolor), wxSizerFlags().Expand());
-- sunSizer->Add(m_SkyList = new VariableListBox(scrolledWindow, _("Sky set"), g_EnvironmentSettings.skyset), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableSliderBox(scrolledWindow, _("Fog Factor"), g_EnvironmentSettings.fogfactor, 0.0f, 0.01f), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableSliderBox(scrolledWindow, _("Fog Thickness"), g_EnvironmentSettings.fogmax, 0.5f, 0.0f), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableColorBox(scrolledWindow, _("Fog color"), g_EnvironmentSettings.fogcolor), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableColorBox(scrolledWindow, _("Ambient color"), g_EnvironmentSettings.ambientcolor), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Sun rotation"), g_EnvironmentSettings.sunrotation, -static_cast<float>(M_PI), static_cast<float>(M_PI)), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Sun elevation"), g_EnvironmentSettings.sunelevation, -static_cast<float>(M_PI) / 2.0f, static_cast<float>(M_PI) / 2.0f), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Sun overbrightness"), g_EnvironmentSettings.sunoverbrightness, 1.0f, 3.0f), wxSizerFlags().Expand());
-+ sunSizer->Add(new LightControl(
-+ scrolledWindow, wxSize(150, 150), g_EnvironmentSettings));
-+ sunSizer->Add(new VariableColorBox(
-+ scrolledWindow, _("Sun color"), g_EnvironmentSettings.suncolor), wxSizerFlags().Expand());
-+ sunSizer->Add(m_SkyList = new VariableListBox(
-+ scrolledWindow, _("Sky set"), g_EnvironmentSettings.skyset), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Fog Factor"), g_EnvironmentSettings.fogfactor, 0.0f, 0.01f), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Fog Thickness"), g_EnvironmentSettings.fogmax, 0.5f, 0.0f), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableColorBox(
-+ scrolledWindow, _("Fog color"), g_EnvironmentSettings.fogcolor), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableColorBox(
-+ scrolledWindow, _("Ambient color"), g_EnvironmentSettings.ambientcolor), wxSizerFlags().Expand());
-
- wxSizer* postProcSizer = new wxStaticBoxSizer(wxVERTICAL, scrolledWindow, _T("Post-processing settings"));
- scrollSizer->Add(postProcSizer, wxSizerFlags().Expand().Border(wxTOP, 8));
-
-- postProcSizer->Add(m_PostEffectList = new VariableListBox(scrolledWindow, _("Post Effect"), g_EnvironmentSettings.posteffect), wxSizerFlags().Expand());
-- postProcSizer->Add(new VariableSliderBox(scrolledWindow, _("Brightness"), g_EnvironmentSettings.brightness, -0.5f, 0.5f), wxSizerFlags().Expand());
-- postProcSizer->Add(new VariableSliderBox(scrolledWindow, _("Contrast (HDR)"), g_EnvironmentSettings.contrast, 0.5f, 1.5f), wxSizerFlags().Expand());
-- postProcSizer->Add(new VariableSliderBox(scrolledWindow, _("Saturation"), g_EnvironmentSettings.saturation, 0.0f, 2.0f), wxSizerFlags().Expand());
-- postProcSizer->Add(new VariableSliderBox(scrolledWindow, _("Bloom"), g_EnvironmentSettings.bloom, 0.2f, 0.0f), wxSizerFlags().Expand());
-+ postProcSizer->Add(m_PostEffectList = new VariableListBox(
-+ scrolledWindow, _("Post Effect"), g_EnvironmentSettings.posteffect), wxSizerFlags().Expand());
-+ postProcSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Brightness"), g_EnvironmentSettings.brightness, -0.5f, 0.5f), wxSizerFlags().Expand());
-+ postProcSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Contrast (HDR)"), g_EnvironmentSettings.contrast, 0.5f, 1.5f), wxSizerFlags().Expand());
-+ postProcSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Saturation"), g_EnvironmentSettings.saturation, 0.0f, 2.0f), wxSizerFlags().Expand());
-+ postProcSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Bloom"), g_EnvironmentSettings.bloom, 0.2f, 0.0f), wxSizerFlags().Expand());
-
- m_Conn = g_EnvironmentSettings.RegisterObserver(0, &SendToGame);
-
diff --git a/games-strategy/0ad/files/0ad-0.0.25b_alpha-python3.10.patch b/games-strategy/0ad/files/0ad-0.0.25b_alpha-python3.10.patch
deleted file mode 100644
index 80991e3c7a6e..000000000000
--- a/games-strategy/0ad/files/0ad-0.0.25b_alpha-python3.10.patch
+++ /dev/null
@@ -1,156 +0,0 @@
-https://github.com/0ad/0ad/commit/c2ec217eea6952c4877095969e11900b70c7cda3
-https://bugs.gentoo.org/845987
-
-From: s0600204 <s0600204@3db68df2-c116-0410-a063-a993310a9797>
-Date: Wed, 23 Feb 2022 20:30:38 +0000
-Subject: [PATCH] Fix building spidermonkey on systems with python 3.10
-
-Tested by:
-* Langbart - macOS 10.15.7: `homebrew`ed python 3.9.9 & 3.10.1
-* andy5995 - Manjaro 21.2.3: python 3.10.2
-* s0600204 - ArchLinux: python 3.10.2
-
-Differential Revision: https://code.wildfiregames.com/D4437
-
-
-
-git-svn-id: https://svn.wildfiregames.com/public/ps/trunk@26475 3db68df2-c116-0410-a063-a993310a9797
---- /dev/null
-+++ b/libraries/source/spidermonkey/FixPythonCollectionABC.diff
-@@ -0,0 +1,87 @@
-+--- a/python/mach/mach/config.py
-++++ b/python/mach/mach/config.py
-+@@ -144,7 +144,7 @@
-+ return _
-+
-+
-+-class ConfigSettings(collections.Mapping):
-++class ConfigSettings(collections.abc.Mapping):
-+ """Interface for configuration settings.
-+
-+ This is the main interface to the configuration.
-+@@ -190,7 +190,7 @@
-+ will result in exceptions being raised.
-+ """
-+
-+- class ConfigSection(collections.MutableMapping, object):
-++ class ConfigSection(collections.abc.MutableMapping, object):
-+ """Represents an individual config section."""
-+ def __init__(self, config, name, settings):
-+ object.__setattr__(self, '_config', config)
-+--- a/python/mach/mach/decorators.py
-++++ b/python/mach/mach/decorators.py
-+@@ -159,7 +159,7 @@
-+ 'Conditions argument must take a list ' + \
-+ 'of functions. Found %s instead.'
-+
-+- if not isinstance(command.conditions, collections.Iterable):
-++ if not isinstance(command.conditions, collections.abc.Iterable):
-+ msg = msg % (command.name, type(command.conditions))
-+ raise MachError(msg)
-+
-+--- a/python/mach/mach/main.py
-++++ b/python/mach/mach/main.py
-+@@ -16,7 +16,7 @@
-+ import sys
-+ import traceback
-+ import uuid
-+-from collections import Iterable
-++from collections.abc import Iterable
-+
-+ from six import string_types
-+
-+--- a/python/mozbuild/mozbuild/backend/configenvironment.py
-++++ b/python/mozbuild/mozbuild/backend/configenvironment.py
-+@@ -9,7 +9,8 @@
-+ import sys
-+ import json
-+
-+-from collections import Iterable, OrderedDict
-++from collections import OrderedDict
-++from collections.abc import Iterable
-+ from types import ModuleType
-+
-+ import mozpack.path as mozpath
-+--- a/python/mozbuild/mozbuild/makeutil.py
-++++ b/python/mozbuild/mozbuild/makeutil.py
-+@@ -7,7 +7,7 @@
-+ import os
-+ import re
-+ import six
-+-from collections import Iterable
-++from collections.abc import Iterable
-+
-+
-+ class Makefile(object):
-+--- a/python/mozbuild/mozbuild/util.py
-++++ b/python/mozbuild/mozbuild/util.py
-+@@ -782,7 +782,7 @@
-+ self._strings = StrictOrderingOnAppendList()
-+ self._children = {}
-+
-+- class StringListAdaptor(collections.Sequence):
-++ class StringListAdaptor(collections.abc.Sequence):
-+ def __init__(self, hsl):
-+ self._hsl = hsl
-+
-+--- a/testing/mozbase/manifestparser/manifestparser/filters.py
-++++ b/testing/mozbase/manifestparser/manifestparser/filters.py
-+@@ -15,1 +15,2 @@
-+-from collections import defaultdict, MutableSequence
-++from collections import defaultdict
-++from collections.abc import MutableSequence
-+--- a/third_party/python/pipenv/pipenv/vendor/jinja2/sandbox.py
-++++ b/third_party/python/pipenv/pipenv/vendor/jinja2/sandbox.py
-+@@ -82,1 +82,1 @@
-+-from collections import MutableSet, MutableMapping, MutableSequence
-++from collections.abc import MutableSet, MutableMapping, MutableSequence
---- /dev/null
-+++ b/libraries/source/spidermonkey/FixVirtualenvForPython310.diff
-@@ -0,0 +1,15 @@
-+--- a/third_party/python/virtualenv/virtualenv.py
-++++ b/third_party/python/virtualenv/virtualenv.py
-+@@ -1804,7 +1804,11 @@
-+ pass
-+ else:
-+ # noinspection PyProtectedMember
-+- if sysconfig._get_default_scheme() == "posix_local":
-++ try: # Python >= 3.10
-++ default_scheme = sysconfig.get_default_scheme()
-++ except: # Python < 3.10
-++ default_scheme = sysconfig._get_default_scheme()
-++ if default_scheme == "posix_local":
-+ local_path = os.path.join(home_dir, "local")
-+ if not os.path.exists(local_path):
-+ os.mkdir(local_path)
---- a/libraries/source/spidermonkey/patch.sh
-+++ b/libraries/source/spidermonkey/patch.sh
-@@ -52,6 +60,11 @@ patch -p1 < ../FixMSVCRootedVoid.diff
- # so this patches it to an arbitrarily high Mac OS 11
- patch -p1 < ../FixMacBuild.diff
-
-+# In python 3.3, the Collections' Abstract Base Classes were moved from `collections` to
-+# `collections.abc`, and aliases were set up for backwards compatibility.
-+# In python 3.10, these aliases were removed, requiring all code that used them to update.
-+patch -p1 < ../FixPythonCollectionABC.diff
-+
- # Fix FP access breaking compilation on RPI3+
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1526653
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1536491
-
-diff --git a/libraries/source/spidermonkey/patch.sh b/libraries/source/spidermonkey/patch.sh
-index 2a3e165..5dde46f 100644
---- a/libraries/source/spidermonkey/patch.sh
-+++ b/libraries/source/spidermonkey/patch.sh
-@@ -2,6 +2,11 @@
- # Apply patches if needed
- # This script gets called from build.sh.
-
-+# In python 3.10 `sysconfig._get_default_scheme()` was renamed to
-+# `sysconfig.get_default_scheme()`. This breaks the version of
-+# `virtualenv` bundled with the spidermonkey source code.
-+patch -p1 < ../FixVirtualenvForPython310.diff
-+
- # Mozglue symbols need to be linked against static builds.
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1588340
- patch -p1 < ../FixMozglue.diff