summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-03-08 19:10:39 +0100
committerSebastian Pipping <sping@gentoo.org>2024-03-08 19:11:30 +0100
commit21b54572da4b61506664183ee1af56adafa34617 (patch)
treef884980c38c989e3b52e947a6caa9498a5b1535e
parentnet-analyzer/tcpslice: add 1.7 (diff)
downloadgentoo-21b54572da4b61506664183ee1af56adafa34617.tar.gz
gentoo-21b54572da4b61506664183ee1af56adafa34617.tar.bz2
gentoo-21b54572da4b61506664183ee1af56adafa34617.zip
dev-vcs/git-big-picture: 1.3.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
-rw-r--r--dev-vcs/git-big-picture/Manifest1
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.3.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/git-big-picture/Manifest b/dev-vcs/git-big-picture/Manifest
index a9684c28ab3a..8ff7494ba344 100644
--- a/dev-vcs/git-big-picture/Manifest
+++ b/dev-vcs/git-big-picture/Manifest
@@ -1 +1,2 @@
DIST git-big-picture-1.2.2.tar.gz 2964564 BLAKE2B 39971b21a9c9a0a8d1bf41f37350a158b634d2eaa0add460c1c18b70f643ab226736d53a337d4ed2583903a5d6c3188ab7a1b06f48a3f354e28d57ec74441599 SHA512 62c43727bb688d6572e7caafe9c5da3b782504738dd0d83d5df675ba757e8be22a8630ec1863c07f0fd2e54549b2ccbd1250ba8f367a6f840afa7b8962c487e8
+DIST git-big-picture-1.3.0.tar.gz 2965335 BLAKE2B 07e7485259c63d4826bc73280d41c4f64abf526f817213f81d8de5318cbdae6b348589028b82c961b06806137cd6dd265bfb0ff4df55cd1eeb418cb7bd7b8f67 SHA512 8e0a6c821308fe54b2924b6dd1f7294f205e301c20cb9d43837a16e9b2848a5476497e3868b3b96e512f3b8cf8f20639f07932b26f3507d77a2a9bae01707de7
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.3.0.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.3.0.ebuild
new file mode 100644
index 000000000000..c0662dc77cf1
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# NOTE: dev-util/cram explictly does not need [${PYTHON_USEDEP}]
+# since test.cram is a shell session and not Python code
+DEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram
+ )
+"
+# NOTE: No need for "[python]" or "[${PYTHON_USEDEP}]" with any of
+# these since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}