summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-18 12:28:45 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-18 12:31:02 +0100
commit22042e328bd7c077739163c4822a74855795bd3e (patch)
treec14309345c9e3540ce00d6d1cdd92731ba92028f
parentdev-util/boost-build: Clean old versions up (diff)
downloadgentoo-22042e328bd7c077739163c4822a74855795bd3e.tar.gz
gentoo-22042e328bd7c077739163c4822a74855795bd3e.tar.bz2
gentoo-22042e328bd7c077739163c4822a74855795bd3e.zip
dev-util/universalindentgui: python-single-r1, \!qt4-r2, EAPI=6
-rw-r--r--dev-util/universalindentgui/universalindentgui-1.2.0-r3.ebuild (renamed from dev-util/universalindentgui/universalindentgui-1.2.0-r2.ebuild)42
1 files changed, 18 insertions, 24 deletions
diff --git a/dev-util/universalindentgui/universalindentgui-1.2.0-r2.ebuild b/dev-util/universalindentgui/universalindentgui-1.2.0-r3.ebuild
index 457c80eb24ee..c0e56b522953 100644
--- a/dev-util/universalindentgui/universalindentgui-1.2.0-r2.ebuild
+++ b/dev-util/universalindentgui/universalindentgui-1.2.0-r3.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-PYTHON_DEPEND="python? 2"
-LANGS="de fr ja ru uk zh_TW"
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
-inherit eutils python qmake-utils qt4-r2
+inherit eutils python-single-r1 qmake-utils
DESCRIPTION="Cross platform GUI for several code formatters, beautifiers and indenters"
HOMEPAGE="http://universalindent.sourceforge.net/"
@@ -32,20 +31,20 @@ RDEPEND="${DEPEND}
)
perl? ( dev-perl/Perl-Tidy )
php? ( dev-php/PEAR-PHP_Beautifier )
+ python? ( ${PYTHON_DEPS} )
ruby? ( dev-lang/ruby )
xml? ( dev-util/xmlindent )
"
-DOCS="CHANGELOG.txt readme.html"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
+ default
+
# correct translation binaries
sed -e "s|lupdate-qt4|$(qt4_get_bindir)/lupdate|" \
-e "s|lrelease-qt4|$(qt4_get_bindir)/lrelease|" \
@@ -85,7 +84,7 @@ src_prepare() {
UEXAMPLES="${UEXAMPLES} py"
UINDENTERS="${UINDENTERS} pindent.py"
UIGUIFILES="${UIGUIFILES} pindent"
- python_convert_shebangs -r 2 .
+ python_fix_shebang .
fi
if use ruby; then
@@ -102,7 +101,7 @@ src_prepare() {
local IFILES= I=
for I in ${UINDENTERS}; do
IFILES="${IFILES} indenters/${I}"
- chmod +x indenters/${I}
+ chmod +x indenters/${I} || die
done
for I in ${UIGUIFILES}; do
@@ -114,28 +113,23 @@ src_prepare() {
die ".pro patching failed"
sed -i -e "s:indenters/uigui_\*\.ini:${IFILES}:" UniversalIndentGUI.pro ||
die ".pro patching failed"
+}
- local lang
- for lang in ${LANGS}; do
- if ! use linguas_${lang}; then
- sed -e "/_${lang}.ts/d" -e "/_${lang}.qm/d" \
- -i UniversalIndentGUI.pro || die "failed while disabling ${lang}"
- fi
- done
-
- qt4-r2_src_prepare
+src_configure() {
+ eqmake4 UniversalIndentGUI.pro
}
src_install() {
- qt4-r2_src_install
+ emake install INSTALL_ROOT="${D}"
+ dodoc CHANGELOG.txt readme.html
doman doc/${PN}.1.gz
if use examples; then
- insinto /usr/share/doc/${PF}/examples
+ docinto examples
local I
for I in ${UEXAMPLES}; do
- doins indenters/example.${I}
+ dodoc indenters/example.${I}
done
fi