summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-26 22:03:14 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-26 22:06:33 -0400
commit240d0c9699477f1c3871a47da4be620f696b4dc7 (patch)
tree9b1d485242aa8a6445a8ae7c1e10c510e5ec53f4
parentapp-emulation/buildah: Remove vulnerable versions (diff)
downloadgentoo-240d0c9699477f1c3871a47da4be620f696b4dc7.tar.gz
gentoo-240d0c9699477f1c3871a47da4be620f696b4dc7.tar.bz2
gentoo-240d0c9699477f1c3871a47da4be620f696b4dc7.zip
dev-cpp/gconfmm: Fix build with glib-2.68
Also port to EAPI=7 and drop IUSE=doc. Closes: https://bugs.gentoo.org/785244 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-cpp/gconfmm/files/gconfmm-2.28.3-no-extern-c-glib-includes.patch44
-rw-r--r--dev-cpp/gconfmm/gconfmm-2.28.3-r1.ebuild30
2 files changed, 55 insertions, 19 deletions
diff --git a/dev-cpp/gconfmm/files/gconfmm-2.28.3-no-extern-c-glib-includes.patch b/dev-cpp/gconfmm/files/gconfmm-2.28.3-no-extern-c-glib-includes.patch
new file mode 100644
index 000000000000..b05face5b0a0
--- /dev/null
+++ b/dev-cpp/gconfmm/files/gconfmm-2.28.3-no-extern-c-glib-includes.patch
@@ -0,0 +1,44 @@
+diff -Naur gconfmm-2.28.3-original/gconf/gconfmm/callback.h gconfmm-2.28.3/gconf/gconfmm/callback.h
+--- gconfmm-2.28.3-original/gconf/gconfmm/callback.h 2011-10-18 11:33:49.000000000 -0400
++++ gconfmm-2.28.3/gconf/gconfmm/callback.h 2021-02-13 09:21:06.167235506 -0500
+@@ -22,10 +22,7 @@
+ #ifndef GCONFMM_CALLBACK_H
+ #define GCONFMM_CALLBACK_H
+
+-extern "C"
+-{
+ #include <gconf/gconf-client.h>
+-}
+
+ #include <glibmm/object.h>
+ #include <gconfmm/entry.h>
+diff -Naur gconfmm-2.28.3-original/gconf/gconfmm/schema.h gconfmm-2.28.3/gconf/gconfmm/schema.h
+--- gconfmm-2.28.3-original/gconf/gconfmm/schema.h 2011-10-21 04:51:27.000000000 -0400
++++ gconfmm-2.28.3/gconf/gconfmm/schema.h 2021-02-13 09:21:24.616354041 -0500
+@@ -31,10 +31,8 @@
+ #include <gconfmm/value.h>
+
+
+-extern "C" {
+- // TODO: do not include this.
++// TODO: do not include this.
+ #include <gconf/gconf-schema.h>
+-}
+
+ namespace Gnome
+ {
+diff -Naur gconfmm-2.28.3-original/gconf/src/schema.hg gconfmm-2.28.3/gconf/src/schema.hg
+--- gconfmm-2.28.3-original/gconf/src/schema.hg 2011-10-18 11:33:49.000000000 -0400
++++ gconfmm-2.28.3/gconf/src/schema.hg 2021-02-13 09:21:58.002568546 -0500
+@@ -24,10 +24,8 @@
+
+ _DEFS(gconfmm,gconf)
+
+-extern "C" {
+- // TODO: do not include this.
++// TODO: do not include this.
+ #include <gconf/gconf-schema.h>
+-}
+
+ namespace Gnome
+ {
diff --git a/dev-cpp/gconfmm/gconfmm-2.28.3-r1.ebuild b/dev-cpp/gconfmm/gconfmm-2.28.3-r1.ebuild
index 5fc75bb2c584..745c74a92947 100644
--- a/dev-cpp/gconfmm/gconfmm-2.28.3-r1.ebuild
+++ b/dev-cpp/gconfmm/gconfmm-2.28.3-r1.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
+EAPI=7
GNOME_TARBALL_SUFFIX="bz2"
inherit flag-o-matic gnome2
@@ -14,27 +12,21 @@ HOMEPAGE="https://www.gtkmm.org"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~ia64 ppc ppc64 sparc x86"
-IUSE="doc"
-RDEPEND="
+DEPEND="
>=gnome-base/gconf-2.4:2
- >=dev-cpp/glibmm-2.12:2[doc?]
+ >=dev-cpp/glibmm-2.12:2
>=dev-cpp/gtkmm-2.4:2.4
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-extern-c-glib-includes.patch
+)
src_configure() {
append-cxxflags -std=c++11 #568580
gnome2_src_configure \
- $(use_enable doc documentation)
-}
-
-src_install() {
- gnome2_src_install
-
- if use doc ; then
- dohtml -r docs/reference/html/*
- fi
+ --disable-documentation
}