summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-08-13 01:46:20 -0300
committerMatt Turner <mattst88@gentoo.org>2023-08-14 09:59:08 -0400
commit243867da454774b698eb6640a5f172724c32219b (patch)
treee9bafb4c09f23b0a594948698ffaf6087aca2dee
parentdev-libs/vala-common: Version bump to 0.56.11 (diff)
downloadgentoo-243867da454774b698eb6640a5f172724c32219b.tar.gz
gentoo-243867da454774b698eb6640a5f172724c32219b.tar.bz2
gentoo-243867da454774b698eb6640a5f172724c32219b.zip
sys-apps/xdg-dbus-proxy: Version bump to 0.1.5
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32279 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sys-apps/xdg-dbus-proxy/Manifest1
-rw-r--r--sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/xdg-dbus-proxy/Manifest b/sys-apps/xdg-dbus-proxy/Manifest
index 2290afccae01..7aebbb90567e 100644
--- a/sys-apps/xdg-dbus-proxy/Manifest
+++ b/sys-apps/xdg-dbus-proxy/Manifest
@@ -1 +1,2 @@
DIST xdg-dbus-proxy-0.1.4.tar.xz 122112 BLAKE2B c7d2898b703c51d6b53838996a0ae74e7a4e163b9611e28dfded54ab1a44c0473fa25daa13e94977c918544e0741bf0dd4747dfcae858468bc4abd288613cb8b SHA512 d50fa916d07f23e080ab53cf290b5d6db73cfd8262253a48b9f012ce6c182e201d0a67efaeb7f28a844d3ef146aa48936dfbe4279a59b909a6dc4419d5f15b04
+DIST xdg-dbus-proxy-0.1.5.tar.xz 124780 BLAKE2B bb9e1c42826ebfab1a93351f43ab09d7280dc27883bfd23d00c8c919bd7b0ea12b87acffe8025d4c41301593c71a98af4ccf10b6c780479e84e020529a8d08bb SHA512 4b079c060aa4c1d7f305216d03166b9edc19cb73ef1230e14a882f07a6400929f62afc8535338c8560ea032a519c0934fbc69533f5bebb555fecb8f090330a33
diff --git a/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.5.ebuild b/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.5.ebuild
new file mode 100644
index 000000000000..9ce21ea18c8e
--- /dev/null
+++ b/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Filtering proxy for D-Bus connections"
+HOMEPAGE="https://github.com/flatpak/xdg-dbus-proxy"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/dbus )
+"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dinstalled_tests=false
+ -Dman=enabled
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}