summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-01-21 21:12:14 +0000
committerSam James <sam@gentoo.org>2024-01-22 05:52:46 +0000
commit26830db60d1c1f3b4579af6dd5f9c4cfe5c4dc73 (patch)
tree8faefac70acb07012756ba29eb0134eac1e28fa6
parentdev-libs/glib: fix Python 3.12 build w/o setuptools (diff)
downloadgentoo-26830db60d1c1f3b4579af6dd5f9c4cfe5c4dc73.tar.gz
gentoo-26830db60d1c1f3b4579af6dd5f9c4cfe5c4dc73.tar.bz2
gentoo-26830db60d1c1f3b4579af6dd5f9c4cfe5c4dc73.zip
net-irc/kvirc: fix forcing of qt5
Closes: https://bugs.gentoo.org/922636 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/34947 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-irc/kvirc/files/kvirc-5.2.0-qtver.patch25
-rw-r--r--net-irc/kvirc/kvirc-5.2.0-r1.ebuild (renamed from net-irc/kvirc/kvirc-5.2.0.ebuild)4
2 files changed, 29 insertions, 0 deletions
diff --git a/net-irc/kvirc/files/kvirc-5.2.0-qtver.patch b/net-irc/kvirc/files/kvirc-5.2.0-qtver.patch
new file mode 100644
index 000000000000..9f3700ec9d9b
--- /dev/null
+++ b/net-irc/kvirc/files/kvirc-5.2.0-qtver.patch
@@ -0,0 +1,25 @@
+From a301aa4998c4f0040d093cd2950b7b2f4ec4dcdc Mon Sep 17 00:00:00 2001
+From: Alexey Sokolov <sokolov@google.com>
+Date: Sun, 21 Jan 2024 21:07:37 +0000
+Subject: [PATCH] Fix ability to select Qt5 vs Qt6
+
+https://bugs.gentoo.org/922636
+---
+ CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index aabc0988b..9368e81c9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -389,7 +389,9 @@ endif()
+ ############################################################################
+
+ # first check if Qt6 or Qt5 has to be used
+-find_package(QT NAMES Qt6 Qt5 REQUIRED COMPONENTS Core)
++if(NOT DEFINED QT_VERSION_MAJOR)
++ find_package(QT NAMES Qt6 Qt5 REQUIRED COMPONENTS Core)
++endif()
+ # second, detect available modules for the specific Qt version
+ find_package(Qt${QT_VERSION_MAJOR} REQUIRED COMPONENTS Widgets)
+ if(Qt${QT_VERSION_MAJOR}Widgets_FOUND)
diff --git a/net-irc/kvirc/kvirc-5.2.0.ebuild b/net-irc/kvirc/kvirc-5.2.0-r1.ebuild
index aff1e010cbc6..9e0cd048be85 100644
--- a/net-irc/kvirc/kvirc-5.2.0.ebuild
+++ b/net-irc/kvirc/kvirc-5.2.0-r1.ebuild
@@ -66,6 +66,10 @@ RDEPEND="${DEPEND}
DOCS=()
+PATCHES=(
+ "${FILESDIR}/kvirc-5.2.0-qtver.patch"
+)
+
pkg_setup() {
if use python; then
python-single-r1_pkg_setup