summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-12 13:19:04 +0100
committerSam James <sam@gentoo.org>2023-10-13 00:20:10 +0100
commit26b63ca65cd33d9cd6e6abda3e0a4d1b8641383a (patch)
tree00eabcbac3ca49c1ed1eb025338b2c2a6cd17887
parentdev-util/idea-community: drop 2023.2.2 (diff)
downloadgentoo-26b63ca65cd33d9cd6e6abda3e0a4d1b8641383a.tar.gz
gentoo-26b63ca65cd33d9cd6e6abda3e0a4d1b8641383a.tar.bz2
gentoo-26b63ca65cd33d9cd6e6abda3e0a4d1b8641383a.zip
app-arch/pigz: drop 2.7, 2.7-r1, 2.7-r2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-arch/pigz/Manifest1
-rw-r--r--app-arch/pigz/files/pigz-2.7-memcpy-ub.patch26
-rw-r--r--app-arch/pigz/files/pigz-2.7-zlib-1.3.patch22
-rw-r--r--app-arch/pigz/pigz-2.7-r1.ebuild38
-rw-r--r--app-arch/pigz/pigz-2.7-r2.ebuild41
-rw-r--r--app-arch/pigz/pigz-2.7.ebuild34
6 files changed, 0 insertions, 162 deletions
diff --git a/app-arch/pigz/Manifest b/app-arch/pigz/Manifest
index 4b2303ab8543..4fddcc524d11 100644
--- a/app-arch/pigz/Manifest
+++ b/app-arch/pigz/Manifest
@@ -1,3 +1,2 @@
-DIST pigz-2.7.tar.gz 108102 BLAKE2B d391522fd6f8eb6918d671fb1c9517034941f3ae8e05ffcd7bece141e6dae110cde1560bad02bd2bcca2f868cdba2a8a16b5606ad6637d40d5ced5ec9bfffcc8 SHA512 9f9f61de4a0307fc057dc4e31a98bd8d706d9e709ecde0be02a871534fddf6a1fe1321158aa72708603aaaece43f83d2423b127f7689b6219b23aea4f989e8f5
DIST pigz-2.8.tar.gz 121304 BLAKE2B 9f1ae8b5e0dd9d9b1f17bcdbc41d8a9d50fd9b9ba7c50eb0bc1b738105d05cc396d9ce8e01f58f6b2fa7247a7c7e9926c602a613b1bb3e3a117c8f5c919ce640 SHA512 ae3d9d593e1645d65f9ab77aa828600c9af4bb30d0a073da7ae3dd805e65b87efaf6a0efb980f2d0168e475ae506eba194547d6479956dabb9d88293a9078a7f
DIST pigz-2.8.tar.gz.asc 235 BLAKE2B eb204079597d3e958da3672ba7f92481848bb7824da12b9306ff180add107175bed7bdd435dbc270170769a489c34a033d6ff547e8203cf1d71df6564381b43d SHA512 cb1dbca21d8fed25049693de02abf7489f61407d85f9a52d566c14e0194c6c393aed3edd2fd716d0ecedf7eeead6ae89d0cecc236caacd98740d14bd71e078db
diff --git a/app-arch/pigz/files/pigz-2.7-memcpy-ub.patch b/app-arch/pigz/files/pigz-2.7-memcpy-ub.patch
deleted file mode 100644
index db53660748b4..000000000000
--- a/app-arch/pigz/files/pigz-2.7-memcpy-ub.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-https://github.com/madler/pigz/commit/e1ed230a1599a3cb64c8f5c003cced60e10e3314
-https://github.com/madler/pigz/issues/107
-
-From e1ed230a1599a3cb64c8f5c003cced60e10e3314 Mon Sep 17 00:00:00 2001
-From: Mark Adler <madler@alumni.caltech.edu>
-Date: Sat, 31 Dec 2022 21:28:26 -0800
-Subject: [PATCH] Avoid calling memcpy() with a NULL pointer.
-
-This is not permitted by the C99 standard even when the length is
-zero. Go figure.
---- a/pigz.c
-+++ b/pigz.c
-@@ -3414,8 +3414,10 @@ local int outb(void *desc, unsigned char *buf, unsigned len) {
-
- // copy the output and alert the worker bees
- out_len = len;
-- g.out_tot += len;
-- memcpy(out_copy, buf, len);
-+ if (len) {
-+ g.out_tot += len;
-+ memcpy(out_copy, buf, len);
-+ }
- twist(outb_write_more, TO, 1);
- twist(outb_check_more, TO, 1);
-
-
diff --git a/app-arch/pigz/files/pigz-2.7-zlib-1.3.patch b/app-arch/pigz/files/pigz-2.7-zlib-1.3.patch
deleted file mode 100644
index 232dc3787ab7..000000000000
--- a/app-arch/pigz/files/pigz-2.7-zlib-1.3.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://github.com/madler/pigz/issues/111
-https://github.com/madler/pigz/commit/907ca0763be4547a9b0cce8c1057217488149744
-
-From 907ca0763be4547a9b0cce8c1057217488149744 Mon Sep 17 00:00:00 2001
-From: Mark Adler <madler@alumni.caltech.edu>
-Date: Fri, 18 Aug 2023 03:27:12 -0700
-Subject: [PATCH] Make pigz compatible with two-component zlib version numbers.
-
-zlib 1.3 (not 1.3.0) broke the zlib_vernum() function in pigz.
-This commit fixes that.
---- a/pigz.c
-+++ b/pigz.c
-@@ -1333,7 +1333,7 @@ local long zlib_vernum(void) {
- }
- ver++;
- } while (left);
-- return left < 2 ? num << (left << 2) : -1;
-+ return left < 3 ? num << (left << 2) : -1;
- }
-
- // -- check value combination routines for parallel calculation --
-
diff --git a/app-arch/pigz/pigz-2.7-r1.ebuild b/app-arch/pigz/pigz-2.7-r1.ebuild
deleted file mode 100644
index c07380f70b83..000000000000
--- a/app-arch/pigz/pigz-2.7-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="A parallel implementation of gzip"
-HOMEPAGE="https://www.zlib.net/pigz/"
-SRC_URI="https://www.zlib.net/pigz/${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~ppc-macos"
-IUSE="static test"
-RESTRICT="!test? ( test )"
-
-LIB_DEPEND=">=sys-libs/zlib-1.2.3[static-libs(+)]"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
- test? ( app-arch/ncompress )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-memcpy-ub.patch
-)
-
-src_compile() {
- use static && append-ldflags -static
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin ${PN}
- dosym ${PN} /usr/bin/un${PN}
- dodoc README
- doman ${PN}.1
-}
diff --git a/app-arch/pigz/pigz-2.7-r2.ebuild b/app-arch/pigz/pigz-2.7-r2.ebuild
deleted file mode 100644
index 6bbbc55c5601..000000000000
--- a/app-arch/pigz/pigz-2.7-r2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="A parallel implementation of gzip"
-HOMEPAGE="https://www.zlib.net/pigz/"
-SRC_URI="https://www.zlib.net/pigz/${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos"
-IUSE="static test"
-RESTRICT="!test? ( test )"
-
-LIB_DEPEND=">=sys-libs/zlib-1.2.3[static-libs(+)]"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="
- ${RDEPEND}
- static? ( ${LIB_DEPEND} )
- test? ( app-arch/ncompress )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-memcpy-ub.patch
- "${FILESDIR}"/${P}-zlib-1.3.patch
-)
-
-src_compile() {
- use static && append-ldflags -static
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin ${PN}
- dosym ${PN} /usr/bin/un${PN}
- dodoc README
- doman ${PN}.1
-}
diff --git a/app-arch/pigz/pigz-2.7.ebuild b/app-arch/pigz/pigz-2.7.ebuild
deleted file mode 100644
index 1c9e4f93cec3..000000000000
--- a/app-arch/pigz/pigz-2.7.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="A parallel implementation of gzip"
-HOMEPAGE="https://www.zlib.net/pigz/"
-SRC_URI="https://www.zlib.net/pigz/${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~ppc-macos"
-IUSE="static test"
-RESTRICT="!test? ( test )"
-
-LIB_DEPEND=">=sys-libs/zlib-1.2.3[static-libs(+)]"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
- test? ( app-arch/ncompress )"
-
-src_compile() {
- use static && append-ldflags -static
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin ${PN}
- dosym ${PN} /usr/bin/un${PN}
- dodoc README
- doman ${PN}.1
-}