summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-12 23:41:46 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-13 22:54:37 +0200
commit26d78938d4d485a5e80dc9c92b67736e06159cea (patch)
tree1ae178d151059bb8ceb3a3a0837751f3b9132d49
parentnet-analyzer/netperf: drop old version (diff)
downloadgentoo-26d78938d4d485a5e80dc9c92b67736e06159cea.tar.gz
gentoo-26d78938d4d485a5e80dc9c92b67736e06159cea.tar.bz2
gentoo-26d78938d4d485a5e80dc9c92b67736e06159cea.zip
net-analyzer/scanlogd: migrate to GLEP 81
Bug: https://bugs.gentoo.org/781356 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.7-r1.ebuild50
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.8-r1.ebuild55
2 files changed, 105 insertions, 0 deletions
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.7-r1.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.7-r1.ebuild
new file mode 100644
index 000000000000..7598563d3815
--- /dev/null
+++ b/net-analyzer/scanlogd/scanlogd-2.2.7-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="A port scan detection tool"
+SRC_URI="http://www.openwall.com/scanlogd/${P}.tar.gz"
+HOMEPAGE="http://www.openwall.com/scanlogd/"
+
+LICENSE="scanlogd GPL-2" # GPL-2 for initscript
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="+nids pcap"
+REQUIRED_USE="?? ( nids pcap )"
+
+DEPEND="
+ nids? ( net-libs/libnids )
+ pcap? ( net-libs/libpcap )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/scanlogd
+ acct-user/scanlogd
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+ restore_config params.h
+ tc-export CC
+}
+
+src_compile() {
+ local target=linux
+ use nids && target=libnids
+ use pcap && target=libpcap
+ emake ${target}
+}
+
+src_install() {
+ dosbin scanlogd
+ doman scanlogd.8
+ newinitd "${FILESDIR}"/scanlogd.rc scanlogd
+ save_config params.h
+}
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.8-r1.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.8-r1.ebuild
new file mode 100644
index 000000000000..df7a9b460ecc
--- /dev/null
+++ b/net-analyzer/scanlogd/scanlogd-2.2.8-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="A port scan detection tool"
+SRC_URI="https://www.openwall.com/scanlogd/${P}.tar.gz"
+HOMEPAGE="https://www.openwall.com/scanlogd/"
+
+LICENSE="scanlogd GPL-2" # GPL-2 for initscript
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+nids pcap"
+REQUIRED_USE="?? ( nids pcap )"
+
+DEPEND="
+ nids? ( net-libs/libnids )
+ pcap? ( net-libs/libpcap )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/scanlogd
+ acct-user/scanlogd
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.7-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ restore_config params.h
+
+ tc-export CC
+}
+
+src_compile() {
+ local target=linux
+
+ use nids && target=libnids
+ use pcap && target=libpcap
+ emake ${target}
+}
+
+src_install() {
+ dosbin scanlogd
+
+ doman scanlogd.8
+ newinitd "${FILESDIR}"/scanlogd.rc scanlogd
+
+ save_config params.h
+}