summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-08-28 22:22:25 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-08-28 22:27:06 +0900
commit2746248be2cb0e7478ebeaaa281ad6645bba0b43 (patch)
treee7b170490a5f505e3fee94f0bd07f17054f01da0
parentp/f/p/s/kernel-2.6.16+/profile.bashrc: no dup3 or pipe2 for ocaml. (diff)
downloadgentoo-2746248be2cb0e7478ebeaaa281ad6645bba0b43.tar.gz
gentoo-2746248be2cb0e7478ebeaaa281ad6645bba0b43.tar.bz2
gentoo-2746248be2cb0e7478ebeaaa281ad6645bba0b43.zip
app-i18n/ibus-hangul: update to EAPI 6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.5.0-r1.ebuild37
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.5.0.ebuild43
-rw-r--r--app-i18n/ibus-hangul/metadata.xml5
3 files changed, 41 insertions, 44 deletions
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.5.0-r1.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..b4eb943e4273
--- /dev/null
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.5.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-single-r1
+
+DESCRIPTION="Hangul engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/choehwanjin/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=app-i18n/libhangul-0.1
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i "s/@PYTHON@/${EPYTHON}/" setup/${PN/-/-setup-}.in
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.5.0.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.5.0.ebuild
deleted file mode 100644
index 38435562f840..000000000000
--- a/app-i18n/ibus-hangul/ibus-hangul-1.5.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="The Hangul engine for IBus input platform"
-HOMEPAGE="https://github.com/ibus/ibus/wiki"
-SRC_URI="https://github.com/choehwanjin/ibus-hangul/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="nls"
-
-RDEPEND=">=app-i18n/ibus-1.4[python,${PYTHON_USEDEP}]
- =dev-python/pygobject-2*[${PYTHON_USEDEP}]
- =dev-python/pygtk-2*[${PYTHON_USEDEP}]
- >=app-i18n/libhangul-0.1
- nls? ( virtual/libintl )
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? (
- dev-util/intltool
- >=sys-devel/gettext-0.17
- )"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-src_prepare() {
- sed -ie "s:python:${EPYTHON}:" \
- setup/ibus-setup-hangul.in || die
-}
-
-src_configure() {
- econf $(use_enable nls)
-}
diff --git a/app-i18n/ibus-hangul/metadata.xml b/app-i18n/ibus-hangul/metadata.xml
index 7f550752e704..9b2935d879d7 100644
--- a/app-i18n/ibus-hangul/metadata.xml
+++ b/app-i18n/ibus-hangul/metadata.xml
@@ -5,7 +5,10 @@
<email>cjk@gentoo.org</email>
<name>Cjk</name>
</maintainer>
- <longdescription lang="en">The Hangul engine for IBus platform. It provides Korean input method from libhangul.</longdescription>
+ <longdescription lang="en">
+ The Hangul engine for IBus. It provides Korean input method from
+ <pkg>app-i18n/libhangul</pkg>.
+ </longdescription>
<upstream>
<remote-id type="google-code">ibus</remote-id>
<remote-id type="github">ibus/ibus</remote-id>