summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-21 11:10:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-21 11:48:10 -0400
commit2789250e7e776e19599bab2da0fd20b4e8ddbe2d (patch)
tree8e5e0c60a9d86e1716562043a08a4f561cbd676a
parentnet-print/pnm2ppa: fix build w/ upcoming clang16 (diff)
downloadgentoo-2789250e7e776e19599bab2da0fd20b4e8ddbe2d.tar.gz
gentoo-2789250e7e776e19599bab2da0fd20b4e8ddbe2d.tar.bz2
gentoo-2789250e7e776e19599bab2da0fd20b4e8ddbe2d.zip
x11-misc/ktsuss: EAPI6->8, fix deps and build w/ clang16
bug #781185 could have two causes, either no su(1) or no which(1) given neither are guaranteed. Closes: https://bugs.gentoo.org/781185 Closes: https://bugs.gentoo.org/874540 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-misc/ktsuss/files/ktsuss-2.1-clang16.patch29
-rw-r--r--x11-misc/ktsuss/files/ktsuss-2.1-no-which.patch13
-rw-r--r--x11-misc/ktsuss/ktsuss-2.1-r1.ebuild45
-rw-r--r--x11-misc/ktsuss/ktsuss-2.1.ebuild32
4 files changed, 87 insertions, 32 deletions
diff --git a/x11-misc/ktsuss/files/ktsuss-2.1-clang16.patch b/x11-misc/ktsuss/files/ktsuss-2.1-clang16.patch
new file mode 100644
index 000000000000..e0763c688a62
--- /dev/null
+++ b/x11-misc/ktsuss/files/ktsuss-2.1-clang16.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/874540
+--- a/src/ktsuss.c
++++ b/src/ktsuss.c
+@@ -38,2 +38,3 @@
+ #include <sys/types.h>
++#include <err.h>
+ #include <errno.h>
+--- a/src/su_backend.c
++++ b/src/su_backend.c
+@@ -40,2 +40,3 @@
+ #include <sys/types.h>
++#include <err.h>
+ #include <errno.h>
+@@ -54,2 +55,4 @@
+
++void tty_raw(int ttyfd);
++
+ static struct termios orig_termios;
+--- a/src/sudo_backend.c
++++ b/src/sudo_backend.c
+@@ -40,2 +40,3 @@
+ #include <sys/types.h>
++#include <err.h>
+ #include <errno.h>
+@@ -55,2 +56,4 @@
+
++void tty_raw(int ttyfd);
++
+ static struct termios orig_termios;
diff --git a/x11-misc/ktsuss/files/ktsuss-2.1-no-which.patch b/x11-misc/ktsuss/files/ktsuss-2.1-no-which.patch
new file mode 100644
index 000000000000..12909025c18c
--- /dev/null
+++ b/x11-misc/ktsuss/files/ktsuss-2.1-no-which.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/781185
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,3 +25,3 @@
+ AC_MSG_CHECKING([whether we can locate the su program])
+- supath=`which su 2>/dev/null`
++ supath=`command -v su 2>/dev/null`
+ if test "x$supath" = "x"; then
+@@ -36,3 +36,3 @@
+ AC_MSG_CHECKING([whether we can locate the sudo program])
+- sudopath=`which sudo 2>/dev/null`
++ sudopath=`command -v sudo 2>/dev/null`
+ if test "x$sudopath" = "x"; then
diff --git a/x11-misc/ktsuss/ktsuss-2.1-r1.ebuild b/x11-misc/ktsuss/ktsuss-2.1-r1.ebuild
new file mode 100644
index 000000000000..87718a586671
--- /dev/null
+++ b/x11-misc/ktsuss/ktsuss-2.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Graphical version of su written in C and GTK+ 2"
+HOMEPAGE="https://github.com/nomius/ktsuss/"
+SRC_URI="https://github.com/nomius/ktsuss/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 x86"
+IUSE="sudo"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ sudo? ( app-admin/sudo )
+ !sudo? (
+ || (
+ sys-apps/util-linux[su]
+ sys-apps/shadow[su]
+ )
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( Changelog CREDITS README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+ "${FILESDIR}"/${P}-no-which.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable sudo)
+}
diff --git a/x11-misc/ktsuss/ktsuss-2.1.ebuild b/x11-misc/ktsuss/ktsuss-2.1.ebuild
deleted file mode 100644
index 957f0076fb18..000000000000
--- a/x11-misc/ktsuss/ktsuss-2.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Graphical version of su written in C and GTK+ 2"
-HOMEPAGE="https://github.com/nomius/ktsuss"
-SRC_URI="https://github.com/nomius/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~mips ppc ppc64 x86"
-IUSE="sudo"
-
-RDEPEND=">=x11-libs/gtk+-2.12.11:2
- >=dev-libs/glib-2.16.5:2
- sudo? ( app-admin/sudo )"
-DEPEND="virtual/pkgconfig
- ${RDEPEND}"
-
-DOCS=( Changelog CREDITS README.md )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable sudo)
-}