summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-03-30 22:18:19 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-03-30 22:20:57 +0000
commit281de830dfe4c182cce589b1befa90cf946e5a29 (patch)
tree3712534aab934bfcbd01ff7248ad19876ef8cc2b
parentdev-util/quilt: Add zstd dependency (diff)
downloadgentoo-281de830dfe4c182cce589b1befa90cf946e5a29.tar.gz
gentoo-281de830dfe4c182cce589b1befa90cf946e5a29.tar.bz2
gentoo-281de830dfe4c182cce589b1befa90cf946e5a29.zip
games-engines/odamex: Unconditionally depend on X11
Although the SDL-based client itself doesn't strictly need X11, the FLTK-based launcher currently does, regardless of whether you use the bundled FLTK or not, so we might as well depend on X11 unconditionally. Conversely, the wxWidgets-based odalaunch doesn't need X11 and seems to work fine under pure Wayland, so adjust the wxGTK dependency accordingly. Closes: https://bugs.gentoo.org/890299 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-engines/odamex/odamex-10.4.0-r3.ebuild (renamed from games-engines/odamex/odamex-10.4.0-r2.ebuild)7
1 files changed, 3 insertions, 4 deletions
diff --git a/games-engines/odamex/odamex-10.4.0-r2.ebuild b/games-engines/odamex/odamex-10.4.0-r3.ebuild
index 97ddf96efce4..de72a4d61655 100644
--- a/games-engines/odamex/odamex-10.4.0-r2.ebuild
+++ b/games-engines/odamex/odamex-10.4.0-r3.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${PN}-src-${PV}.
LICENSE="GPL-2+ MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="+client hidpi master +odalaunch portmidi server upnp X"
+IUSE="+client hidpi master +odalaunch portmidi server upnp"
REQUIRED_USE="|| ( client master server )"
# protobuf is still bundled. Unfortunately an old version is required for C++98
@@ -26,11 +26,11 @@ RDEPEND="
media-libs/libsdl2[joystick,sound,video]
media-libs/sdl2-mixer
net-misc/curl
+ x11-libs/libX11
!hidpi? ( x11-libs/fltk:1 )
portmidi? ( media-libs/portmidi )
- X? ( x11-libs/libX11 )
)
- odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+ odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER} )
server? (
dev-libs/jsoncpp:=
upnp? ( net-libs/miniupnpc:= )
@@ -70,7 +70,6 @@ src_configure() {
-DENABLE_PORTMIDI=$(usex portmidi)
-DUSE_MINIUPNP=$(usex upnp)
)
- use client && mycmakeargs+=(-DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X))
cmake_src_configure
}