summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-04-29 16:28:41 +0300
committerConrad Kostecki <conikost@gentoo.org>2023-04-30 00:13:08 +0200
commit281f81b18d12203f0992d37cfe1c2dbb71c58ce7 (patch)
tree4e35966667fb2dae2cdc98812e3eb2dfea56ec67
parentsys-fs/dmg2img: EAPI8 bump (diff)
downloadgentoo-281f81b18d12203f0992d37cfe1c2dbb71c58ce7.tar.gz
gentoo-281f81b18d12203f0992d37cfe1c2dbb71c58ce7.tar.bz2
gentoo-281f81b18d12203f0992d37cfe1c2dbb71c58ce7.zip
app-misc/esekeyd: fix revision generation
Fix revision generation based on upstream commits. Closes: https://bugs.gentoo.org/905271 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-misc/esekeyd/esekeyd-1.2.7-r2.ebuild26
-rw-r--r--app-misc/esekeyd/files/1.2.7-fix-revision.patch66
2 files changed, 92 insertions, 0 deletions
diff --git a/app-misc/esekeyd/esekeyd-1.2.7-r2.ebuild b/app-misc/esekeyd/esekeyd-1.2.7-r2.ebuild
new file mode 100644
index 000000000000..76b688ceeeaf
--- /dev/null
+++ b/app-misc/esekeyd/esekeyd-1.2.7-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Multimedia key daemon that uses the Linux event interface"
+HOMEPAGE="https://github.com/burghardt/esekeyd"
+SRC_URI="https://github.com/burghardt/esekeyd/archive/refs/tags/${P}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/1.2.7-fix-revision.patch"
+)
+
+DOCS=( AUTHORS ChangeLog examples/example.conf NEWS README TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}
diff --git a/app-misc/esekeyd/files/1.2.7-fix-revision.patch b/app-misc/esekeyd/files/1.2.7-fix-revision.patch
new file mode 100644
index 000000000000..af59712c3ce7
--- /dev/null
+++ b/app-misc/esekeyd/files/1.2.7-fix-revision.patch
@@ -0,0 +1,66 @@
+From 28bd6caa3401b2e79fa4c922ecc2d5d1ada8460f Mon Sep 17 00:00:00 2001
+From: Krzysztof Burghardt <krzysztof@burghardt.pl>
+Date: Tue, 11 Aug 2015 07:03:34 +0200
+Subject: [PATCH] Include git describe output in each binary.
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -9,5 +9,12 @@ version.h:
+ endif
+ echo \#define PACKAGE_VERSION_SVN_REV \"SVN-r`svnversion`\" > version.h
+
++if DOT_GIT
++version.h: .git/HEAD .git/index
++else
++version.h:
++endif
++ echo \#define PACKAGE_VERSION_SVN_REV \"GIT-`git describe --dirty --always --tags`\" > version.h
++
+ all: config.h version.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,6 +4,7 @@ AC_CONFIG_SRCDIR(src/esekeyd.c)
+ AM_CONFIG_HEADER(config.h)
+ AM_INIT_AUTOMAKE
+ AM_CONDITIONAL([DOT_SVN], [test -f .svn/entries])
++AM_CONDITIONAL([DOT_GIT], [test -f .git/index])
+
+ if test "$CFLAGS"; then
+ CFLAGS_CUSTOM=yes
+From dbac719dfd8d0d4aa4fe4699c73772553d7566f7 Mon Sep 17 00:00:00 2001
+From: Krzysztof Burghardt <krzysztof@burghardt.pl>
+Date: Thu, 13 Aug 2015 22:30:17 +0200
+Subject: [PATCH] Do not override all:, use BUILT_SOURCES for version.h
+ generation.
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,20 +1,20 @@
+ SUBDIRS = src doc examples
+
++BUILT_SOURCES = version.h
+ EXTRA_DIST = version.h
+
+ if DOT_SVN
+ version.h: .svn/entries
+-else
+-version.h:
+-endif
+ echo \#define PACKAGE_VERSION_SVN_REV \"SVN-r`svnversion`\" > version.h
+-
++else
+ if DOT_GIT
+ version.h: .git/HEAD .git/index
++ echo \#define PACKAGE_VERSION_SVN_REV \"GIT-`git describe --dirty --always --tags`\" > version.h
+ else
+ version.h:
++ echo \#define PACKAGE_VERSION_SVN_REV \"unknown\" > version.h
++endif
+ endif
+- echo \#define PACKAGE_VERSION_SVN_REV \"GIT-`git describe --dirty --always --tags`\" > version.h
+
+-all: config.h version.h
+- $(MAKE) $(AM_MAKEFLAGS) all-recursive
++clean-local:
++ rm -f version.h