summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2022-05-02 15:58:23 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-05-02 16:24:41 +0800
commit284e771bd39b4709afddcc3dd666f5f8665c3754 (patch)
tree935c39f13c9d6feefa778f67cccf87612ede09c2
parentdev-python/libvirt-python: Stabilize 8.2.0 x86, #841884 (diff)
downloadgentoo-284e771bd39b4709afddcc3dd666f5f8665c3754.tar.gz
gentoo-284e771bd39b4709afddcc3dd666f5f8665c3754.tar.bz2
gentoo-284e771bd39b4709afddcc3dd666f5f8665c3754.zip
sci-libs/hipCUB: loosen the dependency on dev-util/hip
sci-libs/hipSPARSE: sci-libs/rocPRIM: sci-libs/rocRAND: sci-libs/rocSOLVER: sci-libs/rocSPARSE: same The possibility is pointed out by Cory Bloor: You can probably build the versions of rocBLAS and rocSOLVER tagged at rocm-5.1.1 with the HIP stack from ROCm 4.3.1. Just be sure to rebuild all the {roc,hip}{BLAS,SOLVER} libraries at the new tag, since they all use private (unstable) APIs provided by rocBLAS. The sci-libs/* ROCm packages should be aligned with sci-libs/rocBLAS, while the other dev-*/* ROCm packages should be aligned with dev-util/hip. Credit: Cory Bloor Suggested-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Closes: https://bugs.gentoo.org/838394 Closes: https://bugs.gentoo.org/841982 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--sci-libs/hipCUB/hipCUB-4.3.0-r1.ebuild (renamed from sci-libs/hipCUB/hipCUB-4.3.0.ebuild)4
-rw-r--r--sci-libs/hipSPARSE/hipSPARSE-4.3.0-r2.ebuild (renamed from sci-libs/hipSPARSE/hipSPARSE-4.3.0-r1.ebuild)6
-rw-r--r--sci-libs/rocPRIM/rocPRIM-4.3.0-r2.ebuild (renamed from sci-libs/rocPRIM/rocPRIM-4.3.0-r1.ebuild)4
-rw-r--r--sci-libs/rocRAND/rocRAND-4.3.0-r1.ebuild (renamed from sci-libs/rocRAND/rocRAND-4.3.0.ebuild)4
-rw-r--r--sci-libs/rocSOLVER/rocSOLVER-4.3.0-r1.ebuild (renamed from sci-libs/rocSOLVER/rocSOLVER-4.3.0.ebuild)2
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-4.3.0-r3.ebuild (renamed from sci-libs/rocSPARSE/rocSPARSE-4.3.0-r2.ebuild)2
6 files changed, 11 insertions, 11 deletions
diff --git a/sci-libs/hipCUB/hipCUB-4.3.0.ebuild b/sci-libs/hipCUB/hipCUB-4.3.0-r1.ebuild
index 0b57014f6d15..65b61c2352cc 100644
--- a/sci-libs/hipCUB/hipCUB-4.3.0.ebuild
+++ b/sci-libs/hipCUB/hipCUB-4.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,7 +15,7 @@ SLOT="0/$(ver_cut 1-2)"
IUSE="benchmark test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-util/hip:${SLOT}
+RDEPEND="dev-util/hip
sci-libs/rocPRIM:${SLOT}
benchmark? ( dev-cpp/benchmark )"
DEPEND="${RDEPEND}"
diff --git a/sci-libs/hipSPARSE/hipSPARSE-4.3.0-r1.ebuild b/sci-libs/hipSPARSE/hipSPARSE-4.3.0-r2.ebuild
index 9acb3016c001..c246c94db511 100644
--- a/sci-libs/hipSPARSE/hipSPARSE-4.3.0-r1.ebuild
+++ b/sci-libs/hipSPARSE/hipSPARSE-4.3.0-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake
+inherit cmake toolchain-funcs
DESCRIPTION="ROCm SPARSE marshalling library"
HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipSPARSE"
@@ -38,8 +38,8 @@ IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-util/rocminfo:${SLOT}
- dev-util/hip:${SLOT}
+RDEPEND="dev-util/rocminfo
+ dev-util/hip
sci-libs/rocSPARSE:${SLOT}"
DEPEND="${RDEPEND}"
BDEPEND="dev-util/rocm-cmake
diff --git a/sci-libs/rocPRIM/rocPRIM-4.3.0-r1.ebuild b/sci-libs/rocPRIM/rocPRIM-4.3.0-r2.ebuild
index 0e7bba7b2a7c..eba4e1317b94 100644
--- a/sci-libs/rocPRIM/rocPRIM-4.3.0-r1.ebuild
+++ b/sci-libs/rocPRIM/rocPRIM-4.3.0-r2.ebuild
@@ -14,9 +14,9 @@ KEYWORDS="~amd64"
SLOT="0/$(ver_cut 1-2)"
IUSE="benchmark test"
-RDEPEND="dev-util/hip:${SLOT}
+RDEPEND="dev-util/hip
benchmark? ( dev-cpp/benchmark )"
-BDEPEND="dev-util/rocm-cmake:${SLOT}
+BDEPEND="dev-util/rocm-cmake
>=dev-util/cmake-3.22
test? ( dev-cpp/gtest )"
DEPEND="${RDEPEND}"
diff --git a/sci-libs/rocRAND/rocRAND-4.3.0.ebuild b/sci-libs/rocRAND/rocRAND-4.3.0-r1.ebuild
index 926f784a0249..074ee2912a97 100644
--- a/sci-libs/rocRAND/rocRAND-4.3.0.ebuild
+++ b/sci-libs/rocRAND/rocRAND-4.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,7 +15,7 @@ SLOT="0/$(ver_cut 1-2)"
IUSE="benchmark test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-util/hip:${SLOT}"
+RDEPEND="dev-util/hip"
DEPEND="${RDEPEND}
>=dev-util/rocm-cmake-${PV}"
BDEPEND="test? ( dev-cpp/gtest )"
diff --git a/sci-libs/rocSOLVER/rocSOLVER-4.3.0.ebuild b/sci-libs/rocSOLVER/rocSOLVER-4.3.0-r1.ebuild
index c017b7ad31a0..6287d7b096d5 100644
--- a/sci-libs/rocSOLVER/rocSOLVER-4.3.0.ebuild
+++ b/sci-libs/rocSOLVER/rocSOLVER-4.3.0-r1.ebuild
@@ -15,7 +15,7 @@ SLOT="0/$(ver_cut 1-2)"
IUSE="test benchmark"
-RDEPEND="dev-util/hip:${SLOT}
+RDEPEND="dev-util/hip
sci-libs/rocBLAS:${SLOT}
benchmark? ( virtual/blas )"
DEPEND="${RDEPEND}"
diff --git a/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r2.ebuild b/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r3.ebuild
index 208d02f6cc3d..f32d34643e14 100644
--- a/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r2.ebuild
+++ b/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r3.ebuild
@@ -43,7 +43,7 @@ KEYWORDS="~amd64"
IUSE="benchmark test"
SLOT="0/$(ver_cut 1-2)"
-RDEPEND="dev-util/hip:${SLOT}
+RDEPEND="dev-util/hip
sci-libs/rocPRIM:${SLOT}"
DEPEND="${RDEPEND}"
BDEPEND="test? (