summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-03 20:26:18 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-03 20:26:47 -0500
commit2900be0da7fbad59b5b711c18a247d19c08de7d1 (patch)
tree4faa827c4d1496e9ebd605ff651a0e0263480ef9
parentsys-kernel/gentoo-sources: hppa stable (bug #743859) (diff)
downloadgentoo-2900be0da7fbad59b5b711c18a247d19c08de7d1.tar.gz
gentoo-2900be0da7fbad59b5b711c18a247d19c08de7d1.tar.bz2
gentoo-2900be0da7fbad59b5b711c18a247d19c08de7d1.zip
app-admin/ansible: fix upgrade and unify ebuilds (live)
closes: https://bugs.gentoo.org/746398 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible/ansible-2.10.0.ebuild19
-rw-r--r--app-admin/ansible/ansible-9999.ebuild24
2 files changed, 32 insertions, 11 deletions
diff --git a/app-admin/ansible/ansible-2.10.0.ebuild b/app-admin/ansible/ansible-2.10.0.ebuild
index b2456b17b30d..70df6adeb905 100644
--- a/app-admin/ansible/ansible-2.10.0.ebuild
+++ b/app-admin/ansible/ansible-2.10.0.ebuild
@@ -4,17 +4,25 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1 eutils
DESCRIPTION="Model-driven deployment, config management, and command execution framework"
HOMEPAGE="https://ansible.com/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+fi
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
IUSE="doc test"
RESTRICT="test"
@@ -49,7 +57,10 @@ DEPEND="
dev-vcs/git
)"
-ANSIBLE_SKIP_CONFLICT_CHECK=1
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
python_compile_all() {
if use doc; then
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
index 6ff1f27cd47b..546b4d203b3a 100644
--- a/app-admin/ansible/ansible-9999.ebuild
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -4,13 +4,22 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
-inherit distutils-r1 git-r3 eutils
+inherit distutils-r1 eutils
DESCRIPTION="Model-driven deployment, config management, and command execution framework"
HOMEPAGE="https://ansible.com/"
-EGIT_REPO_URI="https://github.com/ansible/ansible.git"
-EGIT_BRANCH="devel"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+fi
LICENSE="GPL-3"
SLOT="0"
@@ -22,7 +31,6 @@ RDEPEND="
dev-python/paramiko[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
@@ -34,7 +42,6 @@ RDEPEND="
"
DEPEND="
!app-admin/ansible-base
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/packaging-16.6[${PYTHON_USEDEP}]
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
@@ -51,6 +58,11 @@ DEPEND="
dev-vcs/git
)"
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
python_compile_all() {
if use doc; then
cd docs/docsite || die
@@ -66,6 +78,4 @@ python_test() {
python_install_all() {
use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
distutils-r1_python_install_all
-
- dodoc -r examples
}