summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2023-06-18 17:07:17 -0700
committerJoonas Niilola <juippis@gentoo.org>2023-07-14 09:50:36 +0300
commit293a95e11dbb507926fdc931024ddd044302b20f (patch)
tree18441644b13fbed64846ce95a1e6f408a86763d6
parentsys-firmware/broadcom-bt-firmware: drop 12.0.1.1105_p4 (diff)
downloadgentoo-293a95e11dbb507926fdc931024ddd044302b20f.tar.gz
gentoo-293a95e11dbb507926fdc931024ddd044302b20f.tar.bz2
gentoo-293a95e11dbb507926fdc931024ddd044302b20f.zip
net-irc/inspircd: add 3.16.1
Signed-off-by: Wade Cline <wadecline@hotmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-irc/inspircd/Manifest2
-rw-r--r--net-irc/inspircd/inspircd-3.16.1.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/net-irc/inspircd/Manifest b/net-irc/inspircd/Manifest
index 2de3a2a36cee..4c9fe9246a01 100644
--- a/net-irc/inspircd/Manifest
+++ b/net-irc/inspircd/Manifest
@@ -2,3 +2,5 @@ DIST inspircd-3.15.0-fix-build-paths.patch.bz2 4733 BLAKE2B 72bc94f8feb5620ce8bd
DIST inspircd-3.15.0.tar.gz 874629 BLAKE2B 50dd2cdba497e85da6d72c22f612cae5944f2a654783d6edc673e956a33132c539ab71bc7ab9647468bd96cc3e2c73031a300e39df0753886af8ac532d07b696 SHA512 32d10cd7f6a06c79720c138fc4aff3c8db667754c7a2fe3ad7c07a1e56604bedcf17e3dd5d5f54a6fd49b37414acd57b97afc1d4accbf3e5fbd92b483fe6c394
DIST inspircd-3.16.0-fix-build-paths.patch.bz2 4737 BLAKE2B 40099378213c5a5b65e7c856255a0dc70a8e026f9b868ab6b79656478b7ba3193bc18c8861c0909936ba56b73b1c3cb8a8dd5e2f435573e480c505d173966e85 SHA512 be8e37107e3c12b7175c02b0e1628fe932284f247c14ed39a9bc8a7212d3d79dd070bf7472b6b47f084388ef5bf28118f5f2a6282e2363d970918147a9a558e3
DIST inspircd-3.16.0.tar.gz 877665 BLAKE2B 0a07dd00c9092a263a0eab9934ea1a2675aee72438803a4e4d2376a3b622f51211f9586f9300282dde7009fbae583164d1c6892f69cb031e9714a0d410df09b1 SHA512 dfbdb306e79d9a7788cf6c474bfd1d0ce34ea6b3b08e2ab880985d272028a61a6d6257b7b573554f3edd5a51b8d3a29c364beca78caeddd79b251df11e369479
+DIST inspircd-3.16.1-fix-build-paths.patch.bz2 4751 BLAKE2B 78ae06bfbdd6d389af2890aadebc5765f16d1616bb9c1b8820a21b2f2a283f4f4aea5bc4f7edc5d61acc80da67ca80a2d0b007a669cf7a37f1ea77b11f552643 SHA512 1fec0c784a1d306a62c9a5320236bfb53bffd4278bbcc8439ea640500b8668cec4e6c23174d1d88f8109bc88549c931ff889b4c07a8f0f5446bb85a434665702
+DIST inspircd-3.16.1.tar.gz 877817 BLAKE2B a54992c32a13a512bce93157b23a17d433fbdbf7efcaa54a66be17628335db379d0abbb14e22a455e069fd8fb2a1f3e0152a112acbe634e6de87208b4a1b8cd5 SHA512 2b488858b0012bcb3eb92a33960e9927c861587c7b7451a47fd3e10a97fad9c392524d98712593fd455c5cbae7fd1779e4b90b9e55680c2f36b483e0acf2bba5
diff --git a/net-irc/inspircd/inspircd-3.16.1.ebuild b/net-irc/inspircd/inspircd-3.16.1.ebuild
new file mode 100644
index 000000000000..7df864d182dd
--- /dev/null
+++ b/net-irc/inspircd/inspircd-3.16.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Inspire IRCd - The Stable, High-Performance Modular IRCd"
+HOMEPAGE="https://www.inspircd.org/"
+SRC_URI="
+ https://github.com/inspircd/inspircd/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/clinew/gentoo-distfiles/raw/master/inspircd-${PV}-fix-build-paths.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="argon2 debug gnutls ldap maxminddb mbedtls mysql pcre pcre2 postgres re2 regex-posix regex-stdlib sqlite ssl sslrehashsignal tre"
+
+RDEPEND="
+ acct-group/inspircd
+ acct-user/inspircd
+ dev-lang/perl
+ argon2? ( app-crypt/argon2 )
+ gnutls? ( net-libs/gnutls:= dev-libs/libgcrypt:0 )
+ ldap? ( net-nds/openldap:= )
+ maxminddb? ( dev-libs/libmaxminddb:= )
+ mbedtls? ( net-libs/mbedtls:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ pcre? ( dev-libs/libpcre )
+ pcre2? ( dev-libs/libpcre2 )
+ postgres? ( dev-db/postgresql:= )
+ re2? ( dev-libs/re2:= )
+ sqlite? ( >=dev-db/sqlite-3.0 )
+ ssl? ( dev-libs/openssl:= )
+ tre? ( dev-libs/tre )"
+DEPEND="${RDEPEND}"
+
+DOCS=( docs/. .configure/apparmor )
+PATCHES=( "${WORKDIR}"/${P}-fix-build-paths.patch )
+
+src_configure() {
+ local extras=""
+
+ use argon2 && extras+="argon2,"
+ use gnutls && extras+="ssl_gnutls,"
+ use ldap && extras+="ldap,"
+ use maxminddb && extras+="geo_maxmind,"
+ use mbedtls && extras+="ssl_mbedtls,"
+ use mysql && extras+="mysql,"
+ use pcre && extras+="regex_pcre,"
+ use pcre2 && extras+="regex_pcre2,"
+ use postgres && extras+="pgsql,"
+ use re2 && extras+="regex_re2,"
+ use regex-posix && extras+="regex_posix,"
+ use regex-stdlib && extras+="regex_stdlib,"
+ use sqlite && extras+="sqlite3,"
+ use ssl && extras+="ssl_openssl,"
+ use sslrehashsignal && extras+="sslrehashsignal,"
+ use tre && extras+="regex_tre,"
+
+ # The first configuration run enables certain "extra" InspIRCd
+ # modules, the second run generates the actual makefile.
+ if [[ -n "${extras}" ]]; then
+ ./configure --enable-extras=${extras%,}
+ fi
+
+ local myconf=(
+ --disable-auto-extras
+ --disable-ownership
+ --system
+ --uid ${PN}
+ --gid ${PN}
+ --binary-dir="/usr/bin"
+ --data-dir="/var/lib/${PN}/data"
+ --example-dir="/usr/share/doc/${PV}"
+ --manual-dir="/usr/share/man"
+ --module-dir="/usr/$(get_libdir)/${PN}/modules")
+ CXX="$(tc-getCXX)" ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}" $(usev debug INSPIRCD_DEBUG=2) INSPIRCD_VERBOSE=1
+}
+
+src_install() {
+ default
+
+ insinto "/usr/include/${PN}"
+ doins -r include/.
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit .configure/inspircd.service
+
+ keepdir "/var/log/${PN}"
+ insinto "/etc/logrotate.d"
+ newins .configure/logrotate "${PN}"
+
+ diropts -o"${PN}" -g"${PN}" -m0700
+ keepdir "/var/lib/${PN}/data"
+
+ rmdir "${ED}"/run{/inspircd,} || die
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You will find example configuration files under "
+ elog "/usr/share/doc/${PN}"
+ elog "Read the ${PN}.conf.example file carefully before "
+ elog "starting the service."
+ fi
+}