summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-11-18 02:37:15 -0500
committerMike Frysinger <vapier@gentoo.org>2021-11-18 02:59:46 -0500
commit29795392e78d09e59427e7ba7d90c7545f95646d (patch)
tree0d5b218e9f4d94e44e998e253857b36d88c3d968
parentapp-emulation/hercules: restore parallel install fix #772404 (diff)
downloadgentoo-29795392e78d09e59427e7ba7d90c7545f95646d.tar.gz
gentoo-29795392e78d09e59427e7ba7d90c7545f95646d.tar.bz2
gentoo-29795392e78d09e59427e7ba7d90c7545f95646d.zip
app-emulation/hercules: fix configure test with POSIX shell
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rw-r--r--app-emulation/hercules/files/hercules-3.13-posix-test.patch29
-rw-r--r--app-emulation/hercules/hercules-3.13.ebuild1
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emulation/hercules/files/hercules-3.13-posix-test.patch b/app-emulation/hercules/files/hercules-3.13-posix-test.patch
new file mode 100644
index 000000000000..abee4b0cc5ed
--- /dev/null
+++ b/app-emulation/hercules/files/hercules-3.13-posix-test.patch
@@ -0,0 +1,29 @@
+https://github.com/rbowler/spinhawk/pull/106
+
+From 9a9f7182069b8fe0483383c177882218244bad16 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 18 Nov 2021 02:32:02 -0500
+Subject: [PATCH] avoid bashism in test call
+
+POSIX test only supports =, not ==.
+---
+ autoconf/hercules.m4 | 2 +-
+ configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f12d47058562..8dd420af8d13 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -562,7 +562,7 @@ AC_CHECK_DECLS( SIOCADDRT, [hc_cv_have_siocaddrt=yes], [hc_
+ AC_CHECK_DECLS( SIOCDELRT, [hc_cv_have_siocdelrt=yes], [hc_cv_have_siocdelrt=no], [#include <linux/sockios.h>] )
+ AC_CHECK_DECLS( SIOCDIFADDR, [hc_cv_have_siocdifaddr=yes], [hc_cv_have_siocdifaddr=no], [#include <linux/sockios.h>] )
+
+-if test "$hc_cv_have_sys_mtio_h" == "yes"; then
++if test "$hc_cv_have_sys_mtio_h" = "yes"; then
+ AC_CHECK_DECLS( MTEWARN, [hc_cv_have_mtewarn=yes], [hc_cv_have_mtewarn=no], [#include <sys/mtio.h>] )
+ else
+ hc_cv_have_mtewarn=no
+--
+2.33.0
+
diff --git a/app-emulation/hercules/hercules-3.13.ebuild b/app-emulation/hercules/hercules-3.13.ebuild
index 8abf27c7e9a1..e128b5c5332e 100644
--- a/app-emulation/hercules/hercules-3.13.ebuild
+++ b/app-emulation/hercules/hercules-3.13.ebuild
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-3.13-htmldir.patch
+ "${FILESDIR}"/${PN}-3.13-posix-test.patch
"${FILESDIR}"/${PN}-3.13-unbundle-libltdl.patch
"${FILESDIR}"/${PN}-3.13-user-install.patch
)