summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-01 07:57:41 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-02 09:04:57 -0400
commit299934667487cc6c3594b8f121f504e95ed9add5 (patch)
treeb3cbdfceabae979cc9462b0dfdb78d83d36975ca
parentdev-qt/qtshadertools: drop 6.7.0_rc2 (diff)
downloadgentoo-299934667487cc6c3594b8f121f504e95ed9add5.tar.gz
gentoo-299934667487cc6c3594b8f121f504e95ed9add5.tar.bz2
gentoo-299934667487cc6c3594b8f121f504e95ed9add5.zip
dev-qt/qtspeech: drop 6.7.0_rc2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtspeech/Manifest1
-rw-r--r--dev-qt/qtspeech/qtspeech-6.7.0_rc2.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-qt/qtspeech/Manifest b/dev-qt/qtspeech/Manifest
index 89b312f9c4b9..d1b73e67d123 100644
--- a/dev-qt/qtspeech/Manifest
+++ b/dev-qt/qtspeech/Manifest
@@ -4,4 +4,3 @@ DIST qtspeech-everywhere-opensource-src-5.15.12.tar.xz 104816 BLAKE2B 8a64688c8e
DIST qtspeech-everywhere-opensource-src-5.15.13.tar.xz 104612 BLAKE2B 3c35098f0d4f4b4f804808f3d11abc0c0d189e3883cb1d15ea9b350948e061125299df1207ad44ed7af207c417980b0360ab6b44733efbbe7e5bdac6fe2402b5 SHA512 43b97ddc333d1c4a9715b1c306ced0506eb8faf69f1d22500b74e509d33b5a5cb9d0c166b9211a32a78eaba57925195d8ba0c39c8ae6a15551f841426294c75f
DIST qtspeech-everywhere-src-6.6.2.tar.xz 262008 BLAKE2B 6d9ae5b42f96fa02a15ac82e9e1c6a378c3b0ceccd278af9ef99346ad79a256e41d1d2ae10cfef75f311bdfad457271357b09fd067ddc902bff3e4ee31eda12e SHA512 e43793931b81bb86cc074a2153ec0160991c86bc255ea1b11e5b4a272b8d067fcfc6788261d4b2f6f7630eadbcab7be23249b980d2792cb9a109137af614601e
DIST qtspeech-everywhere-src-6.6.3.tar.xz 261976 BLAKE2B 839adf366d268f2872b321d16546fc953d2e3fa6724f76061fb44674d06a0dba949f171d67f528707d071a7b94f0097f4d6e0fa25ca902572477476d3f4872fc SHA512 4a43e1895ae477f6b6890a36ba2da365420e7778dece26535642ead39aab39c0c10d3be1c78a5b823eaddc646bdb60c5bd16bf3ac02f279832bc9724cfedc5d2
-DIST qtspeech-everywhere-src-6.7.0-rc2.tar.xz 261700 BLAKE2B 18c6dd54c48a9589936b6c2fcbcbcd2a3459013f853ab10b9005d4a2446ab1df546cc3b6ef8fa44c61afc569455ab5bb12936dd16f3c470c97a0f39637892093 SHA512 6e7ddca444f186cde1585c5edd2aeca7dc4369cdca302264264040bdd4b8397106fb82f9cb22bca86d97e0d662541292c643c4096e0736364b4ede59dbd13186
diff --git a/dev-qt/qtspeech/qtspeech-6.7.0_rc2.ebuild b/dev-qt/qtspeech/qtspeech-6.7.0_rc2.ebuild
deleted file mode 100644
index 867d3ddc19b8..000000000000
--- a/dev-qt/qtspeech/qtspeech-6.7.0_rc2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Text-to-speech library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm64 ~loong"
-fi
-
-IUSE="flite qml +speechd"
-# can build with neither, but then it is just mock tts and may be confusing
-REQUIRED_USE="|| ( flite speechd )"
-
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6
- ~dev-qt/qtmultimedia-${PV}:6
- flite? ( app-accessibility/flite )
- qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
- speechd? ( app-accessibility/speech-dispatcher )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package qml Qt6Qml)
- $(qt_feature flite)
- $(qt_feature speechd)
-
- # flite_alsa was likely to work around old issues in flite, it does
- # nothing but add -lasound (no code change, and is unneeded)
- -DQT_FEATURE_flite_alsa=OFF
- )
-
- qt6-build_src_configure
-}