summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2024-01-16 19:27:29 -0500
committerKenton Groombridge <concord@gentoo.org>2024-01-16 20:29:20 -0500
commit2b30c5b2a0d1a79a5c803d745ec3ff2f50f3dafb (patch)
tree534fddb109ad0a08a0cec1e0c2f0a2c4ef92cf4d
parentsys-libs/libsemanage: bump to 3.6 (diff)
downloadgentoo-2b30c5b2a0d1a79a5c803d745ec3ff2f50f3dafb.tar.gz
gentoo-2b30c5b2a0d1a79a5c803d745ec3ff2f50f3dafb.tar.bz2
gentoo-2b30c5b2a0d1a79a5c803d745ec3ff2f50f3dafb.zip
sys-apps/checkpolicy: bump to 3.6
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
-rw-r--r--sys-apps/checkpolicy/Manifest1
-rw-r--r--sys-apps/checkpolicy/checkpolicy-3.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/checkpolicy/Manifest b/sys-apps/checkpolicy/Manifest
index d3279c23fc81..d8d08681182e 100644
--- a/sys-apps/checkpolicy/Manifest
+++ b/sys-apps/checkpolicy/Manifest
@@ -1 +1,2 @@
DIST checkpolicy-3.5.tar.gz 69904 BLAKE2B e02ccad07534568a1bbb612330018bbe486800ea40df20ed6f9dc38c88aff7f8858782a28ba7915a58c3bb384f180eb8da7a8fe97a92bcb9baa61eec18da6cbc SHA512 fcd490d865af3b4350c32c5dd9916f8406219841e1e255d8945c6dcc958535247aa27af5597a6988e19f11faea7beeabcb46e8ba2431112bb4aa5c7697bca529
+DIST checkpolicy-3.6.tar.gz 70684 BLAKE2B d32a8b86897bd4a08caf61a096a691c8d049fa7b5b4561f4847e0dfbb62a82fc6c3ddb5be163c7cd6163491c50513aec14e4c67842f256f48688b26178c2887a SHA512 0d48fb385b4d1e66d562e40b6e794406f46d8803cc504705b26547130cb13b65fab5fdb4fc032b1c95d4f91862ff134a89fffde854c5ce466c2dd2657e416070
diff --git a/sys-apps/checkpolicy/checkpolicy-3.6.ebuild b/sys-apps/checkpolicy/checkpolicy-3.6.ebuild
new file mode 100644
index 000000000000..6d5e91d8b18a
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-3.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://userspace.selinuxproject.org"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug"
+
+DEPEND=">=sys-libs/libsepol-${PV}"
+BDEPEND="sys-devel/flex
+ sys-devel/bison"
+
+RDEPEND=">=sys-libs/libsepol-${PV}"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ YACC="bison -y" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ default
+
+ if use debug; then
+ dobin "${S}/test/dismod"
+ dobin "${S}/test/dispol"
+ fi
+}
+
+pkg_postinst() {
+ if ! tc-is-cross-compiler; then
+ einfo "This checkpolicy can compile version `checkpolicy -V | cut -f 1 -d ' '` policy."
+ fi
+}