summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-27 21:48:22 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-27 22:34:36 -0400
commit2be9c5e2c3d3a4f72f4911b7b39a6fd70322c600 (patch)
tree1c817c8b2895ae6f34da5299e038934745265c91
parentnet-misc/hashcash: fix build with clang16 (diff)
downloadgentoo-2be9c5e2c3d3a4f72f4911b7b39a6fd70322c600.tar.gz
gentoo-2be9c5e2c3d3a4f72f4911b7b39a6fd70322c600.tar.bz2
gentoo-2be9c5e2c3d3a4f72f4911b7b39a6fd70322c600.zip
x11-misc/xcalendar: EAPI6->8, toss imake in the trash
Could have used makefile.noi rather than implicit rules, but it feels a bit outdated and it's simpler to control everything while getting to use pkg-config. Should revbump to ~arch in theory here, but not going to bother for some derelict imake x app. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff26
-rw-r--r--x11-misc/xcalendar/xcalendar-4.0-r2.ebuild61
-rw-r--r--x11-misc/xcalendar/xcalendar-4.0-r3.ebuild68
3 files changed, 68 insertions, 87 deletions
diff --git a/x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff b/x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff
deleted file mode 100644
index a35d98bcb814..000000000000
--- a/x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff
+++ /dev/null
@@ -1,26 +0,0 @@
---- xcalendar.orig/Imakefile Sat Sep 30 20:19:17 1995
-+++ xcalendar/Imakefile Tue Aug 20 08:37:48 2002
-@@ -1,18 +1,18 @@
- XCALENDAR_LIBDIR = $(LIBDIR)/xcalendar
- LIBFILES = larrow.xbm qmark.xbm quit.xbm rarrow.xbm xcalendar.hlp
- # Comment out the following two lines for the Motif version
--LOCAL_LIBRARIES = $(XAWLIB) $(XMULIB) $(XTOOLLIB) $(XLIB)
-- EXTRA_DEFINES = -DATHENA
-+#LOCAL_LIBRARIES = $(XAWLIB) $(XMULIB) $(XTOOLLIB) $(XLIB)
-+# EXTRA_DEFINES = -DATHENA
- # Uncomment the following two lines for the Motif version
--# LOCAL_LIBRARIES = -L/usr/local/Motif/lib -lXm $(XMULIB) $(XTOOLLIB) $(XLIB)
--# EXTRA_DEFINES = -I/usr/local/Motif/include
-+ LOCAL_LIBRARIES = -lXm $(XMULIB) $(XTOOLLIB) $(XLIB)
-+ EXTRA_DEFINES =
- SRCS = xcalendar.c dayeditor.c lists.c
- OBJS = xcalendar.o dayeditor.o lists.o
-
- #
- # for Internationalization
- #
--EXTRA_DEFINES = -DXI18N -DATHENA
-+#EXTRA_DEFINES = -DXI18N -DATHENA
- ##if !SharedLibXwchar
- # _UseCat($(USRLIBDIR),$(CONTRIBSRC)/lib/Xwchar,/libXwchar.a)
- # XWCHARLIB = LoaderLibPrefix _Use(-lXwchar,$(DEPXWCHARLIB))
diff --git a/x11-misc/xcalendar/xcalendar-4.0-r2.ebuild b/x11-misc/xcalendar/xcalendar-4.0-r2.ebuild
deleted file mode 100644
index a6ccd1896657..000000000000
--- a/x11-misc/xcalendar/xcalendar-4.0-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit toolchain-funcs
-
-DESCRIPTION="A simple interactive calendar program with a notebook capability"
-HOMEPAGE="https://www.freebsd.org/"
-SRC_URI="ftp://daemon.jp.FreeBSD.org/pub/FreeBSD-jp/ports-jp/LOCAL_PORTS/${P}+i18n.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~alpha amd64 ppc ppc64 x86"
-IUSE="motif"
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXmu
- x11-libs/libXt
- x11-libs/libXaw
- x11-libs/libXext"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
- >=x11-misc/imake-1.0.8-r1
- x11-misc/gccmakedep
- motif? ( >=x11-libs/motif-2.3:0 )"
-
-S=${WORKDIR}/${PN}
-PATCHES=( "${FILESDIR}"/${P}-implicits.patch )
-
-src_prepare() {
- use motif && PATCHES+=( "${FILESDIR}"/${P}-motif-gentoo.diff )
- default
- sed -e "s:%%XCALENDAR_LIBDIR%%:/usr/$(get_libdir)/xcalendar:" \
- -e "s:/usr/local/X11R5/lib/X11/:/usr/$(get_libdir)/:" \
- -i XCalendar.sed || die
-}
-
-src_configure() {
- CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CDEBUGFLAGS="${CFLAGS}" \
- EXTRA_LDOPTIONS="${LDFLAGS}"
-}
-
-src_install() {
- dobin xcalendar
- newman xcalendar.man xcalendar.1
-
- insinto /usr/share/X11/app-defaults
- newins XCalendar.sed XCalendar
-
- insinto /usr/$(get_libdir)/xcalendar
- doins *.xbm *.hlp
-
- einstalldocs
-}
diff --git a/x11-misc/xcalendar/xcalendar-4.0-r3.ebuild b/x11-misc/xcalendar/xcalendar-4.0-r3.ebuild
new file mode 100644
index 000000000000..509f954ff915
--- /dev/null
+++ b/x11-misc/xcalendar/xcalendar-4.0-r3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Simple interactive calendar program with a notebook capability"
+HOMEPAGE="https://www.freebsd.org/"
+SRC_URI="ftp://daemon.jp.FreeBSD.org/pub/FreeBSD-jp/ports-jp/LOCAL_PORTS/${P}+i18n.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 x86"
+IUSE="motif"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ motif? (
+ x11-libs/libXmu
+ x11-libs/motif
+ )
+ !motif? ( x11-libs/libXaw )"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-implicits.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s|%%XCALENDAR_LIBDIR%%|${EPREFIX}/usr/$(get_libdir)/xcalendar|" \
+ -e "s|/usr/local/X11R5/lib/X11/|${EPREFIX}/usr/$(get_libdir)/|" \
+ < XCalendar.sed > XCalendar || die
+}
+
+src_compile() {
+ tc-export CC
+
+ if use motif; then
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags x11 xmu xt || die)
+ append-libs -lXm $($(tc-getPKG_CONFIG) --libs x11 xmu xt || die)
+ else
+ append-cppflags -DATHENA $($(tc-getPKG_CONFIG) --cflags x11 xaw7 xt || die)
+ append-libs $($(tc-getPKG_CONFIG) --libs x11 xaw7 xt || die)
+ fi
+
+ emake LDLIBS="${LIBS}" -f /dev/null -E "xcalendar: dayeditor.o lists.o"
+}
+
+src_install() {
+ dobin xcalendar
+ newman xcalendar.man xcalendar.1
+
+ insinto /usr/share/X11/app-defaults
+ doins XCalendar
+
+ insinto /usr/$(get_libdir)/xcalendar
+ doins *.xbm *.hlp
+
+ einstalldocs
+}