summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-11-05 20:49:42 +0100
committerSebastian Pipping <sping@gentoo.org>2023-11-05 20:50:52 +0100
commit2cc02953c205a56995bb47f95f4db0079de3e16d (patch)
treedd10a62562c67f3bce38c2918b8f5e6871d6b20d
parentapp-portage/metagen: Python 3.12 (diff)
downloadgentoo-2cc02953c205a56995bb47f95f4db0079de3e16d.tar.gz
gentoo-2cc02953c205a56995bb47f95f4db0079de3e16d.tar.bz2
gentoo-2cc02953c205a56995bb47f95f4db0079de3e16d.zip
app-portage/fetchcommandwrapper: Python 3.12
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
-rw-r--r--app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild
new file mode 100644
index 000000000000..788a228fffb1
--- /dev/null
+++ b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Wrapper integrating aria2 into portage's FETCHCOMMAND"
+HOMEPAGE="https://github.com/hartwork/fetchcommandwrapper"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=net-misc/aria2-1.10.2[metalink,xmlrpc]"
+
+pkg_postinst() {
+ ewarn 'You need to append'
+ ewarn ' source /usr/share/fetchcommandwrapper/make.conf'
+ ewarn 'to /etc/portage/make.conf in order to integrate fetchcommandwrapper.'
+}