summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2018-10-13 17:32:42 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-24 13:56:25 +0200
commit2cfc06b5af03ba8fc3369dfa013cdf7e60cbcb76 (patch)
tree21fb0b90948b1028363bb354c763511e4426b46b
parentsys-process/rtirq: correct HOMEPAGE and SRC_URI (diff)
downloadgentoo-2cfc06b5af03ba8fc3369dfa013cdf7e60cbcb76.tar.gz
gentoo-2cfc06b5af03ba8fc3369dfa013cdf7e60cbcb76.tar.bz2
gentoo-2cfc06b5af03ba8fc3369dfa013cdf7e60cbcb76.zip
sys-process/rtirq: version bump to 20180209
- Install systemd service file. - Bump to EAPI 7. - Drop explicit RDEPEND on sys-apps/util-linux. - Group variables as in skel.ebuild. - Update LICENSE to GPL-2+ in accordance with rtirq.sh. - Do not use PN variable in src_install. - Remove OpenRC specific code that was not very useful anyway. - Use KV_LOCAL from linux-info to detect if the current kernel is realtime or not. - Avoid using grep unnecessarily. Closes: https://bugs.gentoo.org/653732 Signed-off-by: Karl Linden <karl.j.linden@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10135 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-process/rtirq/Manifest1
-rw-r--r--sys-process/rtirq/rtirq-20180209.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-process/rtirq/Manifest b/sys-process/rtirq/Manifest
index 57ca7c2065bc..4c95062e1110 100644
--- a/sys-process/rtirq/Manifest
+++ b/sys-process/rtirq/Manifest
@@ -1 +1,2 @@
DIST rtirq-20150216.tar.gz 12249 BLAKE2B b138c3b274e7d0875fc18d21ff77291975f86d841cfd06d704b428bcf7e106fb06b4738a4d8dd88ca2e58fa719b8232ef8a61df0bd088c9a368497e27095bd39 SHA512 4cb4e3a8e314cec238c2a21c975bec258f229b660e0994893b73aa0b16f6041179ff4e220532fde237d70e15fd5420e22ee5dbf84168148060e760d76617b59c
+DIST rtirq-20180209.tar.gz 12290 BLAKE2B 432bf6c931b753d4d9a5d7c50a35b0fb9b2161d09c9f762b97a5aae88152de1f3d14a2a4ccc46d8607d7379e4a7a659d603cc09ee20017923b176359eb4b9133 SHA512 9de924e627b91d6df162b6c8c0c3421fbab11f08162abe98b0fac8742ea924a7e0a18aab23d828e19fe81dfdb70f2f6814c7195acbcbc93af9a339dc549190b2
diff --git a/sys-process/rtirq/rtirq-20180209.ebuild b/sys-process/rtirq/rtirq-20180209.ebuild
new file mode 100644
index 000000000000..5186ad22dd47
--- /dev/null
+++ b/sys-process/rtirq/rtirq-20180209.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit linux-info systemd
+
+DESCRIPTION="Modify realtime scheduling policy and priority of IRQ handlers"
+HOMEPAGE="http://www.rncbc.org/archive/#rtirq"
+SRC_URI="http://www.rncbc.org/archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ get_version
+
+ # Correct config file path.
+ sed -i -e "s:^\(RTIRQ_CONFIG\=\)\(.*\):\1/etc/conf.d/rtirq:" ${PN}.sh || die
+ sed -i -e "s:/etc/sysconfig/rtirq:/etc/conf.d/rtirq:" ${PN}.conf || die
+
+ default
+}
+
+src_install() {
+ dosbin rtirq.sh
+ doinitd "${FILESDIR}"/rtirq
+ newconfd rtirq.conf rtirq
+ systemd_dounit rtirq.service
+}
+
+pkg_postinst() {
+ if [[ ${KV_LOCAL} != *rt* ]] ; then
+ elog "To use rtirq you need a realtime kernel."
+ elog "Realtime kernel sources are supplied in sys-kernel/rt-sources."
+ fi
+}