summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-23 06:47:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-23 08:22:09 +0200
commit2e0b4a6adfe9ac95b4deb49eeca65cf2041f319e (patch)
tree4fcc041af86ff51bcddb66a66fd2264114c6b54f
parentsci-mathematics/z3: Bump to 4.10.1 (diff)
downloadgentoo-2e0b4a6adfe9ac95b4deb49eeca65cf2041f319e.tar.gz
gentoo-2e0b4a6adfe9ac95b4deb49eeca65cf2041f319e.tar.bz2
gentoo-2e0b4a6adfe9ac95b4deb49eeca65cf2041f319e.zip
dev-python/importlib_resources: Bump to 5.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/importlib_resources/Manifest1
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.9.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index f246fdc28dc7..4926f4108ece 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1,2 +1,3 @@
DIST importlib_resources-5.7.1.tar.gz 31272 BLAKE2B 3e30117ae4f18a9f2151b5435428f3853664ce291d2d4ce9490d1a3043ca5ce2e80cf04d7dcef71ebdaba8bbad17ee61bb47303637a8bee73a2263853b65293b SHA512 8fd89dfcea4112d26418bcfa522de36c2136a50d07470ac8de18f62bb7bb964a459534554802b1455996ae65796018bea806a592746c1d2717f1313608cf4918
DIST importlib_resources-5.8.0.tar.gz 31461 BLAKE2B ce6668520297cd7e06b944146277065cd1a0f5ae3f9e3bce24005f0f4a1181a41fa7f91f6b9ee9c0ef4caf7ca65c8efff748957c5c1a45c56778b30568970b36 SHA512 5c20a46a1832c7aaddfaa561a3986ea02dae59b94c06861757b6e5912f36624d564c65e184612af6e5930927a3172dc132ceb9846b0585de851d019c68cc8955
+DIST importlib_resources-5.9.0.gh.tar.gz 32691 BLAKE2B bc922945d0577222e704ac3a5aa24cd6abb31c9b44f42c342e78f45fb035ee2b3843c437eba31bc8a73f609f6126390f4141c52b9eef15ff8bc7efc44233e81b SHA512 9054b633f3c9b3523ccfa2be93774d0aa4b0c2ab8bfb228f1e0bfbbc076362b416c9714409ff365aa5eae579554feedc8f2aeaa49c766db37ab669414eb22827
diff --git a/dev-python/importlib_resources/importlib_resources-5.9.0.ebuild b/dev-python/importlib_resources/importlib_resources-5.9.0.ebuild
new file mode 100644
index 000000000000..7fbce509df31
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-5.9.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+# This is a backport of Python 3.9's importlib.resources
+PYTHON_COMPAT=( pypy3 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="
+ https://github.com/python/importlib_resources/
+ https://pypi.org/project/importlib-resources/
+"
+SRC_URI="
+ https://github.com/python/importlib_resources/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/zipp-3.7.0-r1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+distutils_enable_tests unittest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "importlib_resources"
+ version = "${PV}"
+ description = "Read resources from Python packages"
+ EOF
+}