summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 13:34:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 13:35:09 +0100
commit2ef08fa78e9d8eca4eb022b0b9a22cde7f6a7bd1 (patch)
treec25a17ed67b91e92aeeff6c08cbd6f6d65fc0a59
parentdev-python/crcmod: Switch to PEP 517 build (diff)
downloadgentoo-2ef08fa78e9d8eca4eb022b0b9a22cde7f6a7bd1.tar.gz
gentoo-2ef08fa78e9d8eca4eb022b0b9a22cde7f6a7bd1.tar.bz2
gentoo-2ef08fa78e9d8eca4eb022b0b9a22cde7f6a7bd1.zip
dev-python/dicttoxml: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dicttoxml/dicttoxml-1.7.4-r3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/dicttoxml/dicttoxml-1.7.4-r3.ebuild b/dev-python/dicttoxml/dicttoxml-1.7.4-r3.ebuild
new file mode 100644
index 000000000000..5f65f5b39908
--- /dev/null
+++ b/dev-python/dicttoxml/dicttoxml-1.7.4-r3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts a Python dictionary or other data type to a valid XML string"
+HOMEPAGE="https://github.com/quandyfactory/dicttoxml https://pypi.org/project/dicttoxml/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+PATCHES=(
+ # https://github.com/quandyfactory/dicttoxml/pull/73/files
+ "${FILESDIR}/${P}-py3.10.patch"
+)