summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-17 03:19:01 +0000
committerSam James <sam@gentoo.org>2023-03-17 03:19:01 +0000
commit2f7dad5c2882013ab855c0c65db529904dd4c0c7 (patch)
tree2b41e214c5c9e2af3cf56ce14f87208b749419d6
parentdev-ml/ocaml-migrate-parsetree: Stabilize 2.4.0 x86, #901633 (diff)
downloadgentoo-2f7dad5c2882013ab855c0c65db529904dd4c0c7.tar.gz
gentoo-2f7dad5c2882013ab855c0c65db529904dd4c0c7.tar.bz2
gentoo-2f7dad5c2882013ab855c0c65db529904dd4c0c7.zip
sci-libs/geos: add 3.11.2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/files/geos-3.11.2-gcc-13.patch38
-rw-r--r--sci-libs/geos/geos-3.11.2.ebuild50
3 files changed, 89 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index e090e325a34b..42022eecc40f 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,2 +1,3 @@
DIST geos-3.11.0.tar.bz2 6727294 BLAKE2B 7d2cb7ae2dc6c5eb13836c16c8164402c1e964f98df95d5aaf9f6fd957ebcdbdefb43ae4fb17a5a671b6dfdb812bdacfdbfdfdea6e5bd44f135e3701a3cc914d SHA512 40c7553bbb93673c231ddd0131b73bf43b3f50524bc5bd9e6934c068d2c09632f388b7429254ae15d9641da2d15e3a626b430438854e98d9e7419ad04e535189
DIST geos-3.11.1.tar.bz2 6753232 BLAKE2B 376050ca3224e5220f69d82ff62d79ff7ea3d35d5fe90b7ab4e0cabcb4200b47d7569110538c201df9cb28da784f09f8207a9a8233ee002ab2ec87f5cf336ba1 SHA512 708500aba9b04208ee46a531d55ddf63a213dfaa2922dae937b524300b2b46c95143ed6cd3ff1414e9099f2be95e5df5a2e0b49df43acf93a9478215259f20d3
+DIST geos-3.11.2.tar.bz2 6774288 BLAKE2B 62ddcaf5b6716983d49a6931c97ebe8d4c457ce7d127531ff3ff985555e9dfc2f1ebd211d1fe7afe183a3858913b4c22ec4674f68fb28ee8c43c9e9ce61abd3b SHA512 b5df5b773bef595335e1be6c6d3325f932f1577e2a4b8bdfa8cf26f09c7d41ed5e0695ca15826d1f95bc4a45b777839c2be8a96a8af5415c8bcf58cc804eb1ec
diff --git a/sci-libs/geos/files/geos-3.11.2-gcc-13.patch b/sci-libs/geos/files/geos-3.11.2-gcc-13.patch
new file mode 100644
index 000000000000..fa46cf8bf4d2
--- /dev/null
+++ b/sci-libs/geos/files/geos-3.11.2-gcc-13.patch
@@ -0,0 +1,38 @@
+https://github.com/libgeos/geos/commit/bea3188be44075034fd349f5bb117c943bdb7fb1
+
+From bea3188be44075034fd349f5bb117c943bdb7fb1 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <mail@heiko-becker.de>
+Date: Mon, 23 Jan 2023 15:56:11 +0100
+Subject: [PATCH] Fix build with gcc 13 by including <cstdint> (#805)
+
+In addition to [1]. Otherwise geos fails to build with:
+"geos-3.11.1/include/geos/shape/fractal/HilbertEncoder.h:40:28: error: expected ')' before 'p_level'
+ 40 | HilbertEncoder(uint32_t p_level, geom::Envelope& extent);
+ | ~ ^~~~~~~~
+ | )
+/var/tmp/paludis/build/sci-libs-geos-3.11.1/work/geos-3.11.1/include/geos/shape/fractal/HilbertEncoder.h:41:5: error: 'uint32_t' does not name a type
+ 41 | uint32_t encode(const geom::Envelope* env);
+ | ^~~~~~~~"
+
+[1] 0e8d4368b8bd72a7d361286e8523ebce5cff6146
+--- a/include/geos/shape/fractal/HilbertEncoder.h
++++ b/include/geos/shape/fractal/HilbertEncoder.h
+@@ -19,6 +19,7 @@
+ #include <geos/geom/Geometry.h>
+ #include <string>
+ #include <vector>
++#include <cstdint>
+
+ // Forward declarations
+ namespace geos {
+--- a/tests/unit/capi/GEOSMakeValidTest.cpp
++++ b/tests/unit/capi/GEOSMakeValidTest.cpp
+@@ -9,6 +9,7 @@
+ #include <cstdlib>
+ #include <cmath>
+ #include <cstring>
++#include <cstdint>
+
+ #include "capi_test_utils.h"
+
+
diff --git a/sci-libs/geos/geos-3.11.2.ebuild b/sci-libs/geos/geos-3.11.2.ebuild
new file mode 100644
index 000000000000..9aa1b4eecd40
--- /dev/null
+++ b/sci-libs/geos/geos-3.11.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="https://libgeos.org/"
+SRC_URI="https://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-13.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ -DUSE_CCACHE=OFF
+
+ # bug #709368
+ $(usev arm '-DDISABLE_GEOS_INLINE=ON')
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc ; then
+ HTML_DOCS=( "${BUILD_DIR}"/doxygen/doxygen_docs/html/. )
+ einstalldocs
+ fi
+}