summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <pv@excello.cz>2018-03-13 09:51:50 +0100
committerAaron Bauman <bman@gentoo.org>2018-05-05 16:51:38 -0400
commit30e2fd920b9bb5cdc056a31b07174c17d9f1c9cb (patch)
tree8c0990291aac5cf8f765277a0c594902376a08ba
parentmeson.eclass: Don't mix host *FLAGS with build *FLAGS (diff)
downloadgentoo-30e2fd920b9bb5cdc056a31b07174c17d9f1c9cb.tar.gz
gentoo-30e2fd920b9bb5cdc056a31b07174c17d9f1c9cb.tar.bz2
gentoo-30e2fd920b9bb5cdc056a31b07174c17d9f1c9cb.zip
media-sound/cmusfm: Bump to 0.3.3
Closes: https://bugs.gentoo.org/609140 Closes: https://github.com/gentoo/gentoo/pull/7441
-rw-r--r--media-sound/cmusfm/Manifest1
-rw-r--r--media-sound/cmusfm/cmusfm-0.3.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/cmusfm/Manifest b/media-sound/cmusfm/Manifest
index 0c0b1ca263a9..9573b1f519b3 100644
--- a/media-sound/cmusfm/Manifest
+++ b/media-sound/cmusfm/Manifest
@@ -1,2 +1,3 @@
DIST cmusfm-0.2.5.tar.gz 28651 BLAKE2B c69dcaa5900ed4cf3d1a0274ac3dc6e6322b73222a472c26434fa4912c2f351fa67b0f3ac1d91df9f707d5c38d6ffa7c4401ed3500ed929adcbb63b9e513f765 SHA512 0db8d865342438531bfb800d835800240e47732444795159f72ed3c91a4c3f0747ba2da1dcc8e71ef340ba5a3febdb39d8dd5868b134afcbcf7b3614a7790eae
DIST cmusfm-0.3.1.tar.gz 34521 BLAKE2B d5f7ce5cb37a03114e910f0ad7fd39bb3e940ce9d0ad416e464dc6cfc5438bbe901845b610bd8d0e508bde236ef6ed9cb894afb5a4cae710b1347d3173ffa60b SHA512 2d4d551d2a82fc2d70c7f75705f8cec236a0cf7b8e5268c91cc32b4ede4ecd51c4577d673b8c36f041e514af59142f2c9c001cd422c0790f0e0b3596b4394064
+DIST cmusfm-0.3.3.tar.gz 37553 BLAKE2B f266d83edbed960d8c466cba80ce57d645c5c9cdfceac27c29d0ef424c8135f22377dc0490462d3107dfcfd32ac9d15fa6142269b453c8a80818da9bd10a28fd SHA512 6537905bdf09d04f09783237997536a1ee231ee4e589826d87f435c0dd7542dbd7d97167990bf949d2a9eb73c4a9a4da1bab17888de0aecedb2a63deaa873f39
diff --git a/media-sound/cmusfm/cmusfm-0.3.3.ebuild b/media-sound/cmusfm/cmusfm-0.3.3.ebuild
new file mode 100644
index 000000000000..3a2f2d2e87bf
--- /dev/null
+++ b/media-sound/cmusfm/cmusfm-0.3.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools readme.gentoo-r1
+
+DESCRIPTION="Last.fm scrobbler for cmus music player"
+HOMEPAGE="https://github.com/Arkq/cmusfm"
+SRC_URI="https://github.com/Arkq/cmusfm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+CDEPEND="net-misc/curl
+ dev-libs/openssl:0=
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ media-sound/cmus"
+
+src_prepare() {
+ default
+ eautoreconf
+ DOC_CONTENTS="Please refer to the README.md file before running cmusfm the first time."
+}
+
+src_configure() {
+ econf $(use_enable libnotify)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+}