summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 15:36:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 15:36:34 +0200
commit31462083016f2dc53858f7af676aab42bc20b07a (patch)
tree046161a097cf82352c2ead570d2204682e7532d2
parentdev-python/flask-gravatar: Enable py3.10 (diff)
downloadgentoo-31462083016f2dc53858f7af676aab42bc20b07a.tar.gz
gentoo-31462083016f2dc53858f7af676aab42bc20b07a.tar.bz2
gentoo-31462083016f2dc53858f7af676aab42bc20b07a.zip
dev-python/flask-debug: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask-debug/flask-debug-0.4.3-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/flask-debug/flask-debug-0.4.3-r1.ebuild b/dev-python/flask-debug/flask-debug-0.4.3-r1.ebuild
index 07be1ba7c222..c4ac46372d40 100644
--- a/dev-python/flask-debug/flask-debug-0.4.3-r1.ebuild
+++ b/dev-python/flask-debug/flask-debug-0.4.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
@@ -13,6 +13,7 @@ HOMEPAGE="https://github.com/mbr/Flask-Debug"
# PyPI tarballs don't include tests
# https://github.com/mbr/Flask-Debug/pull/2
SRC_URI="https://github.com/mbr/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="MIT"
SLOT="0"
@@ -24,7 +25,5 @@ RDEPEND="
dev-python/jinja[${PYTHON_USEDEP}]
"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/alabaster