summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-24 14:48:29 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-24 14:48:29 +0100
commit31660a8e4f331f774e9e7d20382a7b9676ebf69a (patch)
tree45f3bba163190233a17bff08a624eb1cdff2ce9c
parentsci-libs/openlibm: Remove old (diff)
downloadgentoo-31660a8e4f331f774e9e7d20382a7b9676ebf69a.tar.gz
gentoo-31660a8e4f331f774e9e7d20382a7b9676ebf69a.tar.bz2
gentoo-31660a8e4f331f774e9e7d20382a7b9676ebf69a.zip
sci-libs/nfft: Bump to 3.5.2
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-libs/nfft/Manifest1
-rw-r--r--sci-libs/nfft/nfft-3.5.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-libs/nfft/Manifest b/sci-libs/nfft/Manifest
index d431745d3883..9a74f409f2c0 100644
--- a/sci-libs/nfft/Manifest
+++ b/sci-libs/nfft/Manifest
@@ -1 +1,2 @@
DIST nfft-3.3.2.tar.gz 2821259 BLAKE2B b0029ecb0027a18de84f1a4db058101a26038547642c524125dec66bc6dc1da19873314ff6e4f483c401d39ee7c999cb9225de456be0928d55bca9fb1c1f6e69 SHA512 66bcd2439c9ba27063aa1db01c526a580c5c67938e2db332068ce20035ede1d8766e8f134a0e5dac5263aca14121573ca4f5a906b452c43f218636f5f6161c02
+DIST nfft-3.5.2.tar.gz 5377870 BLAKE2B 5a9b79fd2db781f163f3e694e25096f9abfac67ae9e2f0614444e99160ac6ce150356b72130ba44f82c541120f8876723a06e989a5c125e1da1b85976b7ff500 SHA512 e5437b358f22807de2251527025accf326d77322e029cfc3df6ee733ccca4d020cbd3c045773735de0641618c71e5cc9b8f4df53becea3b7a7e27750f21fa64e
diff --git a/sci-libs/nfft/nfft-3.5.2.ebuild b/sci-libs/nfft/nfft-3.5.2.ebuild
new file mode 100644
index 000000000000..27ff8602d25e
--- /dev/null
+++ b/sci-libs/nfft/nfft-3.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="library for nonequispaced discrete Fourier transformations"
+HOMEPAGE="https://www-user.tu-chemnitz.de/~potts/nfft/"
+SRC_URI="https://github.com/NFFT/nfft/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc openmp"
+
+RDEPEND="sci-libs/fftw:3.0[threads,openmp?]"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ if ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected compiler"
+
+ if tc-is-clang; then
+ ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
+ ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
+ fi
+
+ die "need openmp capable compiler"
+ fi
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-all \
+ --enable-shared \
+ --disable-static \
+ $(use_enable openmp)
+}
+
+src_install() {
+ default
+ use doc || rm -r "${ED}/usr/share/doc/${P}/html" || die
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}