summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-04 06:51:09 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-04 06:54:22 +0100
commit31a407156336351cfeed6c75021f78cc7fe574a2 (patch)
treea0be1bdf9196b02aa57b6726730471a57c8b540a
parentapp-emacs/lsp-mode: import of 8.0.0 (diff)
downloadgentoo-31a407156336351cfeed6c75021f78cc7fe574a2.tar.gz
gentoo-31a407156336351cfeed6c75021f78cc7fe574a2.tar.bz2
gentoo-31a407156336351cfeed6c75021f78cc7fe574a2.zip
dev-ruby/httpauth: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/httpauth/httpauth-0.2.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/httpauth/httpauth-0.2.1-r1.ebuild b/dev-ruby/httpauth/httpauth-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..9e257ddfc835
--- /dev/null
+++ b/dev-ruby/httpauth/httpauth-0.2.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md TODO"
+RUBY_FAKEGEM_GEMSPEC="httpauth.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library implementing the full HTTP Authentication protocol (RFC 2617)"
+HOMEPAGE="https://github.com/Manfred/HTTPauth"
+SRC_URI="https://github.com/Manfred/HTTPauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+RUBY_S=HTTPauth-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}