summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-09-05 13:02:51 -0500
committerAustin English <wizardedit@gentoo.org>2017-09-05 13:32:26 -0500
commit31c09bb4c06a4a8fa57038d6059821579af61880 (patch)
tree9e2d86625303293f358567dee9c06e586db2be39
parentx11-misc/tint2: remove unused patch (diff)
downloadgentoo-31c09bb4c06a4a8fa57038d6059821579af61880.tar.gz
gentoo-31c09bb4c06a4a8fa57038d6059821579af61880.tar.bz2
gentoo-31c09bb4c06a4a8fa57038d6059821579af61880.zip
games-emulation/mekanix: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--games-emulation/mekanix/mekanix-070-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-emulation/mekanix/mekanix-070-r1.ebuild b/games-emulation/mekanix/mekanix-070-r1.ebuild
new file mode 100644
index 000000000000..ee7f2d85c12d
--- /dev/null
+++ b/games-emulation/mekanix/mekanix-070-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="SG-1000, SC-3000, SF-7000, SSC, SMS, GG, COLECO, and OMV emulator"
+HOMEPAGE="http://www.smspower.org/meka/"
+SRC_URI="http://www.smspower.org/meka/releases/${PN}${PV}.tgz"
+
+LICENSE="mekanix"
+SLOT="0"
+KEYWORDS="~x86"
+RESTRICT="strip"
+IUSE=""
+
+RDEPEND="media-libs/libpng
+ x11-libs/libXpm"
+
+S=${WORKDIR}/${PN}
+
+# file verfies that it's an elf, not win32, binary:
+QA_PREBUILT="opt/${PN}/meka.exe"
+
+src_install() {
+ local dir="/opt/${PN}"
+
+ insinto "${dir}"
+ doins * || die "doins failed"
+ fperms a+x "${dir}/meka.exe"
+ make_wrapper mekanix ./meka.exe "${dir}"
+}