summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-11-28 21:36:24 +0100
committerSebastian Pipping <sping@gentoo.org>2022-11-28 21:37:13 +0100
commit327daa6ad4bd49a65f31d754cec306142b04012b (patch)
treec15320f4647f75ea947cd6bb54f90fe60dc7b77d
parentapp-portage/elogv: Python 3.11 (diff)
downloadgentoo-327daa6ad4bd49a65f31d754cec306142b04012b.tar.gz
gentoo-327daa6ad4bd49a65f31d754cec306142b04012b.tar.bz2
gentoo-327daa6ad4bd49a65f31d754cec306142b04012b.zip
app-portage/fetchcommandwrapper: Python 3.11 + EAPI 8 + DistutilsNonPEP517Build
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
-rw-r--r--app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r3.ebuild b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r3.ebuild
new file mode 100644
index 000000000000..b5cad4774b8e
--- /dev/null
+++ b/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Wrapper integrating aria2 into portage's FETCHCOMMAND"
+HOMEPAGE="https://github.com/hartwork/fetchcommandwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=net-misc/aria2-1.10.2[metalink,xmlrpc]"
+
+pkg_postinst() {
+ ewarn 'You need to append'
+ ewarn ' source /usr/share/fetchcommandwrapper/make.conf'
+ ewarn 'to /etc/portage/make.conf in order to integrate fetchcommandwrapper.'
+}