summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-05-29 15:42:10 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-05-29 15:43:35 +0100
commit33470b53c126038cfb84831516172bd8ff3bbe00 (patch)
tree56371386eb66c8688e88ce2f7c356c06e1ad9f78
parentdev-libs/ocl-icd: Version bump to 2.3.0 (diff)
downloadgentoo-33470b53c126038cfb84831516172bd8ff3bbe00.tar.gz
gentoo-33470b53c126038cfb84831516172bd8ff3bbe00.tar.bz2
gentoo-33470b53c126038cfb84831516172bd8ff3bbe00.zip
dev-libs/ocl-icd: Drop old and broken 2.2.14
Closes: https://bugs.gentoo.org/789558 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--dev-libs/ocl-icd/Manifest1
-rw-r--r--dev-libs/ocl-icd/ocl-icd-2.2.14-r1.ebuild57
-rw-r--r--dev-libs/ocl-icd/ocl-icd-2.2.14.ebuild44
3 files changed, 0 insertions, 102 deletions
diff --git a/dev-libs/ocl-icd/Manifest b/dev-libs/ocl-icd/Manifest
index 50148b966278..d56cb7163168 100644
--- a/dev-libs/ocl-icd/Manifest
+++ b/dev-libs/ocl-icd/Manifest
@@ -1,3 +1,2 @@
DIST ocl-icd-2.2.12.tar.gz 80718 BLAKE2B 524f9eea9782323eafa2f41858c4970333c029898c651bbf15624331e184d1b439d2259532b02defd67c9ab434a35b1b9a64a28e1515b3f42f09b3a270975df7 SHA512 f1668c3a39ecfbc089ee5a5f61f44ceb86ab80e504e58064dec306ce907daf77936c5403b4af15ed8714068891d68346c86725f285cfbc90c4fcb35d18db4048
-DIST ocl-icd-2.2.14.tar.gz 100629 BLAKE2B 4862560541c979edb06d89f7f57b78a34c02e38843c02b0f125a121649cd6a33570e29c86fe7d3fd6f0fa3d489831777100daef97264e32b82854384075cbbf2 SHA512 78510b6fa4e2c6a52141a51ccf0d0ef3110b0b4902a43bb97f7622ff0ce470b108dc05c9619c28ce8758ccea1e1cf6b2e7f1a296f8b07f52532f23b2b036a5cf
DIST ocl-icd-2.3.0.tar.gz 100848 BLAKE2B b9e5b78df63f4865bb4cb3623fbc6bd336c86b4a9e1f23a29fab1cf11f848cb20d6d8d4a480ff44e442b02d606247a923798143058256ef59c2b16c9daf7098d SHA512 003f3661b7086a7364e79d1058591f12a7095aa2c3decfc4b496f00a0863a91cd81080f33b9308e3948045f8aca5856868ed2725f478654230e51a60d654e613
diff --git a/dev-libs/ocl-icd/ocl-icd-2.2.14-r1.ebuild b/dev-libs/ocl-icd/ocl-icd-2.2.14-r1.ebuild
deleted file mode 100644
index 909ba9498eaf..000000000000
--- a/dev-libs/ocl-icd/ocl-icd-2.2.14-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-inherit autotools flag-o-matic multilib-minimal ruby-single
-
-DESCRIPTION="Alternative to vendor specific OpenCL ICD loaders"
-HOMEPAGE="https://github.com/OCL-dev/ocl-icd"
-SRC_URI="https://github.com/OCL-dev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Does nothing now but by keeping it here we avoid having to have virtual/opencl
-# handle ebuilds both with and without this flag.
-IUSE="+khronos-headers"
-
-BDEPEND="${RUBY_DEPS}"
-DEPEND=">=dev-util/opencl-headers-2020.12.18"
-RDEPEND="${DEPEND}
- !app-eselect/eselect-opencl
- !dev-libs/opencl-icd-loader"
-
-src_prepare() {
- replace-flags -Os -O2 # bug 646122
-
- default
- eautoreconf
-}
-
-multilib_src_configure() {
- # dev-util/opencl-headers ARE official Khronos Group headers, what this option
- # does is disable the use of the bundled ones
- ECONF_SOURCE="${S}" econf --enable-pthread-once --disable-official-khronos-headers
-}
-
-multilib_src_compile() {
- local candidates=(${USE_RUBY})
- local ruby=
- for (( idx=${#candidates[@]}-1 ; idx>=0 ; idx-- )) ; do
- if ${candidates[idx]} --version &> /dev/null; then
- ruby=${candidates[idx]} && break
- fi
- done
- [[ -z ${ruby} ]] && die "No ruby executable found"
-
- emake RUBY=${ruby}
-}
-
-multilib_src_install() {
- default
-
- # Drop .la files
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/dev-libs/ocl-icd/ocl-icd-2.2.14.ebuild b/dev-libs/ocl-icd/ocl-icd-2.2.14.ebuild
deleted file mode 100644
index e5b4c9f26236..000000000000
--- a/dev-libs/ocl-icd/ocl-icd-2.2.14.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-inherit autotools flag-o-matic multilib-minimal ruby-single
-
-DESCRIPTION="Alternative to vendor specific OpenCL ICD loaders"
-HOMEPAGE="https://github.com/OCL-dev/ocl-icd"
-SRC_URI="https://github.com/OCL-dev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Does nothing now but by keeping it here we avoid having to have virtual/opencl
-# handle ebuilds both with and without this flag.
-IUSE="+khronos-headers"
-
-BDEPEND="${RUBY_DEPS}"
-DEPEND=">=dev-util/opencl-headers-2020.12.18"
-RDEPEND="${DEPEND}
- !app-eselect/eselect-opencl
- !dev-libs/opencl-icd-loader"
-
-src_prepare() {
- replace-flags -Os -O2 # bug 646122
-
- default
- eautoreconf
-}
-
-multilib_src_configure() {
- # dev-util/opencl-headers ARE official Khronos Group headers, what this option
- # does is disable the use of the bundled ones
- ECONF_SOURCE="${S}" econf --enable-pthread-once --disable-official-khronos-headers
-}
-
-multilib_src_install() {
- default
-
- # Drop .la files
- find "${ED}" -name '*.la' -delete || die
-}