summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-28 15:59:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-28 16:05:40 +0200
commit3386db3ead980706cdaaff40510a85bae5734d2b (patch)
treefddbba80e85b2e9056602b5be257c14d1e227946
parentdev-python/accessible-pygments: Enable py3.12 (diff)
downloadgentoo-3386db3ead980706cdaaff40510a85bae5734d2b.tar.gz
gentoo-3386db3ead980706cdaaff40510a85bae5734d2b.tar.bz2
gentoo-3386db3ead980706cdaaff40510a85bae5734d2b.zip
dev-python/aiohttp-cors: Fix running async tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aiohttp-cors/Manifest2
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild18
2 files changed, 13 insertions, 7 deletions
diff --git a/dev-python/aiohttp-cors/Manifest b/dev-python/aiohttp-cors/Manifest
index 4912de93657a..047e1846cfd0 100644
--- a/dev-python/aiohttp-cors/Manifest
+++ b/dev-python/aiohttp-cors/Manifest
@@ -1 +1 @@
-DIST aiohttp-cors-0.7.0.tar.gz 39728 BLAKE2B 747499856272f551cf8e2e0911ff7cbb2c7cb8a1f3159327dd8f0d40cabbbd9713a1a9e30ef9c99f3f9642567c99025e049db837c89f907d6698a27005ac2632 SHA512 72e0b365b952c08a02c1123d7672cfea01063e2ff01743a71e10f804d22178edc0f1c6b7f87b7ed484ca7c24e89a32de90d0d279f2f5c060427319182f9bdd3b
+DIST aiohttp-cors-0.7.0.gh.tar.gz 39728 BLAKE2B 747499856272f551cf8e2e0911ff7cbb2c7cb8a1f3159327dd8f0d40cabbbd9713a1a9e30ef9c99f3f9642567c99025e049db837c89f907d6698a27005ac2632 SHA512 72e0b365b952c08a02c1123d7672cfea01063e2ff01743a71e10f804d22178edc0f1c6b7f87b7ed484ca7c24e89a32de90d0d279f2f5c060427319182f9bdd3b
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
index 152bc5045683..46a27617638b 100644
--- a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
@@ -4,13 +4,19 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
-HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
-SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/aio-libs/aiohttp-cors/
+ https://pypi.org/project/aiohttp_cors/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohttp-cors/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
@@ -36,7 +42,7 @@ PATCHES=(
"${FILESDIR}/${P}-py3_11.patch"
)
-src_prepare() {
- sed -i -e '/^addopts=/d' setup.cfg || die
- distutils-r1_src_prepare
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p aiohttp -p asyncio --asyncio-mode=auto
}